Table of Contents

Introduction ................................................................................................................................................ 5

Components of SmartFusion2 Device Used ................................................................................................... 6

Tutorial Requirements ......................................................................................................................................... 6

Software Requirements ..........................................................................................................................................6

Hardware Requirements ........................................................................................................................................6

Extracting the source files ............................................................................................................................ 7

Step 1 – Creating a Libero SoC Project .......................................................................................................... 7

Launching Libero SoC..............................................................................................................................................7

Checking Tool Profiles and IP Cores.........................................................................................................................7

Creating the Libero SoC Project...............................................................................................................................8

Step 2 – Configuring the SmartFusion2 MSS with System Builder................................................................. 9

Step 3 – Constraining the Design................................................................................................................ 26

Importing an IO Constraint file..................................................................................................................................26

Generating Timing Constraints............................................................................................................................................27

Step 4 – Synthesis, Layout and Programming ............................................................................................ 29

Configuring the SmartFusion2 SMF2000 board ......................................................................................................29

Running the Tcl script ........................................................................................................................................... 30

Step 5 – Running the Application ............................................................................................................... 31

Step 6 – Generating Sample Projects and Exporting the Firmware Configuration Files ......................... 32

Generating sample projects..................................................................................................................................32

Exporting firmware configuration files and firmware drivers .................................................................................37

Step 7 - Debugging with SoftConsole v6.0 .................................................................................................. 40

Running the CorePWM slow blink application .........................................................................................................40

Confirming the SoftConsole v6.0 Project Settings .................................................................................................47

Building the Project..............................................................................................................................................51

Debugging with SoftConsole .................................................................................................................................51

Step 8 - Running the RTC_time application (time permitting).................................................................... 60

Step 9 - Debugging code running from the SmartFusion2 eNVM .................................................................. 64

Building the project with the Release build configuration ......................................................................................65

List of Figures ............................................................................................................................................ 69
Introduction

This tutorial demonstrates how to implement a basic SmartFusion2 Microcontroller Subsystem (MSS) configuration that includes the GPIO, MMUART_0, the RTC and a soft PWM (CorePWM) in the SmartFusion2 fabric using System Builder.

The SmartFusion2 GPIO[8] will be configured as an input. GPIO[8] will be connected to one of the switches on the SmartFusion2 SMF2000. The fabric PWM[8:1] will be configured as 16 bit PWM; outputs will drive LEDs on the SmartFusion2 SMF2000;

After completing this tutorial you will be familiar with the following:

- Using a Tcl script to create a Libero SoC project
- Using System Builder to configure the SmartFusion2 MSS, add fabric peripherals and generate the design
- Constraining the design for synthesis and layout
- Synthesize the SmartFusion2 design with Synplify Pro ME
- Run layout
- Generate a bitstream
- Program the SmartFusion2 silicon on the SMF2000 board
- Creating firmware configuration files and Sample projects from Libero SoC
- Using SoftConsole v6.0 to create and debug SmartFusion2 applications

Online Reference Manual:

https://wiki.trenz-electronic.de/display/PD/TEM0001+TRM

Schematics:

http://www.trenz-electronic.de/fileadmin/docs/Trenz_Electronic/Modules_and_Module_Carriers/2.5x6.15/TEM0001/REV01/Documents/SCH-TEM0001-01-010C.PDF
Components of SmartFusion2 Device Used
This tutorial uses the SmartFusion2 Cortex-M3, the MSS GPIO block, MMUART_0, the RTC and the FPGA fabric.

Tutorial Requirements

Software Requirements
- Microsemi Libero SoC v12.0
- Synplify Pro ME N-2018.03M-SP1-1
- Identify ME Identify N-2018.03M-SP1
- FlashPro Express v12.0
- Microchip SoftConsole v6.0

SmartFusion2 MSS Component versions
The table below lists the version of the SmartFusion2 MSS which must be used.

<table>
<thead>
<tr>
<th>Libero SoC Version</th>
<th>SmartFusion2 MSS version</th>
<th>System Builder</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.0</td>
<td>1.1.500</td>
<td>1.0</td>
</tr>
</tbody>
</table>

| Table 1 – SmartFusion2 MSS component versions |

Hardware Requirements
This tutorial targets the Arrow and Trenz Board SMF2000 with SmartFusion2 on it. The free Libero SoC Silver license can be used for this tutorial.
Extracting the source files
Use ArrowTraining.zip to extract the required lab files to $C:/ArrowTraining/$ on the HDD of your PC. Confirm that a folder named ArrowTraining containing 3 sub-folders named constraints, Hex_file and Script were extracted.

Step 1 – Creating a Libero SoC Project
In this step, you will create a Libero SoC v12.0 project.

Launching Libero SoC
1. Click Start > Programs > Microsemi Libero SoC v12.0 > Libero SoC v12.0, or click the shortcut on your desktop. The Libero SoC Project Manager will open.

![Libero SoC Project Manager](image)

Checking Tool Profiles and IP Cores
2. Click Project > Tool Profiles from the Libero SoC menu to open the Tool Profiles dialog box. Verify that the following tool profiles exist:
   - Synthesis: Synplify Pro ME contained in $<Libero_v12.0_installation>/SynplifyPro/bin/synplify_pro.exe$
   - Simulation: ModelSim ME contained in $<Libero_v12.0_installation>/Modelsim/win32acoem/modelsim.exe$
   - Programming: FPExpress contained in $<Libero_v12.0_installation>/Designer/bin/FPExpress.exe$

3. Click OK to close the Tool Profiles dialog box.
4. Open the Libero SoC IP catalog (View > Windows > Catalog). If the message New Cores are available appears at the bottom of the catalog, click Download them now to download the cores.

![Image of IP Catalog indicating new cores are available]

**Figure 3 - IP Catalog indicating new cores are available**

**Creating the Libero SoC Project**

Use the Tcl script contained in the Scripts folder to create the Libero SoC project.

5. Select **Project > Execute Script** from the Libero SoC menu. The Execute Script dialog box will open.

6. Click the Browse button ( ) to open the Select the script file dialog.

7. Navigate to the C:/ArrowTraining/Scripts folder. Select **Project_creation.tcl** then click **Open**.

8. Click **Run** in the Execute Script dialog box to execute the script.

![Image of Execute Script dialog box]

**Figure 4 - Executing the project creation script**

9. The script execution report will appear as shown below indicating successful execution of the script.

**Step 2 – Configuring the SmartFusion2 MSS with System Builder**

In this step, you will configure the SmartFusion2 Microcontroller Subsystem (MSS) using System Builder.

1. Select the Libero SoC Design Flow tab. Expand Create Design and double-click System Builder.

2. Enter SF2_MSS when prompted for a name for your system.
3. System Builder will open with the “System Builder - Device Features” page visible as shown below.

![Figure 8 – SmartFusion2 System Builder Device Features page](image)

4. Enter the following on the “System Builder - Device Features” page:

   - **Memory**
     - MSS External Memory un-checked (default)
     - MSS On-chip Flash Memory (eNVM) checked
   - **Microcontroller Options**
     - Watchdog Timer un-checked (default)
     - Peripheral DMA un-checked (default)
     - Real Time Counter checked
5. Click **Next**. The “System Builder – Memory” page will open.
6. Double-click Data Storage under Available client types (highlighted in the figure above) then click **Add to System**. This will create a partition in the SmartFusion2 Embedded Non-volatile memory (eNVM) which will be used to store the Cortex-M3 application program.

7. Enter the following in the Add Data Storage Client dialog box:
   - **Client name**: PGM_store
   - **Content**:
     - Click the browse button to open the Import Memory File dialog box.
     - Navigate to the C:/ArrowTraining/Hex_file folder
     - Select Arrow_pwm_demo_eNVM.hex and Use relative path from project directory, then click **Open**

![Figure 11 - Selecting the hex file for the data storage client](image)

8. The Add Data Storage Client dialog box will appear as shown in the figure below. Click **OK** to close the Add Data Storage Client dialog box.

![Figure 12 - Data Storage Client dialog box after importing the hex file](image)
9. The client will be visible in the System Builder Memories page.

![System Builder Memories page after adding the data storage client](image)

Figure 13 - System Builder Memories page after adding the data storage client

10. Click **Next**. The “System Builder – Peripherals” page will open. Here you can enable or disable MSS peripherals and add fabric peripherals. Configure peripherals by clicking the wrench symbol ( ). The number of fabric peripherals used can be changed by editing the number in the Quantity column.
11. Disable the MM_UART_1, MSS_I2C_0, MSS_I2C_1, MSS_SPI_0 and MSS_SPI_1 peripherals by clicking the box in the Enable column.

12. Double-click the wrench symbol (🔧) next to the MM_UART_0 peripheral to open the MM_UART_0 Configurator. Use the pull-down menu to Connect to the IO. Click OK to close the configurator.
13. Enable the MSS_GPIO peripheral by clicking the box under the Enable column.

14. Double-click the wrench symbol (🔧) next to the MSS_GPIO peripheral to open the MSS GPIO Configurator. Configure the GPIOs as shown below:
   - Set/Reset Definition: accept default settings
   - Configure GPIO[31:0] per the table below:

<table>
<thead>
<tr>
<th>GPIO ID</th>
<th>Direction</th>
<th>Package Pin</th>
<th>Connectivity</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPIO[0:7]</td>
<td>Not Used</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>GPIO_8</td>
<td>Input</td>
<td>NA</td>
<td>FABRIC_A</td>
</tr>
<tr>
<td>GPIO_[9:31]</td>
<td>Not Used</td>
<td>NA</td>
<td>NA</td>
</tr>
</tbody>
</table>

Table 3 – SmartFusion2 GPIO configuration

15. Click OK to close the MSS GPIO configurator.

16. Drag an instance of CorePWM from the Fabric Slave Cores to the MSS FIC_0 - MSS Master Subsystem. This will add a soft PWM core in the FPGA fabric which will be connected to FIC_0.
17. Click the wrench symbol (🔧) next to corepwm_0 in the MSS FIC_0 - MSS Master Subsystem to open the CorePWM configurator. Enter the following in the Configuring corepwm_0 dialog box.

- **Global Configuration**:
  - Configuration Mode: 0 - PWM Only Mode (default)
  - Number of PWM Channels: 8
  - APB Data Bus Width / Resolution: 16

- **Global PWM Mode Configuration**:
  - Fixed Prescale: un-checked
  - Fixed Value: 0 (default)
  - Fixed Period: un-checked (default)

- **Channel 1 Configuration**: accept the default settings
- **Channel 2 Configuration**: accept the default settings

18. Click **OK** to close the CorePWM configuration dialog box.
18. Click **Next**. The “System Builder – Clocks” page will open. Use this page to specify the clock source and clock frequencies used in the design. Enter the following:

- **System Clock**: Select On-chip 25/50 MHz RC Oscillator from the pull-down menu
- **M3_CLK**: 100 MHz
- **APB_0 CLK**: M3_CLK/1 (100 MHz) (default)
- **APB_1 CLK**: M3_CLK/1 (100 MHz) (default)
- **FIC_0_CLK**: M3_CLK/2 (50 MHz)

These frequencies were chosen to maximize the speed of the Cortex-M3 microcontroller.
19. Click **Next**. The “System Builder - Microcontroller” page will open. This page has multiple tabs, which allow configuring the Cortex-M3 microcontroller, the Cache Controller and the AHB Bus Matrix.
20. Select the Real Time Counter tab in the System Builder - Microcontroller pane. This is where options for the RTC are set.

21. Select the On-chip 1 MHz RC Oscillator as the RTC clock source from the pull-down menu in the Clock Source field on the Real Time Counter tab. This option matches the RTC sample projects available in the Firmware Catalog.

22. Accept the default settings for the Wakeup Interrupt and the RTC_MATCH signal.
23. Although we won’t be making any other changes, take a moment to become familiar with the contents of each tab.
24. Click **Next** to accept the default settings on the Microcontroller page.
25. The “System Builder – SECDED” (Single Error Correct / Double Error Detect) page will open. Use this page to enable SECDED for various memory blocks within the SmartFusion2 MSS. Although we won’t be using SECDED for this design, take a moment to become familiar with the contents of this page.
26. Accept the default settings on the page and click **Next**.
27. The “System Builder – Security” page will open. This page is used to set the Master to Slave Read/Write access for devices that support Data Security features. The SmartFusion2 devices on the SMF2000 kit does not support these security features, so these options will be grayed out.
28. Click **Next** to accept the default settings.
29. The “System Builder – Interrupts” page will open. This page displays interrupt connections generated from attached fabric peripherals. The CorePWM TACHINT interrupt will be visible as shown in the figure below.
30. Click **Next**. The “System Builder – Memory Map” page will open. This page displays the addresses of fabric peripherals. The address of CorePWM will be visible. Up to six different memory regions can be assigned to each FIC in the MSS memory map. In this design, two memory regions (0x30000000 and 0x50000000) are assigned to FIC_0 for the interface to the FPGA fabric and CorePWM.
31. Click Finish.

32. Confirm that the message “System_sb” was generated successfully appears in the Libero SoC Message tab.

33. A component named SF2_MSS_sb_0 will be visible in the SmartDesign canvas as shown below. If necessary, click the SF2_MSS tab to display the SmartDesign canvas.
34. Connect the FAB_RESET_N port to VCC by selecting the port, right-clicking and selecting **Tie High**.

35. If necessary, click the + sign next to corepwm_0_0_PINS to expand the pin group. Promote the PWM[8:1] port to the top level by selecting the port, right-clicking and selecting **Promote to Top Level**. These outputs will drive LEDs on the target board. Connect the TACHIN[1] port to GND by selecting the port, right-clicking and selecting **Tie Low**.

36. Mark the POWER_ON_RESET_N and MSS_READY output ports unused by selecting the port, right-clicking and selecting **Mark Unused**.

37. If necessary, click the + sign next to FAB_CCC_PINS to expand the pin group. Mark the FAB_CCC_GL0 and FAB_CCC_LOCK pins unused. These pins are not used in the design.
38. If necessary, click the + sign next to GPIO_FABRIC to expand the pin group. Promote the GPIO_8_F2M port to the top level by selecting the port, right-clicking and selecting **Promote to Top Level**. The GPIO_8_F2M port will connect to a switch on the SMF2000 board.

39. If necessary, click the + sign next to the INIT_PINS output port to expand the group. Mark the INIT_DONE output port unused.

40. After making the pin connections the **SF2_MSS_sb_0** component will look like the figure below.

![Figure 28 – SF2_MSS_sb_0 component after making pin connections](image)

41. Generate the design by clicking **SmartDesign > Generate Component** or by clicking the Generate Component icon on the SmartDesign toolbar ( ).

42. The message “‘SF2_MSS’ was generated successfully” will appear in the Libero SoC Message window indicating the design was generated without any errors.

![Figure 29 - Libero SoC Message window after generating the design](image)

40. Close the design (**File > Close SF2_MSS**).
Step 3 – Constraining the Design

Importing an IO Constraint file

There are multiple ways to make I/O Assignments. In this lab, we will use the I/O Physical Design Constraint (PDC) file that is provided in the lab source files.

1. Expand Constraints in the Libero Design Flow window and double-click Manage Constraints.

![Figure 30 - Opening the Constraint Editor](image)

2. The Enhanced constraint manager will open.

![Figure 31 - Libero SoC Enhanced Constraint Manager](image)

3. Click Import on the I/O Attributes tab to open the Import Files dialog box. Navigate to the `<C: or D:>\ArrowTraining\constraints` folder. Select `io_constraints.pdc` then click Open.
4. The file will be visible on the I/O Attributes tab of the Constraint Manager.

5. Double-click io_constraints.pdc to open the file in the Libero SoC text editor. Scroll in the file to become familiar with the syntax. The constraint set_io sets the pin number and I/O specific attributes. The # symbol is a comment.

6. Close the editor (File > Close io_constraints.pdc).

7. Check the box under Place and Route for constraint\io\io_constraints.pdc the I/O Attributes tab to use the PDC constraint file for layout.

**Generating Timing Constraints**

In this step, you derive timing constraints for the design. Libero can generate timing constraints for known blocks (such as the RC oscillators and the PLLs) automatically.

7. Select the Timing tab in the Constraint manager window. Double-click **Derive Constraints**.

8. Click on **Yes** in the Message window to automatically associate the derived constraints SDC file to the ‘Synthesis’, ‘Place and Route’ and ‘Timing Verification’.
9. A constraint file named SF2_MSS Derived_constraints.sdc will be visible. Double-click on the file name to open the file in the Libero text editor.
Step 4 – Synthesis and Layout

In this step, you will use the push-button flow to synthesize the design with Synplify Pro, run layout and generate the programming file.

1. Double-click the Generate Bitstream in the Design Flow window to synthesize the design, run layout using the I/O constraints that were created and generate the programming file.

![Design Flow window with Generate Bitstream highlighted](image-url)

*Figure 37 - Generate Bitstream*
The design implementation tools will run in batch mode. Successful completion of a design step will be indicated by a green check mark next to the Implement Design item in the Design Flow window.

Figure 38 - Successful completion of design implementation
2. The Reports tab will display reports for the tools used to implement the design.

![Project Summary](image1)


4. Run program action

![Run program action](image2)

**Step 5 – Running the Application**

The next step is to observe the operation of the Cortex-M3 program in the design.

**Determining the COM port setting**

This design requires a terminal emulator. In order to configure the terminal emulator, the COM port assignment must be determined.

1. Open the Windows Device Manager and expand the Ports (COM & LPT) section.
   - One port will be listed as “FlashPro 5 Port”. Record the COM port number below.

   USB Serial Port: COM_______
2. Open a terminal emulator program such as TeraTerm or PuTTY and configure a Serial terminal as follows:
   - Port: Select the COM port number recorded above.
   - Baud rate: 115200
   - Data Bits: 8
   - Parity: None
   - Stop Bits: 1
   - Flow Control: None


4. The LEDs should appear as follows:
   - LED D9 to LED D2 – gradually get dimmer and brighter. The PWM core in the FPGA fabric drives these LEDs.

Step 6 – Generating Sample Projects and Exporting the Firmware Configuration Files

In this step, you will generate sample projects and export the firmware configuration files for the design.

Generating sample projects

2. The DESIGN FIRMWARE tab will open.

3. Confirm that none of the drivers appears in italics. If any drivers appear in italics, click the check box in the Generate column for the missing core. Click Yes when prompted about downloading the core.

4. Click Yes in the Download Required dialog box to download any firmware cores that are missing from the IP vault.

5. Use the pull-down menu in the SmartFusion2_CMSIS_0 row to select version 2.3.105 if it is not selected.
6. Create the CorePWM sample project by selecting CorePWM_Driver_0 on the DESIGN FIRMWARE tab, then right clicking and selecting Generate Sample Project > Cortex-M3 > SoftConsole v4.0 > PWM slow blink. Note that SoftConsole v4.0 projects can be opened in SoftConsole v6.0.

7. Confirm the following settings in the Generate Sample Options dialog box then click OK:
   - Folder: C:\ArrowTraining\SF2-M3_BaseDesign\SoftConsole
   - Show generation report: checked

8. The Report dialog box will list all the files generated and the location.
9. Click **Close** to close the Report window.
10. Create the MSS RTC sample project by selecting SmartFusion2_MSS_RTC_Driver_0 on the DESIGN FIRMWARE tab, then right clicking and selecting **Generate Sample Project > Cortex-M3 > SoftConsole v4.0 > RTC Time**.

11. Confirm the following settings in the Generate Sample Options dialog box then click **OK**:
   - **Folder**: C:\ArrowTraining\SF2-M3_BaseDesign\SoftConsole
   - **Show generation report**: checked
12. The Report dialog box will list all the files generated and the location.

![Generate Sample Options dialog box](image)

**Figure 48 – RTC Time sample project location**

13. Click **Close** to close the Report window.

![Report window](image)

**Figure 49 - RTC_time project files**
14. Close the DESIGN Firmware tab (File > Close DESIGN Firmware). Select Yes if prompted about saving changes to DESIGN_FIRMWARE.

Exporting firmware configuration files and firmware drivers

The firmware used in a SoftConsole project must match the target hardware configuration. For SmartFusion2 projects, Libero SoC generates specific firmware files that are required to ensure that the SoftConsole project matches and is compatible with the target hardware. The sample projects created in the previous step contain generic firmware files that may not match the target hardware. In this step, you will export firmware configuration files that match the design configuration.

15. Select Export Firmware under Handoff Design for Firmware Development on the Design Flow tab, then right-click and select Export Firmware... to create the firmware drivers for the design.

16. Enter the following in the Export Firmware dialog box then click OK:
   - Location: Accept the default location
   - Software IDE: select SoftConsole4.0 from the pull-down menu
   - Export hardware configuration: Checked
17. Click **OK** in the dialog box that indicates the location of the firmware cores.

18. The firmware drivers will be visible on the Libero SoC Files tab. The Project for selected toolchain and the sample projects will be visible on the Files tab in the SoftConsole folder. If the projects are not visible, select **View > Refresh Design Hierarchy** from the Libero SoC menu.
19. The Data Sheet containing the memory map will be visible in the Libero SoC Report tab.

20. Scroll in the SF2_MSS data sheet and become familiar with the Generated Files, Firmware and Memory Map sections (click on the hyperlink at the top of the data sheet to move to the section of interest).
21. Select the Memory Map to become familiar with the locations of the peripherals.

What is the address of MMUART_0? ________________

What is the address of corepwm? ________________

22. Minimize Libero SoC.

**Step 7 - Debugging with SoftConsole v6.0**

**Running the CorePWM slow blink application**

In this step, you will launch SoftConsole v6.0, import the sample projects created from Libero SoC and run the CorePWM slow blink application from the SmartFusion2 eSRAM.

1. Click **Start > Programs > Microsemi > SoftConsole v6.0**, or click the shortcut on your desktop. The SoftConsole 6.0 Workspace Launcher may open as shown below.

![Figure 55 - SoftConsole 6.0 Workspace Launcher (location shown may differ)](image)

2. Click the browse button SoftConsole in the Workspace Launcher and navigate to C:\ArrowTraining\SF2-M3_BaseDesign\SoftConsole then click **Select Folder**.
3. Click **Launch** in the Eclipse Launcher to open the SoftConsole GUI.

4. The SoftConsole v6.0 GUI will open.
If the workspace launcher did not open, select **File > Switch Workspace > Other** and navigate to the workspace location shown on the previous page.

**Importing the CorePWM slow blink and RTC Time SoftConsole Projects**

5. Import the SoftConsole Projects by selecting **File > Import** from the SoftConsole menu. The Import dialog box will open. Expand General and select **Existing Projects into Workspace** then click **Next**.
6. Enter the following in the Import Projects dialog box then click **Finish**:

- **Select root directory**: Browse to C:\ArrowTraining\SF2-M3_BaseDesign\SoftConsole. Click **Select Folder** in the Select Folder dialog box.
- **Projects**: SF2_GNU_SC4_pwm_slow_blink and SF2_GNU_SC4_RTC_time checked
- **Options**:
  - Search for nested projects: un-checked
  - Copy projects into workspace: un-checked
  - Close newly imported projects upon completion: un-checked
  - Hide projects that already exist in the workspace: un-checked

![Import Projects Dialog](image)

**Figure 60 - Importing the sample projects into the workspace**

7. The SoftConsole projects will be visible in the SoftConsole Project Explorer.
8. Close the SF2_GNU_SC4_RTC_time project by selecting the project name in the Project Explorer then right-clicking and selecting **Close Project**.

**Importing the firmware configuration files**

9. Import the firmware configuration files that were exported from Libero SoC into the SF2_GNU_SC4_pwm_slow_blink project by selecting SF2_GNU_SC4_pwm_slow_blink in the Project Explorer then selecting **File > Import** from the SoftConsole menu. The Import dialog box will open.

10. Expand the General category in the Import dialog box and select **File System** and then click **Next**.
11. The File system dialog box will open. Click the **Browse** button. Navigate to the C:\ArrowTraining\SF2-M3_BaseDesign\firmware folder and click **Select Folder**.

12. Enter the following in the File system dialog box:
   - From directory:
     C:\ArrowTraining\SF2-M3_BaseDesign\firmware .
   - Select
     - Click next to the firmware folder in the left window pane to expand it (circled in the figure below)
     - Select the following:
       - CMSIS
       - drivers
       - drivers_config
       - hal
   - Into Folder: SF2_GNU_SC4_pwm_slow_blink

![Figure 63 - Importing the firmware configuration files into the project](image1)

13. Click **Finish**. Click **Yes To All** in the Question dialog box when prompted about Overwriting files.

![Figure 64 - Question dialog box](image2)

14. The project should appear in the Project Explorer as shown in the figure below.
15. Double click main.c in the Project Explorer window to open the file in the SoftConsole C/C++ editor. Scroll through the file to become familiar with it.

```c
/*
(c) Copyright 2015 Microsemi SoC Products Group. All rights reserved.

This example project demonstrates control of individual PWM outputs.
Please refer to the file README.txt for further details about this example.

SVN $Revision: 8042 $
SVN $Date: 2015-10-15 17:55:12 +0530 (Thu, 15 Oct 2015) $
*/
#include "platform.h"
#include "core_pwm.h"

#define DELAY_COUNT 10000

/* PWM prescale and period configuration values.
#define PWM_PRESCALE 8
#define PWM_PERIOD 100

/* CorePWM instance data.

pwm_instance_t the_pwm;
```

16. Double click platform.h in the Project Explorer window to open the file in the SoftConsole C/C++ editor. Compare the COREPWM_BASE_ADDR on line 16 to the address recorded on page 39. Modify and save the file if necessary.
Confirming the SoftConsole v6.0 Project Settings

The next steps to confirm the sample project settings prior to performing a build. SoftConsole supports multiple build configurations. By default, projects contain two build configurations: Debug and Release. Some project settings apply to all build configurations while others apply to a specific build configuration.

17. Open the Project Properties dialog box by clicking on the project name (SF2_GNU_SC4_pwm_slow_blink) in the Project Explorer and selecting Project > Properties.

18. Navigate to C/C++ Build > Settings in the Properties for SF2_GNU_SC4_pwm_slow_blink dialog box.
Select different Build configurations by using the pull-down menu in the Configuration field of the Project Properties dialog box (highlighted in the figure above). Some project settings are applicable to all build configurations while others are for a specific build configuration.

19. Select *Configuration = [All configurations]* to configure settings applicable to both the Debug and Release build targets.

![Figure 69 - Selecting all build configurations](image)

20. Select *Cross ARM C Compiler > Includes* on the Tool Settings tab. Confirm that the Include paths (-I) field contains the following:

- ../drivers_config/sys_config
- ../drivers/CorePWM
- ../CMSIS
- ../hal/CortexM3/GNU
- ../hal/CortexM3
- ..
- ../hal

![Figure 70 - Project Include paths](image)

If necessary, add or modify the Include paths by clicking the Add directory path button ( ) or the Edit directory path button ( ).

21. SmartFusion2 projects require a setting in order for the preprocessor to find the toolchain CMSIS header files. Select *Cross ARM C Compiler > Miscellaneous* on the Tool Settings tab. Confirm that the Other compiler flags field contains *--specs=cmsis.specs*.

![Figure 70 - Project Include paths](image)
The appropriate linker script must be configured for the project build configuration. The sample projects include linker scripts bundled with the CMSIS/HAL firmware core. Follow the steps below to confirm the linker script setting for the Debug and Release build configurations.

22. Select **Configuration = Debug [Active]** from the pull-down menu in the Configuration field of the Project Properties dialog box.

23. Select **Cross ARM C Linker > General** on the Tool Settings tab of the Project Properties dialog box. Confirm that the Script files (-T) contains `..//CMSIS/startup_gcc/debug-in-microsemi-smartfusion2-esram.ld`. This linker script builds an application that runs from the SmartFusion2 eSRAM.
24. Select **Configuration = Release** from the pull-down menu in the Configuration field of the Project Properties dialog box.

25. Select **Cross ARM C Linker > General** on the Tool Settings tab of the Project Properties dialog box and confirm that the Script files (-T) field contains `../CMSIS/startup_gcc/debug-in-microsemi-smartfusion2-envm.ld`. This linker script builds an application that runs from the SmartFusion2 eNVM.

26. After confirming the settings listed in the previous steps, click **Apply and Close** in the Properties for SF2_GNU_SC4_pwm_slow_blink dialog box.
Building the Project
After configuring the project settings, the next step is to build the project. The build configuration may need to be set prior to building the project.

27. Select SF2_GNU_SC4_pwm_slow_blink in the Project Explorer then and select Project > Build Configurations > Set Active. Confirm that a check mark appears next to Debug indicating it is the selected build configuration. If necessary click Debug.

28. With the project name still selected in the Project Explorer, select Project > Build All or by clicking the Build All icon ( ) on the SoftConsole toolbar to build the project. The results of the build process can be viewed in the Console view and the Problems view. Confirm that there are no errors or warnings in the Problems view.

Debugging with SoftConsole
After building the project, the next step is to use the SoftConsole debugger to run the application on the SmartFusion2 Cortex-M3. Before using the On-chip Debugger (OCD), the debug launch configuration must be created.
Creating a debug launch configuration

29. Select SF2_GNU_SC4_pwm_slow_blink in the SoftConsole Project Explorer View.

30. Select Run > Debug Configurations... from the SoftConsole menu. The Debug Configurations dialog will open.

31. Select GDB OpenOCD Debugging in the Debug Configurations dialog box then right-click and select New Configuration to create a new debug launch configuration for the Debug build configuration.

32. Ensure that the C/C++ Application field on the Main tab of the Debug Configurations dialog box contains Debug\SF2_GNU_SC4_pwm_slow_blink.elf.

33. Select the Debugger tab of the Debug Configurations dialog box. The Config Options field must contain the correct command line options/script to be passed to OpenOCD.
34. Enter `--command "set DEVICE M2S010" --file board/microsemi-cortex-m3.cfg` in the Config Options field.
---

--command "set DEVICE M2SXXX" specifies the target device. This line needs to be modified based on the target silicon.
---

--file board/microsemi-cortex-m3.cfg is a board script that supports SmartFusion2 programs that target eSRAM or eNVM.

35. Scroll to the GDB Client Setup field on the Debugger tab. Confirm that the following appear:
- **Executable:** `${cross_prefix}gdb${cross_suffix}
- **Commands:** `set mem inaccessible-by-default off`. If necessary, delete the lines "set arch riscv:rv32" and "set riscv use_compressed_breakpoints no"

![Figure 78 - SoftConsole v6.0 Debugger tab settings for the SmartFusion2 SMF2000 kit](image)

36. Select the Startup tab and confirm that the default settings are configured as shown in the figure below.
37. Click **Apply** to save the changes.

38. Click **Debug** to launch the Debugger. Click **Switch** in the **Confirm Perspective Switch** dialog box. The SoftConsole Debug perspective will open. The code will be downloaded to the SmartFusion2 SMF2000 board. The program will be suspended at the first line of main() as shown in the figure below.
Running the pwm_slow_blink Application

39. Start the Cortex-M3 software application by clicking Run > Resume from the SoftConsole menu. The LEDs will appear as shown in the table below.

<table>
<thead>
<tr>
<th>LED</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>LED D2</td>
<td>On</td>
</tr>
<tr>
<td>LED D3</td>
<td>Toggle On/Off</td>
</tr>
<tr>
<td>LED D4, D5, D6, D7</td>
<td>Off</td>
</tr>
<tr>
<td>LED D8, D9</td>
<td>On</td>
</tr>
</tbody>
</table>

Table 2 – SMF2000 board LED states

40. Suspend the software application by clicking Run > Suspend from the SoftConsole menu or by clicking the Suspend icon ( ) on the SoftConsole Toolbar.
41. Open the Registers view (Window > Show View > Registers).
42. Select the Registers view on the lower window pane to view the value of the Cortex-M3 internal registers as shown in the figure below. Your values may differ. If the Registers view is not visible, open it by selecting Window > Show View > Registers.

43. Choose Window > Show View > Disassembly to display the assembly level instructions. The Disassembly window will open on the right side in the middle of the Debug perspective as shown in the figure below.
Figure 82 – SoftConsole Disassembly view

44. Scroll in main.c and locate PWM_PERIOD on line 24.

Figure 83 - PWM_PERIOD in main.c

45. Changing the value of PWM_PERIOD on line 24 will change the toggle rate of the LED. Try changing the value then save the file (File > Save). A larger value for the period will make the LED toggle more slowly.

46. Build the project by selecting Project > Build All. Select the Problems View and confirm that there are no errors.

47. Select SF2_GNU_SC4_pwm_slow_blink.elf under the Debug tab in the upper left corner of the SoftConsole Debug Perspective. Right-click and choose Terminate and Relaunch to stop the debugger and download the new application.
48. Run the application by clicking Run > Resume from the SoftConsole menu. The LED will toggle at a different rate.

Driving two LEDs

The application in the sample project only drives one LED, but CorePWM was configured to drive two outputs. Follow the steps below to modify the application to drive two LEDs.

49. Terminate the software application by clicking Run > Terminate from the SoftConsole menu.
50. Scroll in main to the section with the comment “* Set the initial duty cycle for CorePWM output 1.” on line 50. This line configures one CorePWM output.
51. Copy the line “PWM_set_duty_cycle( &the_pwm, PWM_1, duty_cycle );” and paste it below the existing line. Modify the line to drive PWM_2.
52. Scroll to the section with the comment “* Update the duty cycle for CorePWM output 1.” on line 58.
53. Copy the line “PWM_set_duty_cycle( &the_pwm, PWM_1, duty_cycle );” and paste it below the existing line. Modify the line to drive PWM_2. Save the file after making the edits above.
54. Repeat the previous steps to build the project. Confirm that there are no errors in the Problems View.

55. Re-launch the debugger (Run > Debug History > SF2_GNU_SC4_pwm_slow_blink Debug).

56. Run the application (Run > Resume) and observe the LEDs. Both LED D2 and LED D3 should toggle at the same rate.

   When finished, terminate the application by selecting SF2_GNU_SC4_pwm_slow_blink.elf under the Debug view, then right-clicking and selecting **Terminate and Remove** to stop the debugger. Click **Yes** when prompted about Terminating.
57. Close the Debug perspective (Window > Perspective > Close Perspective).

58. Close the SF2_GNU_SC4_pwm_slow_blink project by selecting the project name in the Project Explorer then right-clicking and selecting Close Project.
Step 8 - Running the RTC_time application (time permitting)
In this step, you will open the SF2_GNU_SC4_RTC_time sample project, import the firmware configuration files and run the application. This sample project uses the SmartFusion2 RTC’s calendar function.

1. Open the SF2_GNU_SC4_RTC_time project by selecting the project name in the Project Explorer then right-clicking and selecting **Open Project**.
2. Repeat the steps on pages 43 and 44 to import the firmware drivers and configuration files into the project.
3. Double click main.c in the Project Explorer window to open the file in the SoftConsole C/C++ editor. Scroll through the file to become familiar with it. The comments at the top of the file describe what the program does.
4. Select SF2_GNU_SC4_RTC_time in the SoftConsole Project Explorer. Build the project by selecting **Project > Build All** or by clicking the Build All icon.

Determining the COM port setting
This design requires a terminal emulator. The COM port assignment must be determined to configure the terminal emulator.

6. Open the Windows Device Manager and expand the **Ports (COM & LPT)** section.
   - One port will appear as “FlashPro 5 Port”. Record the COM port number below.

   **USB Serial Port:** COM_______

![Windows Device Manager showing COM port](image)

Creating a debug launch configuration

7. Select SF2_GNU_SC4_RTC_time in the SoftConsole Project Explorer View.
8. Select **Run > Debug Configurations...** from the SoftConsole menu. The Debug Configurations dialog will open.
9. Select GDB OpenOCD Debugging in the Debug Configurations dialog box then right-click and select **New Configuration** to create a new debug launch configuration for the Debug build configuration.
10. Ensure that the C/C++ Application field on the Main tab of the Debug Configurations dialog box contains **Debug\SF2_GNU_SC4_RTC_time.elf**.
11. Select the Debugger tab of the Debug Configurations dialog box. Confirm that the Config options field appears as shown in the figure below.

![Debug Configurations](image1)

**Figure 88 - Debug launch configuration**

12. Select the Startup tab. Confirm that the settings match the figure below.

![Startup Configurations](image2)

**Figure 89 - SoftConsole device and board file settings for the SmartFusion2 SMF2000 kit**
13. Click **Apply** to save if changes were made.

### Launching the Debugger

14. Click **Debug** in the Create, manage and run configurations dialog box. If you already closed the dialog box, select **Run > Debug** from the SoftConsole menu to launch the SoftConsole debugger. You can also launch the debugger by clicking the debug icon ( RecognitionException in the SoftConsole tool bar.

15. Click **Switch** in the **Confirm Perspective Switch** dialog box.

### Configuring a Serial Terminal View

SoftConsole 6.0 includes a built-in serial terminal view, which eliminates the need to run a separate serial terminal emulator when connecting to a target board using a UART.

16. Select **Window > Show View > Terminal** to open a serial terminal. The Terminals view will be visible.
17. Click the Open a terminal button (highlighted in the figure above) to configure the serial terminal.

18. Enter the following in the Launch Terminal dialog box then click OK:
   - Choose terminal: select Serial Terminal from the pull-down menu
   - Port: Enter the COM port number recorded on page 61.
   - Baud rate: 115200
   - Data Bits: 8
   - Parity: None
   - Stop Bits: 1
   - Flow Control: None
   - Encoding: Default (ISO-8859-1)

The baud rate, data bits, parity, stop bits and flow control settings are based on the MSS_UART_init function in main().

19. Run the software application by clicking the Resume icon ( ) or by clicking Run > Resume from the SoftConsole menu. The Terminals view will display a message as shown in the figure below.
Step 9 - Debugging code running from the SmartFusion2 eNVM

The application can also execute from the SmartFusion2 eNVM. The Cortex-M3 has six hardware breakpoints for debugging from eNVM. This section describes the steps to execute code from the SmartFusion2 eNVM.

20. Type d to set the date.

21. Type t to set the time.

22. After becoming familiar with the Debug perspective and the debug features, terminate the debugger by clicking the Terminate icon ( ) or by selecting Run > Terminate from the SoftConsole menu.
Building the project with the Release build configuration

1. Select the SoftConsole C/C++ Perspective by clicking the C/C++ button ( ) or by selecting Window > Perspective > Open Perspective > C/C++ from the SoftConsole menu.
2. The sample project Release build configuration settings use the debug-in-microsemi-smartfusion2-envm.ld linker script to build an executable that will run in the SmartFusion2 eNVM.
3. Select SF2_GNU_SC4_RTC_time in the SoftConsole Project Explorer then right-click and select Build Configurations > Set Active > Release to select the Release configuration as the active build configuration.
4. Build the project build by selecting Project > Build All. Confirm that there are no errors listed in the Problems view.
5. A folder named Release containing the executable for the Release build configuration will be visible in the Project Explorer.
6. Double-click SF2_GNU_SC4_RTC_time.map in the Release folder to open the file in the SoftConsole editor. Scroll down to the Memory Configuration section. The section should appear as shown in the figure below.

![Figure 96 - SF2_GNU_SC4_RTC_time.map for the Release build configuration](image)

7. Notice that the memory configuration for the Release build includes a rom section at 0x60000000, which is the address of the SmartFusion2 eNVM.

Creating the Release debug launch configuration

Create a debug launch configuration for the Release build.

8. Select SF2_GNU_SC4_RTC_time in the SoftConsole Project Explorer View then select Run > Debug Configurations... from the SoftConsole menu. The Debug Configurations dialog will open.
9. Select GDB OpenOCD Debugging in the Debug Configurations dialog box then right-click and select New Configuration to create a new debug launch configuration for the Release build configuration.
10. Click the Search Project button under the C/C++ Application field on the Main tab of the Debug Configurations dialog box.

![Figure 97 - Search Project button](image)

11. The Program Selection dialog box will open. Select armle - / SF2_GNU_SC4_RTC_time /Release/SC4_project.elf then click OK.

![Figure 98 - Selecting the Release configuration application program](image)

12. Select the Debugger tab of the Debug Configurations dialog box. Confirm that the Config options and GDB Client Setup fields contain the settings described previously.
13. Select the Startup tab. Confirm the setting match those shown on page 62.

14. Click **Apply** to save the changes.

15. Click **Debug** to launch the Debugger. Click **Yes** in the **Confirm Perspective Switch** dialog box. The SoftConsole Debug perspective will open and the code will be programmed to the SmartFusion2 eNVM. Messages will appear in the Console view while the code is being downloaded. When finished, the program will be suspended at the first line of main().

16. Select the Terminals view in the Debug Perspective. Right click in the Terminal and select **Clear Terminal** to remove any existing text. If necessary, open the Terminals view (**Window > Show View > Terminals**).

17. Click the Resume icon to run the application. Note that the application runs the same as previously when it was executing from the SmartFusion2 eSRAM memory.

18. Try setting breakpoints while executing the code. When finished, terminate the debugger and close the Debug perspective (**Window > Close Perspective**). Do not close SoftConsole.

19. The C/C++ Perspective will be open. Open the Terminal view (**Window > Show View > Terminals**) and configure as described earlier in the document.

20. Reset the SmartFusion2 SMF2000 kit by pressing and releasing SW3.

21. Observe the code execution in the Terminals view. The code is running without the debugger because it was programmed into the SmartFusion2 eNVM.
Note that the serial terminal can be used to display output even when a program is not being debugged - e.g. a program running from eNVM on power on reset that uses UART output.

Figure 101 - Terminals view in C/C++ perspective

This demonstrates how to generate sample SmartFusion2 firmware projects and debug them with SoftConsole 6.0.

End of SmartFusion2 lab
# List of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>SmartFusion2 Block Diagram</td>
<td>6</td>
</tr>
<tr>
<td>2</td>
<td>Libero SoC Project Manager</td>
<td>7</td>
</tr>
<tr>
<td>3</td>
<td>IP Catalog indicating new cores are available</td>
<td>8</td>
</tr>
<tr>
<td>4</td>
<td>Executing the project creation script</td>
<td>8</td>
</tr>
<tr>
<td>5</td>
<td>Script execution report</td>
<td>9</td>
</tr>
<tr>
<td>6</td>
<td>Libero SoC Design Flow tab</td>
<td>9</td>
</tr>
<tr>
<td>7</td>
<td>Entering a name for System Builder</td>
<td>10</td>
</tr>
<tr>
<td>8</td>
<td>SmartFusion2 System Builder Device Features page</td>
<td>10</td>
</tr>
<tr>
<td>9</td>
<td>System Builder Device Features after selections</td>
<td>11</td>
</tr>
<tr>
<td>10</td>
<td>System Builder Memories page</td>
<td>11</td>
</tr>
<tr>
<td>11</td>
<td>Selecting the hex file for the data storage client</td>
<td>12</td>
</tr>
<tr>
<td>12</td>
<td>Data Storage Client dialog box after importing the hex file</td>
<td>12</td>
</tr>
<tr>
<td>13</td>
<td>System Builder Memories page after adding the data storage client</td>
<td>13</td>
</tr>
<tr>
<td>14</td>
<td>System Builder Peripherals page</td>
<td>14</td>
</tr>
<tr>
<td>15</td>
<td>MM_UART_0 configurator</td>
<td>14</td>
</tr>
<tr>
<td>16</td>
<td>SmartFusion2 GPIO Configuration</td>
<td>15</td>
</tr>
<tr>
<td>17</td>
<td>System Builder Peripherals page after adding CorePWM</td>
<td>16</td>
</tr>
<tr>
<td>18</td>
<td>corepwm_0 configuration</td>
<td>17</td>
</tr>
<tr>
<td>19</td>
<td>Configuring the MSS clocks</td>
<td>18</td>
</tr>
<tr>
<td>20</td>
<td>System Builder Microcontroller options page</td>
<td>19</td>
</tr>
<tr>
<td>21</td>
<td>System Builder Microcontroller options page after selecting the RTC clock source</td>
<td>20</td>
</tr>
<tr>
<td>22</td>
<td>System Builder SECDED options page</td>
<td>21</td>
</tr>
<tr>
<td>23</td>
<td>CorePWM TACHINT options page</td>
<td>22</td>
</tr>
<tr>
<td>24</td>
<td>Fabric memory map</td>
<td>23</td>
</tr>
<tr>
<td>25</td>
<td>Message tab after successfully generating the MSS design</td>
<td>23</td>
</tr>
<tr>
<td>26</td>
<td>SF2_MSS_sys_sb_0 component</td>
<td>24</td>
</tr>
<tr>
<td>27</td>
<td>Connecting FAB_RESET_N port to VCC</td>
<td>24</td>
</tr>
<tr>
<td>28</td>
<td>SF2_MSS_sb_0 component after making pin connections</td>
<td>25</td>
</tr>
<tr>
<td>29</td>
<td>Libero SoC Message window after generating the design</td>
<td>25</td>
</tr>
<tr>
<td>30</td>
<td>Opening the Constraint Editor</td>
<td>26</td>
</tr>
<tr>
<td>31</td>
<td>Libero SoC Enhanced Constraint Manager</td>
<td>26</td>
</tr>
<tr>
<td>32</td>
<td>Importing the I/O constraint file</td>
<td>27</td>
</tr>
<tr>
<td>33</td>
<td>Selecting the I/O constraint file for layout</td>
<td>27</td>
</tr>
<tr>
<td>34</td>
<td>Deriving Timing Constraints</td>
<td>27</td>
</tr>
<tr>
<td>35</td>
<td>Message Window</td>
<td>28</td>
</tr>
<tr>
<td>36</td>
<td>Derived Timing Constraints</td>
<td>28</td>
</tr>
<tr>
<td>37</td>
<td>SmartFusion2 SMF2000 kit</td>
<td>29</td>
</tr>
<tr>
<td>38</td>
<td>Script execution report</td>
<td>30</td>
</tr>
<tr>
<td>39</td>
<td>Windows Device Manager showing COM port</td>
<td>32</td>
</tr>
<tr>
<td>40</td>
<td>TeraTerm Serial Port setup</td>
<td>32</td>
</tr>
<tr>
<td>41</td>
<td>Message in terminal emulator</td>
<td>32</td>
</tr>
<tr>
<td>42</td>
<td>Terminal emulator after pressing and releasing SW2</td>
<td>32</td>
</tr>
<tr>
<td>43</td>
<td>Configuring Firmware cores for the design</td>
<td>33</td>
</tr>
</tbody>
</table>
Figure 88 - Modified code to drive two PWM outputs ......................................................................................................... 58
Figure 89 – Terminating the application ................................................................................................................................... 59
Figure 90 - Windows Device Manager showing COM port ........................................................................................................ 60
Figure 91 - Debug launch configuration .................................................................................................................................. 61
Figure 92 - SoftConsole device and board file settings for the SmartFusion2 SMF2000 kit ..................................................... 61
Figure 93 - Startup tab settings .................................................................................................................................................. 62
Figure 94 - Terminal view in the Debug perspective ................................................................................................................ 63
Figure 95 - Serial terminal settings - COM port setting will vary ............................................................................................. 63
Figure 96 - SoftConsole Terminals view with message ............................................................................................................ 64
Figure 97 - Changing the date .................................................................................................................................................... 64
Figure 98 - Setting the time ....................................................................................................................................................... 64
Figure 99 - SF2_GNU_SC4_RTC_time.map for the Release build configuration ........................................................................... 65
Figure 100 - Search Project button ........................................................................................................................................... 66
Figure 101 - Selecting the Release configuration application program .................................................................................... 66
Figure 102 - Config options for the Release Debug launch configuration for the SmartFusion2 SMF2000 kit ......................... 67
Figure 103 - Console view while downloading to the SmartFusion2 eNVM .............................................................................. 67
Figure 104 - Terminals view in C/C++ perspective .................................................................................................................. 68