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Introduction

This tutorial demonstrates how to implement a basic SmartFusion2® Microcontroller Subsystem (MSS) configuration
that includes the GPIO, MMUART_0, the RTC and a soft PWM (CorePWM) in the SmartFusion2® fabric using System
Builder.

The SmartFusion2® MSS_GPIO[8] will be configured as an input. MSS_GPIO[8] will be connected to one of the switches
on the SmartFusion2® SMF2000. The fabric PWM[8:1] will be configured as 16 bit PWM; outputs will drive LEDs on the
SmartFusion2® SMF2000;

After completing this tutorial, you will be familiar with the following:

e Using a Tcl script to create a Libero® SoC project

e Using System Builder to configure the SmartFusion2® MSS, add fabric peripherals and generate the design
e Constraining the design for synthesis and layout

e Synthesize the SmartFusion2® design with Synplify Pro ME

e Run layout

e Generate a bitstream

e  Program the SmartFusion2® silicon on the SMF2000 board

e Creating firmware configuration files and Sample projects from Libero® SoC

e Using SoftConsole v2021.3 or later to create and debug SmartFusion2® applications

SMF2000 board

Online Reference Manual:

https://wiki.trenz-electronic.de/display/PD/TEMO0O01+TRM

Schematics:

http://www.trenz-electronic.de/fileadmin/docs/Trenz Electronic/Modules and Module Carriers/2.5x6.15/TEM0001/REV01/Documents/SCH-TEM0001-01-010C.PDF
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Figure 1 - SmartFusion2® Block Diagram

Components of SmartFusion2® Device Used
This tutorial uses the SmartFusion2® Cortex-M3, the MSS GPIO, MMUART _0, the RTC blocks and the FPGA fabric.

Tutorial Requirements

Software Requirements
e Microsemi Libero® SoCv2021.3 or later
o Synplify Pro
o ldentify Debugger
o FlashPro Express
e  Microchip SoftConsole v2021.3 or later
e Serial terminal program, such as PuTTY or TeraTerm

SmartFusion2® MSS Component versions
The table below lists the version of the SmartFusion2® MSS which must be used.

Libero® SoC Version SmartFusion2® MSS version System Builder
2021.3 1.1.500 1.0

Table 1 — SmartFusion2® MSS component versions
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Hardware Requirements

This tutorial targets the Trenz Board SMF2000 with SmartFusion2® on it. The free Libero® SoC Silver license can be used
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for this tutorial. Modelsim®Pro (mixed language simulation) is supported by a Silver license generated after May 22"
2020.

Extracting the source files

Use SMF2000 Cortex_M3_PWM _ lab_sources.zip to extract the required lab files to the C:> or D:>\Microsemiprj folder
on the HDD of your PC. Confirm that a folder named SMF2000_Cortex_M3_PWM_lab_sources containing 3 sub-folders

named constraints, hex_File and Script were extracted.

Step 1 - Creating a Libero® SoC Project

In this step, you will create a Libero® SoC project.

Launching Libero® SoC
Click Start > Programs > Microsemi Libero SoC v2021.3 > Libero SoC v2021.3 or click the shortcut on your desktop.
The Libero® SoC Project Manager will open.

1.

@ Libero X
A ,: =]
DS aRX@eo v
startpage | -
5
= Snartes B
F\anenlr\g el smartpesicn
lew... *Memory map docking window
Dpen... AMBA Bus width Design Rule Check (DRC)
Enhance Update Companent/Instance Version funcionality
Recent Projects «RTGH Smarabug FPCA Hortars Brackpait rca raduction
=SmartPoer - Improved actiity annotation during VCD import
= abilty to update ipero, mode and tDebug
Polarfire, RT PolarFire and PolarFire SoC
= Change to default ssttings of specific unused 0 Pins, The updiate eliminates potentisl 10 gltches observed on power up
~Design Initialization Data report enhancement
=Place & Route Minimum Delay Repair enhancement for extemal tining losure of 10D interfaces
*XCUR ERM enhancements to improve transceiver robustness
Polarfire SoC
Links ms /S devices
e MSS simulsbon model enhancements
\elcome to Lbero SoC *Device check when importing an MSS component (CXZ) into Libero SaC
JEotosL e rart
Lbero SoC Quickstart D TTAG Programing ool
Libero So nterface Descrption NS g o e S vty
Lbero SoC Release Notes on the Web
Lbero Tutorials More Information
Product Tutorials To access datasheets and siicon user guides, viit . mi lect the and dick the o tab. Tutorials, Appication Notes, Development Kits & Boards are listed in the Design Resources tzb.
Training Webcasts Click the following links for additional information:
Microsemi SoC Wehsite *Libero SoC— Leam more about Libero So€ including omplete list of and timing and power ted in this release.
more
*Poner Calalators — Find XL5-based estim: e fomiies
*Licensing - Learn more zbout Libero icensing
ez 8 x
(Bvessages Derrors 4 wamings @i
©1oro: Current Vaulc Location = C:\Microsemi\LiberoCommonm\Vaultso
Log [ Message
fFam: [pert:
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Checking Tool Profiles and IP Cores

2. Click Project > Tool Profiles from the Libero® SoC menu to open the Tool Profiles dialog box.
Verify that the following tool profiles exist:

e Synthesis: Synplify Pro® ME contained in
<Libero_v2021.3_installation>\SynplifyPro\bin\synplify_pro.exe

e Simulation: Modelsim® ME Pro contained in
< Libero_v2021.3_installation>\ModelsimPro\win32acoem\modelsim.exe

3. Click OK to close the Tool Profiles dialog box.
4. Open the Libero® SoC IP catalog (View > Windows > Catalog). If the message New Cores are available appears at
the bottom of the catalog, click Download them now to download the cores.

Catalog g %
[ Q, v [ simulation Mode ¥
Name Version

Arithmetic

Basic Blocks

Bus Interfaces

Clock & Management
DSP

Fusion Peripherals

1/0

Memory & Controllers
Peripherals

PolarFire Features
Power Management
Processors

SC/Tamper
Solutions-AXI
Solutions-FIL-HSP-IP
Solutions-MotorControl
Solutions-Video
Solutions-WiredComms
Solutions-Wireless
Tamper

User Defined

o Mew cores are available Download them now! |

Figure 3 - IP Catalog indicating new cores are available

O ] S Oy W Oy B O B O O SO 3 e 3 S e S

Creating the Libero® SoC Project
Use the Tcl script contained in the Scripts folder to create the Libero® SoC project.

5. Select Project > Execute Script from the Libero® SoC menu. The Execute Script dialog box will open.

6. Click the Browse button ( IZI) to open the Select the script file dialog.
7. Navigate to the C:\Microsemiprj\SMF2000_Cortex_M3_PWM _lab_sources\Scripts\ folder.
Select Project creation.tcl then click Open.
8. Click Run in the Execute Script dialog box to execute the script.
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(™ Execute Script 7 x

Script file: IC:ﬂﬂicmsemiprjfsMFZDUU_Curtex_MS_PWM_Iab_suur::esfScriptsfPrnject_creaﬁun.td . I
Arguments: I

V¥ show script report

Help |

Fun | Cancel |

Figure 4 - Executing the project creation script

9. The script execution report will appear as shown below indicating successful execution of the script

@ Script Execution Report

? >
| E] Messages | @ Errors (0) | A4 Warnings (0) | ﬂ Information (0)
Save &3 Print Settings...

Info: This version of Libero supports only the enhanced constraint flow,
The SMF200043_BaseDesign project was created.

The Execute Script command succeeded.

Help |

Close |

Figure 5 - Script execution report

10. Close the Script Execution Report.
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Step 2 - Configuring the SmartFusion2® MSS with System Builder

In this step, you will configure the SmartFusion2® Microcontroller Subsystem (MSS) using System Builder.

1. Select the Libero® SoC Design Flow tab. Expand Create Design and double-click System Builder.

Design Flow

@ Please select a ...

g X

B oQe¢

| Tool

B Create HDL

= b Create Design
”—& System Builder
onfigure M

B Create SmartDesign

: @ Create SmartDesign Testbench

B Create HDL Testbench

+(] Generate Memory Map

B P Verify Pre-Synthesized Design

- [l Simulate
& P Constraints
E- p Implement Design
E- »  Program and Debug Design
&~ p Handoff Design for Production
& p  Handoff Design for Firmware Development
&~ p Handoff Design for Debugging
Design Flow | Design Hierarchy | Stimulus Hierarchy | Catalog | Files |

Figure 6 - Libero® SoC Design Flow tab

2. Enter SF2_MSS when prompted for a name for your system.

[87 Enter a name for your sy.. ?
Name:
[sF2_mss|
Help | oK Cancel

Figure 7 - Entering a name for System Builder
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3. System Builder will open with the “System Builder - Device Features” page visible as shown below.

@ System Builder - Device Features m} X

> Device Features » > Peripherals > > Clocks > > Microcontroller » > SECDED > > Security > > Interrupts > > Memory Map »

Select the SmartFusion2 features you will be using in your design

—Memary J
[ MssExternal Memary
& MDDR
" Soft Memory Controller (SMC)
I~ wmss On-chip Flash Memory { eNVM )

I™ Fabric External DDR Memory { FDDR )

—Microcontroller Options
™ Watchdog Timer
r Peripheral DMA

™ Real Time Counter

FAB_CCC

MI0d 8 Bdv_ O
NS By WO

Figure 8 — SmartFusion2® System Builder Device Features page

4. Enter the following on the “System Builder - Device Features” page:

e Memory

o MSS External Memory un-checked (default)
o MSS On-chip Flash Memory (eNVM) checked

e  Microcontroller Options
o Watchdog Timer un-checked (default)
o Peripheral DMA un-checked (default)
o Real Time Counter checked
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@ System Builder - Device Features

] X

> Device Features > > Memories » » Peripherals » ) Clocks ) > Microcontroller » ) SECDED » ) Security ) »

Interrupts » > Memory Map »

~Memory
[~ Mss External Memory
' MDDR
" Soft Memory Controller (SMC)
¥ mss 0On-chip Flash Memory { eNVM )

[ Fabric External DDR Memary ( FDDR )

[~ Microcontroller Optiens
r Watchdog Timer
r Peripheral DMA

¥ Real Time Counter

Select the SmartFusion2 features you will be using in your design

l

W_L3530d 7S adv Hoon.

H12d"5 AV OO
VIS By HaaN

T =
CORESDR

Help ~ Cancel Next
Figure 9 - System Builder Device Features after selections

5. Click Next. The “System Builder — Memory” page will open.

(@ system Builder - Memories m] %

> Device Features » » Memories » ) Peripherals » } Clocks } > Microcontroller > } SECDED » ) Security y > Interrupts » > Memory Map »

/ ENVM '\

Configure your external and embedded memories

P lable client types

Data Storage|
Serialization

Add to System...

User clients in eNVM

Client Type

Client Name | DepthxWidth | Start Address(Hex) | Page Startl Page End | Initialization Order | Lock Start Address

—Usage statistics
Available pages: 2032
Used pages: 0
Free pages: 2032

| | Used space
] Free space
& Optimize Edit Delete
Help = Cancel Back | Next |
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6. Select Data Storage under Available client types (highlighted in the figure above) then click Add to System. This will
create a partition in the SmartFusion2® Embedded Non-volatile memory (eNVM) which will be used to store the
Cortex-M3 application program.

7. Enter the following in the Add Data Storage Client dialog box:

e (Client name: PGM_store

e Content:
o Click the browse button to open the Import Memory File dialog box.
o Navigate to the C:\Microsemiprj\SMF2000_Cortex_M3_PWM _lab_sources\hex_File folder
o Select pwm_demo_eNVM.hex and “Use relative path” directory, then click Open

@ Import Memory File ? X
Look in: ‘ Cr\Microsemipri\SMF2000_Cortex_M3_PWM_lab_sourcesthex_File j e =] 0 ﬁ @ E]
[ My Computer MName Size Type Date Modified
R lens . . 20KB hexFile 30.11.2..8 12:20
File pame: ‘pv\'m_demu_ENVM.hex
Files of type: [Intel-Hex Files (= hex =.inx) ~|  cancel

" Use absolute path (file wil not be copied if you move the design)
€ @ Userelative path

" Copy memory file to project directory |

Figure 11 - Selecting the hex file for the data storage client

8. The Add Data Storage Client dialog box will appear as shown in the figure below. Click OK to close the Add Data
Storage Client dialog box.

1" Modify Data Storage Client ? *

Client name: |ApplicationCode

eNVM

(®) Content from file: |J_Corhex_M3_PWM_Iab_sourcesmex_FiIe\pwm_demo_eN\n'M.hex

o Imported Memory file location : C:YMchppri\SMF2000_Cortex_M3_PWM_lab_sources
Yhex_File\pwm_demao_eMNVM.hex

Format: |Intel-Hex <
[ Use absolute addressing )
() Content filed with 0s
() No content (dient s a placeholder and will not be programmed)

Start address: 0x

Size of word: 8 | Bits

Number of words: |?824 Decmal

[Juseasrom

[] Use content for simulation

e o

Figure 12 - Data Storage Client dialog box after importing the hex file
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9. The client will be visible in the System Builder Memories page.

(@ System Builder - Memories ] X

> Device Features » 2 Memories ;> » Peripherals » » Clocks » > Microcontroller » > SECDED »» Security »? Interrupts » > Memory Map >

Configure your external and embedded memories

[ ENVM
Available client types User clients in eNv'M
Data Storage

Serialization Client Type Client Mame Depthxwidth Start Address(Hex) Page Start Page End Initialization Order Lock Start Address

applicationCode 7824 % 8

Add to System... |

~Usage statistics
Available pages: 2032
Used pages: 62
Free pages: 1970

| | Used space
= FEzerEE Optimize Edit | Delete |
Help @ | Cancel | Back | Mext |

Figure 13 - System Builder Memories page after adding the data storage client

10. Click Next. The “System Builder — Peripherals” page will open. Here you can enable or disable MSS peripherals and

add fabric peripherals.  Configure peripherals by clicking the wrench symbol ( jF'). The number of fabric
peripherals used can be changed by editing the number in the Quantity column.
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G‘ System Builder - Peripherals m} X
> Device Features > } Memories » » Peripherals » Clocks Microcontroller » SECDED Security Interrupts Memory Map

Select the peripherals and masters for each subsystem

I” Direct Connection Mode { FIC interfaces are exported out of System Builder )

Fabric Slave Cores Subsystems
core Version | [® M55 FIC_0 - M55 Master Subsystem -]
11 CoreAHBLSRAM | 2.0.113 drag and drop here to add to subsystem
2| Corel2C 7.0.102
| coresil 20156 [@® MSS FIC 0 - Fabric Master Subsystem
:CoreGPIO 30420 || drag and drop here to add to subsystem
s | CoreTimer 1.1.101 l®@  MssPerpherak |
? CoreUARTaph 5.2.2 Configure | Enable MName
7| corepwm 41108 @& MM_UART_D
'3 | Fabric AMBA Slave | 0.0.102 o MM_UART_1
B @ MSS_12C_0
Fabric Master Cores #* e
& & |mss.spio
Core Version | @, MSS_SPI_1
ﬂFabncAMEAMaster 0.0.7102 [ 155 GRIG
L |mssuse
O |mssmac
O [msscan
[~

To move 2 penpheral fom one subsystem fo another, drag it from its present focation and drop it onto the desired sushsystem.
You cannot drag and drop onta MSS Peripherals.

Masters are in bold and blue.

Help @ Cancel Back

Figure 14 - System Builder Peripherals page

11. Disable the MM_UART_1, MSS_I2C_0, MSS_12C_1, MSS_SPI_0 and MSS_SPI_1 peripherals by clicking the box in the
Enable column.

12. Click the wrench symbol ( {?) next to the MM_UART_0 peripheral to open the MM_UART_0 Configurator.
Verify the “Connect to 10” configuration. Click OK to close the configurator.

UART Configurator

Microsemi:SystemBuilder:SF2_MSS_UART:0.0.101

Configuration l

Transmit-Receive

Duplex Mode Full Duplex hd
Transmission Mode |Asynchronous ¥

Connect To 10 <

Moderm

Use Modem [

ConnectTo |10

Help Cancel
Figure 15 - MM_UART_0 configurator
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13. Enable the MSS_GPIO peripheral by clicking the box under the Enable column.

14. Click the wrench symbol ( 13-) next to the MSS_GPIO peripheral to open the MSS GPIO Configurator. Configure the
GPIOs as shown below.

e Set/Reset Definition:
e Configure GPIO[31:0] per the table below:

accept default settings

GPIOID Direction Package Pin | Connectivity
GPIO[0:7] Not Used NA NA
GPIO_8 Input NA FABRIC_A
GPIO_[9:31] Not Used NA NA
Table 3 — SmartFusion2® GPIO configuration
B MSS GPIO Cenfigurator ? x
—Configuration —Connectivity Preview =
Set/Reset Definition
GPIO_31_24 Reset Source [SYSREG (MSS_GPID_31_24 SOFT_RESET)  ~v| | ResetState [1 <]
GPI0_23_16 Reset Source [SYSREG (MSS_GPID_23_16_SOFT_RESET)  v| | ResetState [1 <] —
GPIO_15_8 Reset Source |SYSREG (MSS_GPID_15_8 SOFT_RESET) | | ResetState [T ~|
GPIO_7_0 Reset Source  |SYSREG (MSS_GPIO_7.0_SOFT_RESET)  ~| | ResetState m
GPIO Assignment Advanced Options |
GPIO ID Direction Package Pin Connectivity
GPIO_O [Motused  ~] oa =] =
GPIO_1 [Motused  ~] 04 ~ E
GPIO_2 [Motused  ~] 04 ~ EI
GPIO_2 [Motused  ~] 04 ~ ”
GPIO_4 [Motused  ~] 04 ~
FPGA Fabric
GPIO_S [Motused  ~] 10_A -
GPIO.6 Im 0A = Click on a signal row to see the preview
GPIO_T [Motused  ~] 10_A -
GPIO_2 [nput ] [FaBriCA ~]
GPIO_9 [Motused  ~] 10_A - _|LI
‘| »

Cancel |

Figure 16 - SmartFusion2® GPIO Configuration

15. Click OK to close the MSS GPIO Configurator.
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16. Drag an instance of CorePWM from the Fabric Slave Cores to the MSS FIC_0 - MSS Master Subsystem. This will add a
soft PWM core in the FPGA fabric which will be connected to FIC_O.

(-'\ System Builder - Peripherals O X
> Device Features » > Memories » » Peripherals » > Clocks } > Microcontroller > > SECDED ) ) Security » > Interrupts » > Memory Map »
Select the peripherals and masters for each subsystem
| " Direct Connection Mode ( FIC interfaces are exported out of System Builder )
Fabric Slave Cores Subsystems
o= | version =l @ 1S5 FIC_0 - MSS Master Subsystem [+]
2 | Corel2C 7.0.102 Configure | Quantity | Name
CoresPl 30,156 # | 1 [corepwmo]
n CoreGPIO 3.0.120 ® MSS FIC 0 - Fabric Master Subsystem
5 |CoreTimer 1.1.101 drag and drop here to add to subsystem
E CorelJARTapb 5.2.2 @ Mss PE‘I?,U.’?E‘IBJ{S
8 | Fabric AMBA Slave | 0.0.102 - & MM_UART_O
Fabric Master Cores O |mbART
Core Version | O S50
ﬂFahri( AMBA Master 0.0.102 O |wssteet I
O |mSSSPHE
O |MS5SPEE
G MSS_GPIO
O |ms54sB
O |wsswac o -
To move 2 peripheral from one subsystem to another, drag it from its present location and drop it onto the desired susbsystem. -
You cannot drag and drap onto MSS Peripherals.
Masters are in bold and blue.
Help - Cancel Back Next

Figure 17 - System Builder Peripherals page after adding CorePWM

17. Click the wrench symbol ( {?) next to corepwm_0 in the MSS FIC_0 - MSS Master Subsystem to open the CorePWM
configurator. Enter the following in the Configuring corepwm_0 dialog box.
e Global Configuration:
o Configuration Mode: 0 - PWM Only Mode (default)
o Number of PWM Channels: 8
o APB Data Bus Width / Resolution: 16
e Global PWM Mode Configuration:
o Fixed Prescale: un-checked
o Fixed Period: unchecked (default)
e Channel 1 - 8 Configuration: accept the default settings

18. Click OK to close the CorePWM configuration dialog box.
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B Configurator

CorePWM Configurator
i niDirect’ p 1.106
Configuration l

Global Configuration:

Configuration Mode: 0 - PWM Only Made b
Mumber of PWM Channels: ] <z
APB Data Bus Width [ Resolution: |16 b

Global PWM Mode Configuration:

Fixed Value: |0
Fixed Value: |1

Fixed Prescale: [
Fixed Period: |

Channel 1 Configuration:

Channell PWM stretch level (HIGH when selected) [

Channel 2 Configuration:

Channel2 PWM stretch level (HIGH when selected) [

Channel 3 Configuration:

Channel3 PWM stretch level (HIGH when selected) ™

Help A

Low Ripple DAC mode: r Shadow Update Register:
Fixed PWM PosEdge: v Fixed PWM PosEdge Value:
Fixed PWM NegEdge f DAC LevelOut: I Fixed PWM NegEdge Value: |0

Low Ripple DAC mode: r Shadow Update Register:
Fixed PWM PosEdge: Iv Fixed PWM PosEdge Value:
Fixed PWM NegEdge [ DAC LevelOut: r Fixed PWM NegEdge Value:

Low Ripple DAC mode: r Shadow Update Register:
Fixed PWM PosEdge: v Fixed PWM PosEdge Value:
Fixed PWM NegEdge f DAC LevelOut: r Fixed PWM NegEdge Value: |0

-

’07
’”7
-
’07
’@7
-
’07
’”7

OK |

M|

Cancel |

Figure 18 - corepwm_0 configuration
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MICROCHIP

Note: additional information about CorePWM and the configuration parameters is available in the CorePWM handbook.
The CorePWM handbook can be accessed from the CorePWM Configurator by clicking Help.
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19. Click Next. The “System Builder — Clocks” page will open. Use this page to specify the clock source and clock
frequencies used in the design. Enter the following on the Clock tab:

e System Clock:

e M3_CLK:

e APB_O CLK:
e APB_1CLK:
e FIC_O_CLK:

Select On-chip 25/50 MHz RC Oscillator from the pull-down menu
100 MHz (default)

M3_CLK/1 (100 MHz) (default)

M3_CLK/1 (100 MHz) (default)

M3_CLK/2 (50 MHz)

These frequencies were chosen to maximize the speed of the Cortex-M3 microcontroller.

(® System Builder - Clocks [m| X
> Device Features > ? Memories > Peripherals » » Clocks > > Microcontroller >  SECDED » > Security »» Interrupts » > Memory Map »
Configure clock requirements

Clock | Fabriccce | chip Osdilators | R e
! =
System Clock :
50.0 MHz !
1
|on-chip 25/50 MHz RC Oscillator | I
|
Cortex-M3 and M35 Main Clock ]
| MSS_CCC
M3_CLK = [100.00 MHz 100.000 |
1
MDDR Clocks !
1
MDDR_CLK -M3_ClK= |1 'l !
1
DDR/SMC_FIC_CLK =MDDR_CLK / I 1 vl '
1
MSS APB_0/1 Clocks :
1
APB_0_CLK =M3_CK [ |1 'l 100,000 !
1
APE_1_CLK =M3_CLK / |1 vl 100,000 ,
1
Fabric Interface Clocks :
1
FIC_0_CLK —M3_CLK [ Iz vl 50.000 !
— 1
I” AHBLite Bypass Mode :
1
FIC_1_CLK =M3_CLK [ |1 'l !
]
™ AHBLite Bypass Mode !
Fabric DDR Clocks i
1
FODR_CLK - 100 MHz !
]
1 —
FDDR_SUBSYSTEM_CLK = FODR_CLK / |1 vl | Fabric
1
! =
Fl | | 3
Help o | Cancel | Back MNext
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Figure 19 — Configuring the MSS clocks
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20. Click Next. The “System Builder - Microcontroller” page will open. This page has multiple tabs, which allow
configuring the Cortex-M3 microcontroller, the Cache Controller and the AHB Bus Matrix.

(@ System Builder - Microcontroller [m] X

> Device Features » » Memories » » Peripherals » > Clocks » > Microcontroller » > SECDED » » Security »» Interrupts » » Memory Map »

Configure Microcontroller options

/" Real Time Counter \/ Cortex-M3 \/" Cache Contraller \/” AHB Bus Matrix \

Clock Source

Source |External 32 KHz RTC Crystal Osdillator ﬂ

Wakelp Interrupt

Enable WakeUp Interrupt to Cortex-M3 [
Enable WakeUp Interrupt to FPGA Fabric [
RTC_MATCH

Expose RTC_MATCH port to FPGA Fabric [

Help @ Cancel

Back Mext

Figure 20 - System Builder Microcontroller options page
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21. Select the Real Time Counter tab in the System Builder - Microcontroller pane. This is where options for the RTC are
set.

22. Select the On-chip 1 MHz RC Oscillator as the RTC clock source from the pull-down menu in the Clock Source field on
the Real Time Counter tab. This option matches the RTC sample projects available in the Firmware Catalog.

23. Accept the default settings for the Wakeup Interrupt and the RTC_MATCH signal.

(® System Builder - Microcontroller ] x

> Device Features » 2 Memories » » Peripherals » » Clocks » > Microcontroller » > SECDED » » Security »» Interrupts » > Memory Map »

Configure Microcontroller options

/" Real Time Counter \/ Cortex-M3 \/" Cache Contraller \/” AHB Bus Matrix \

Clock Source

Source |On-chip 1 MHz RC Oscillator ﬂ

Wakelp Interrupt
Enable WakeUp Interrupt to Cortex-M3 [
Enable WakeUp Interrupt to FPGA Fabric [

RTC_MATCH

Expose RTC_MATCH port to FPGA Fabric [

Help @ Cancel Back Mext

Figure 21 - System Builder Microcontroller options page after selecting the RTC clock source

24. Although we won’t be making any other changes, take a moment to become familiar with the contents of the other
tabs (Cortex-M3, Cache Controller, AHB Bus Matrix).
25. Click Next to accept the default settings on the Microcontroller page.
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26. The “System Builder — SECDED” (Single Error Correct / Double Error Detect) page will open. Use this page to enable
SECDED for various memory blocks within the SmartFusion2® MSS. Although we won’t be using SECDED for this
design, take a moment to become familiar with the contents of this page.

(> System Builder - SECDED = [ |
> Device Features » » Memories ) » Peripherals » > Clocks » > Microcontroller » ) SECDED »» Security »» Interrupts » > Memory Map »
Configure Single Error Correct / Double Error Detect (SECDED) options

"SECDED \
EDAC Errors
Expose EDAC_ERROR bus [
eSRAM_0
Enable EDAC ] Enable EDAC Interrupt(s) |Mone
eSRAM_1
Enable EDAC ] Enable EDAC Interrupt(s) |Mone
Ethernet TX RAM A
Enable EDAC [7] Enable EDAC Interrupt(s) |Mone i
Ethernet RX RAM
Enable EDAC 7] Enable EDAC Interrupt(s) |Mone
UsB
Enable EDAC 7] Enable EDAC Interrupt(s) |Mone
CAN
Enable EDAC [7] Enable EDAC Interrupt(s) |Mone
MDDR
Erahle MR EE Tabmer ot 7] =

Figure 22 - System Builder SECDED options page

27. Accept the default settings on the page and click Next.

28. The “System Builder — Security” page will open. This page is used to set the Master to Slave Read/Write access for
devices that support Data Security features. The SmartFusion2® devices on the SMF2000 kit does not support these
security features, so these options will be grayed out.

29. Click Next to accept the default settings.
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30. The “System Builder — Interrupts” page will open. This page displays interrupt connections generated from attached
fabric peripherals. The CorePWM TACHINT interrupt will be visible as shown in the figure below.

@ System Builder - Interrupts m| X

> Device Features » ) Memories » » Peripherals » } Clocks } > Microcontroller > ) SECDED ) ) Security ) Interrupts ; > Memory Map »

Interrupt connections generated from attached peripherals and the processor

Processor Interrupt Instance Name Trigger Signals Lock
SF2_MSS_sh_MSS_0:MSS_INT_F2MI0] | corepwm_0_0 TACHINT |
Help - Cancel Back Mext

Figure 23 - CorePWM TACHINT interrupt
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31. Click Next. The “System Builder — Memory Map” page will open. This page displays the addresses of fabric
peripherals. The address of CorePWM will be visible. Up to six different memory regions can be assigned to each FIC in the

MSS memory map. In this design, two memory regions (0x30000000 and 0x50000000) are assigned to FIC_O for the interface to
the FPGA fabric and CorePWM.

(@ System Builder - Memory Map O x

> Device Features » ;  Memories » » Peripherals » > Clocks  » > Microcontroller > ) SECDED » » Security » » Interrupts » > Memory Map
Memory Map for peripherals attached to the processor

Select Bus to View or . .
Assign Peripheral(s) Assign peripherals to addresses on bus:

=1 5F2_MS55 _sb/CM3 Address | Peripheral
= SWITCH

CoreAPB3 0/APB3mmaster: xm corepwm_0_0:APBslave

APE_P1
APE_PO

Help = Cancel Back Finish

Figure 24 - Fabric memory map

32. Click Finish.

33. Confirm that the message “’SF2_MSS_sb’” was generated successfully” appears in the Libero® SoC Message tab.

Message

E]Messages @ Erors Warnings @ nfo E] Manage suppressed messages

Message Message ID Source Location Log Location

Please refer for details about SF2_MSS_sb - - SF2 MSS sb Log
'SF2_MSS_sb' was generated successfully - - -

Log Message

Figure 25 - Message tab after successfully generating the MSS design

34. A component named SF2_MSS_sb_0 will be visible in the SmartDesign canvas as shown below. If necessary, click
the SF2_MSS tab to display the SmartDesign canvas.
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MMUART_0_RXD >

SF2_MSS_sb_0

—|FAB_RESET_N

DEVRST_N [»———DEVRST_N

APWM[8:1]
| pTACHIN[1]

[E]corepwm_0_0_PINS

~y

POWER_ON_RESET_N|—

MMUART_0_PADS[E]
MMUART_O_RXD «
MMUART_O_TXDp
FAB_CCC_PINS[=]
FAB_CCC_GLOp |-
FAB_CCC_LOCKp |-

GPIO_FABRIC[S]
GPIO_8_F2M« [—

MSS_READY|—

INIT_PINS[T]
INIT_DONEp |

»

SF2_MSS_sb

Figure 26 — SF2_MSS_sys_sb_0 component
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————{ > MMUART_0_TXD

35. Connect the FAB_RESET_N port to VCC by selecting the port, right-clicking and selecting Tie High.

MMUART_O_RXD [

SF2_MSS_sb_0
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FAB_
DEVRST N [ = DEVRST_N
[Elcorepwm_t

-
RESET_M

APWM[S:1
p TACHIN[1 +

POWER_ON_RESET_N

MMUART_0_PADS[=]
MMUART_0_RXD 4

== Disconnect

Promote to Top Level
Go To Driver
Magnify Pin
Highlight

Clear Attribute
Invert

Tie Low

Add Pin To New Group

* NIT_DONEp

"y

MS5_READY

XT_0_TXDp
| CCC_PINS[=]
|CCC_GLOp
ICC_LOCKp
INIT_PINS[F]

10_FABRIC[T]

I0_8 F2Mo
—

Figure 27 — Connecting FAB_RESET_N port to VCC
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36.

37.

38.

39.

40.

41.

If necessary, click the + sign next to corepwm_0_0_PINS to expand the pin group. Promote the PWM[8:1] port to
the top level by selecting the port, right-clicking and selecting Promote to Top Level. These outputs will drive LEDs
on the target board. Connect the TACHIN[1] port to GND by selecting the port, right-clicking and selecting Tie Low.
Mark the POWER_ON_RESET_N and MSS_READY output ports unused by selecting the port, right-clicking and
selecting Mark Unused.

If necessary, click the + sign next to FAB_CCC_PINS to expand the pin group. Mark the FAB_CCC GLO and
FAB_CCC_LOCK pins unused. These pins are not used in the design.

If necessary, click the + sign next to GPIO_FABRIC to expand the pin group. Promote the GPIO_8 F2M port to the
top level by selecting the port, right-clicking and selecting Promote to Top Level. The GPIO_8 F2M port will connect
to a switch on the SMF2000 board.

If necessary, click the + sign next to the INIT_PINS output port to expand the group. Mark the INIT_DONE output
port unused.

After making the pin connections the SF2_MSS_sb_0 component will look like the figure below.

MMUART_0_RXD [

SF2_MSS_sb_0

MMUART_0_PADS[=]
MMUART_0_RXD«

MMUART O_TXD» | > MMUART_0_TXD
DEVRST_M [ —>— IDEVRST_N

FAB_CCC_PINS
[=]corepwm_0_0_PINS — i ..El e
APWM[B:1] I — PWM[8:1]

. |
TACHIN[1:1
5 [1:1] GPIO_FABRIC[=]

GPID_B_F2M [ —— GPID_8_F2M+
INIT_PINS[=]

P

1. )

SF2_MSS_sb

=+

FAB_RESET_M

|+

Figure 28 — SF2_MSS_sb_0 component after making pin connections
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42. Execute a Design Rules Check by clicking the Checkmark icon.

Reports & X GeSF2 Mss @ X ] StartPage B X |

| 1
= ~~ D% — | D gD RA N
B v O > TP (o0 N 2R

%Esign Rules Checki

MMUART_O_RXD [»>——

Figure 29— Execute Design Rules Check

43. Verify the correctness of the SmartDesign Component:
o Check Messages window for “SmartDesign 'SF2_MSS' design rules check succeeded”.

44. Generate the design by clicking SmartDesign > Generate Component or by clicking the Generate Component icon

s
on the SmartDesign toolbar ( ).
45. The message “'SF2_MSS’ was generated successfully” will appear in the Libero® SoC Message window indicating the

design was generated without any errors.

Message

(E) Messages € Errors i Warnings @ Info =] Manage suppressed messages

| Message Log Location Iﬂ

SmartDesign 'SF2_MSS' design rules check succeeded - - -
‘SF2_MSS' was generated successfully = = = j

Message ID | Source Location

Log Message

Figure 30 - Libero® SoC Message window after generating the design

40. Close the design (File > Close SF2_MSS).
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Step 3 - Constraining the Design

Importing an 10 Constraint file
There are multiple ways to make I/0 Assignments. In this lab, we will use the I/O Physical Design Constraint (PDC) file
that is provided in the lab source files.

1. Expand Constraints in the Libero® SoC Design Flow window and double-click Manage Constraints.

Design Flow & X

Top Module(root): SF2_MSS =] ° @’

Active Synthesis Implementation: synthesis

Tool

E- b Create Design

& System Builder

- & Configure MSS

E3 Create SmartDesign

Create HDL

@ Create SmartDesign Testbench

Create HDL Testbench

+(] Generate Memory Map

= b Verify Pre-Synthesized Design
- B Simulate

£~ b Constrain

- F Implement Design

B Open Netlist Viewer

G Synthesize

= b Verify Post-Synthesized Design

. -+ Generate Simulation File

- B Simulate

(] Configure Flash*Freeze

Configure Register Lock Bits

Place and Route

& P Verify Post Layout Implementation LI

.« ] Ranarata Rarlk Annntatad Filac

Design Flow I Design Hierarchy I Stimulus Hierarchy I Catalog I Files |

Figure 31 - Opening the Constraint Editor

2. The Enhanced constraint manager will open.

Reports & X | StartPage & X Constraint Manager & X |

5
o Attn'butesl Timing | Floor Planner| Netlist Attrihutes'
New |'| Import | Link | Edit |'| Check | Help ﬂ ﬂ

| Place and Route |

1/0 Settings

[¥ Reserve Pins for Device Migration

Select the devices you are targetting for migration. Pins not bonded on these devices will be reserved in the device selected for this project.
Selected Device: M25010 - 144 TQ

0 m2s010S
O mM2s005
O M2s005S

Target Devices:

— General

¥ Reserve Pins for Probes

Figure 32 - Libero® SoC Enhanced Constraint Manager
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3. Click Import on the 1/O Attributes tab to open the Import Files dialog box. Navigate to the
C:\Microsemiprj\SMF2000_Cortex_M3 PWM lab_sources\constraints folder.
Select io_constraints.pdc then click Open.

G" Import Files X
YN <« ArrowTraining » constraints v & constraints” durchsuchen L

Organisieren * Meuer Ordner =~ W @
@z Timing & Synch MName - Anderungsdatum Typ
s Ubergabefotos " io_constraints 11/27/2018 11:17...  PDC-Datei
@ USB
@ V5C

[ Dieser PC v £ >

Dateiname: |io_constraints v| 10 Constraint Files (*.pdc) e
Abbrechen

Figure 33 - Importing the 1/0O constraint file

4. The file will be visible on the I/0 Attributes tab of the Constraint Manager.
Double-click io_constraints.pdc to open the file in the Libero® SoC text editor. Scroll in the file to become familiar
with the syntax. The constraint set_io sets the pin number and I/O specific attributes. The # symbol is a comment.
Note the internal pull-up setting for the GPIO_8 F2M signal pin.

# USER_BTN
set_io GPIO_8 F2M -pinname B19 -fixed yes -iostd LVCMOS33 -RES_PULL Up

5. Close the editor (File > Close io_constraints.pdc).

6. Check the box under Place and Route for constraint\io\io_constraints.pdc in the I/O Attributes tab to use the PDC
constraint file for layout.

7. Click Save to save all changes in Constraint Manager, select YES in Warning message about flow invalidation.

4

Reports B X Constraint Manager® & X I StartPage & X l

o Ath'ibubes‘l Timing | Floor Planner | Netist Attributes |

Mew |" Import | Link: | Edit “' View | Chedk Help Save Discard |ﬂﬂ

|P|ace and Route |
constraint\ic\io_constraints.pdc

Figure 34 - Selecting and saving the 1/0O constraint file for layout
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Generating Timing Constraints
In this step, you derive timing constraints for the design. Libero® SoC can generate timing constraints for known blocks
(such as the RC oscillators and the PLLs) automatically.

7. Select the Timing tab in the Constraint manager window. Double-click Derive Constraints.

L]

Reports & X | StartPage & X Constraint Manager & X |

I/0 Attributes Floor Plannerl Metlist Attn'hutes'
New | Import | Link | Edit with Constraint Editorl" Check |'| Derive Constraintsl Constraint Coverage |" Help | ﬂ ﬂ

| Synthesis | Place and Route | Timing Verification |

Figure 35 - Deriving Timing Constraints

8. Click on Yes in the Message window to automatically associate the derived constraints SDC file to the ‘Synthesis’,
‘Place and Route’ and ‘Timing Verification’.

B | Message *

|:@ To automatically associate the derived constraint SDC file to the 'Synthesis', 'Place and Route' and Timing Verification' tools click "ves' else click 'No".

Yes No

Figure 36 - Message Window

9. A constraint file named SF2_MSS_derived_constraints.sdc will be visible. Double-click on the file name to open the
file in the Libero® SoC text editor to become familiar with the content.

4l

Reports & X | StartPage & X Constraint Manager & X |

/O Attributes  Timina | Floor Planner | Netlist Attributes|

New | Import | Link | Edit with Constraint Editor|'| Check |'| Derive Constraints | Constraint Coverage |V| Help | ﬂ ﬂ
Synthesis | Place and Route |Timing Verification |
constraint\SF2_MSS_derived_constraints.sdc

Figure 37 - Derived Timing Constraints
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Step 4 - Synthesis and Layout
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In this step, you will use the push-button flow to synthesize the design with Synplify Pro, run layout and generate the

programming file

1. Double-click the Generate Bitstream in the Design Flow window to synthesize the design, run layout using the
I/0 constraints that were created and generate the programming file.
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Design Flow g X

Fabric_Top & O G'
-

Tool

-- P Create Design
= b Constraints

& » Implement Design

- » Program and Debug Design

-3 Manage Constraints

- Netlist Viewer

-2 Synthesize

= b Verify Post-Synthesis Implementation
~+[] Generate Simulation File

- B Simulate

~+[] Configure Flash*Freeze

~+["] Configure Register Lock Bits

1% Place and Route

= b Verify Post Layout Implementation
~+(] Generate Back Annotated Files

B Simulate

&, Verify Timing

&, Open SmartTime

B+ Verify Power

£ b 10 Analyzer

----- £% SSN Analyzer

~+[] Generate FPGA Array Data
-[F Update eNVM Memory Content
#- b Configure Hardware

& Configure Programming Options
- @ Configure Security
= b Program Desi

&- b Debug Design T
- b Handoff Design for Production
B- b Handoff Design for Firmware Development -
. kb Hamdadbdf Masicam fome Maboissaize _I
Design Flow | Design Hierarchy | Stimulus Hierarchy I Catalog | Files |

Figure 38 - Generate Bitstream
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The design implementation tools will run in batch mode. Successful completion of a design step will be indicated by a
green check mark next to the Implement Design item in the Design Flow window.
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z » Create Design
4 } Constraints
_’j Manage Constraints
* Implement Design
B Netlist Viewer
S Synthesize
= » Verify Post-Synthesis Implementation
+L| Configure Flash*Freeze
+L| Configure Register Lock Bits
v 915 Place and Route
4 | Verify Post Layout Implementation
+[| Generate Back Annotated Files
. Simulate
(& Verify Timing
&1 Open SmartTime
lh Werify Power
4 » 10 Analyzer
[ SSM Analyzer
4 F Program and Debug Design
v +[| Generate FPGA Array Data
@g Update eMNVM Memory Content
= » Configure Hardware

< <

« Configure Pragramming Options
& Configure Security
4 p Program Design
v ]ﬁ Generate Bitstream
' Run PROGRAM Action

Design Flow B X
Fabric_Top =2 o #
Tool at

m

Cesign Flow | Design Hierarchy Stimulus Hierarchy

Catalog | Files |

Figure 39 - Successful completion of design implementation
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2. The Reports tab will display reports for the tools used to implement the design.

Reports & X StartPage @ X |

-- Project Summa
B o repors o —

#- Components
= Svnthemze
- synplify.log
- SF2_MSS.srr
- run_ocptions.tt
- 5F2_MS5_dsp_rpt.txt
- 5F2_MS5_ram_rpt.bet
- 5F2_MS5_compile_netlist_resources.ml
- 5F2_MS5_compile_netlist_hier_resources.csv
- i SF2_MS5_compile_netlist.log
[=- Place and Route
- 5F2_MS55_glb_net_reportaxml
SFE_MSS_mmdela].r_repalr_report.rpt
-~ 5F2_MS55_layout_cembinational_lecpsxml
- 5F2_M55_place_and_route_constraint_coveragexm|
- 5F2_MS55_pinrpt_name.rpt
- 5F2_MS5_pinrpt_number.rpt
-~ 5F2_MS55_bankrpt.rpt
- BF2_MES ioffacml
- i} SF2_MSS_layout_log.log
[ Generate FPGA Array Data
b §F2_MSS_init_configaom
[=}- Generate Bitstream
i §F2_MS5_generateBitstream.log

Figure 40 - Reports tab after implementing the design

e\

MICROCHIP

4.Connect the SMF2000 board using a Micro-USB cable to the PC USB port (board power is provided from PC USB port).
The Window’s Device Manager should display the following entries (port number may differ depending on your PC):
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o Device Manager
File Action View Help
&< m Hem

@ Cameras
, 8 Computer
= Disk drives
[l Display adapters
B Firmware
4 Human Interface Devices
2 Keyboards
> 0 Mice and other pointing devices
[ Monitors
» @ Network adaptefs
v - p° . -
§ Unm rollers
' Genenc SupuSpeed US8 Hub
' Genenc USB Hub

' USB Root Hub (USB 3. 0)

Figure 41 - Device Manager
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5. Run program action

174 =I- ¥ Program Design 1
! Generate Bitstream
> Run PROGRAM Action

Figure 42 - Run program action

Step 5 - Running the Application

The next step is to observe the operation of the Cortex-M3 program in the design.

Determining the COM port setting
This design requires a terminal emulator. In order to configure the terminal emulator, the COM port assignment must
be determined.

1. Open the Windows Device Manager and expand the Ports (COM & LPT) section.
e One port will be listed as “FlashPro 5 Port”. Record the COM port number below.

USB Serial Port: com

& Device Manager - m} X

File Action View Help
e« o HE 7

i Firmware ~
¥ Human Interface Devices
= |DE ATA/ATAPI controllers
<i% Imaging devices
=2 Keyboards
L1 Memory technology devices
0 Mice and other pointing devices
@ Monitors
l? Network adapters
W Ports (COM & LPT)
& FlashPro5 Port (COMS)
= Print queues

= Printers
M.

<

Figure 43 - Windows Device Manager showing COM port

2. Open aterminal emulator program such as TeraTerm or PuTTY and configure a Serial terminal as follows:
e Port: Select the COM port number recorded above.
e Baud rate: 115200
e Data Bits: 8
e Parity: None
e Stop Bits: 1
e Flow Control: None
3. Press and release User Button (the one close to the LEDs) at SMF2000 board. The string “Button-Press” will appear
in the Terminal Emulator.
4. Press and release the reset button. The string “Hi! | am SmartFusion2 :)” will appear in the Terminal.
5. The LEDs should appear as follows:
e LED D9 to LED D2 — gradually get dimmer and brighter. The PWM core in the FPGA fabric drives these LEDs.
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Step 6 - Generating Sample Projects and Exporting the Firmware Configuration

Files
In this step, you will generate sample projects and export the firmware configuration files for the design.

Generating sample projects
1. Expand Handoff Design for Firmware Development on the Design Flow tab. Select Configure Firmware Cores, then
right-click and select Open Interactively.

Design Flow

Top Module(root): SF2_MSS B Q

Active Synthesis Implementation: synthesis

Tool ILI
-3 Manage Constraints
¢ o » Implement Design
B Open Netlist Viewer
("4 - Synthesize
&~ b Verify Post-Synthesized Design
+[| Configure Flash*Freeze
~-+] Configure Register Lock Bits
4 B Place and Route
- ¥ Verify Post Layout Implementation
- » Program and Debug Design
v +[] Generate FPGA Array Data
--[@ Update eNVM Memory Content
- »  Configure Hardware
= Configure Programming Options
- @ Configure Security
=- » Program Design
% Generate Bitstream
‘& Run PROGRAM Action
ebug Design
; Identify Debug Design
€ SmartDebug Design
#- p  Handoff Design for Production
E- » Handoff Design for Firmware Development

el

ol
[

-
2

A0 49

- B Export Firmware Run
E- » Handoff Design for Debuggint Clean and Run All

- Export SmartDebug Data Open Interactivel

Clean
Design Flow | Design Hierarchy | Stimulus Hie

Ju

Help

Message

Figure 44 - Configuring Firmware cores for the design

2. The DESIGN_FIRMWARE tab will open.

Reports & X | StartPage & X | Constraint Manager & X E DESIGN_FIRMWARE & X S

o
Generate | Instance Name Core Type Version Compatible Hardware Instance

1 & B CorePWM_Driver_0 CorePWM_Driver 2.4.100 _v||SF2_MSS_sb:corepwm_0_0
o I igF B SmartFusion2_CMSIS_0 SmartFusion2_CMSIS 2.3.105 »||sF2_mss_sh_wss
3 |~7 qg SmartFusion2_MSS_GPIO_Driver_0 SmartFusion2_MSS_GPIO_Driver 2.1.102 i} SF2_MSS_sh_MSS:GPIO
4 I B SmartFusion2_MSS_HPDMA_Driver_0 SmartFusion2_MSS_HPDMA_Driver 2.2.100 ~||sF2_mss_sh_MsS
5 |»7 % SmartFusion2_MSS_MMUART _Driver_0 SmartFusion2_MSS_MMUART _Driver 2.1.100 = SF2_MSS_sb_MSS:MMUART_0
6 |7 B SmartFusion2_MSS_NVM_Driver_0 SmartFusion2_MSS_NVM_Driver 2.5.100 ~||sF2_ms5_sh_MsS
7 Ical qg SmartFusion2_MSS_RTC_Driver_0 SmartFusion2_MSS_RTC_Driver 2.2.100 i} SF2_MSS_sb_MSS:RTC
8 |~7 !g SmartFusion2_MS5_System_Services_Driver_0 SmartFusion2_MS5_System_Services_Driver 2.9.100 ~||SF2_MS55_sh_MSS
g Ical qg SmartFusion2_MSS_Timer_Driver_0 SmartFusion2_MSS_Timer_Driver 2.2.100 t SF2_MSS_sh_MSS

Figure 45 - DESIGN FIRMWARE tab

3. Confirm that none of the drivers appears in italics. If any drivers appear in italics, click the check box in the Generate
column for the missing core. Click Yes when prompted about downloading the core.
4. Click Yes in the Download Required dialog box to download any firmware cores that are missing from the IP vault.
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@ Download Required

N

Ackel:Firmware:SmartFusionz_MS5_MMUART _Driver:2.0,100 isn't in the waulk,
Conkinuing will download this core, and also any other Firmware cores that are nok
already in the vaulk, Is this ok?

es ] [ Mo l

Figure 46 - Downloading missing firmware cores

5. Use the pull-down menu in the SmartFusion2_CMSIS_0 row to select version 2.3.105 if it is not selected.

4l

Reports & X | StartPage & X | Constraint Manager & X E DESIGN_FIRMWARE & X |

K
Generate | Instance Name Core Type Version Compatible Hardware Instance
1 M~ B CorePWM_Driver_0 CorePWM_Driver 2.4.100 ~||SF2_MSS_sb:corepwm_0_0
2 v i@ B SmartFusion2_CMSIS_0 SmartFusion2_CMSIS 2.3.105 z SF2_MSS_sh_MSS
3 ¥ B, SmartFusion2_MSS_GPIO_Driver_0 SmartFusion2_MSS_GPIO_Driver 2.1.102 ~||5F2_MS5_sb_MSS:GPI0
4 |~7 !3 SmartFusion2_MSS_HPDMA_Driver_0 SmartFusion2_MSS_HPDMA_Driver 2.2.100 i SF2_MSS_sb_MSS
5 ¥ B, SmartFusion?_MSS_MMUART Driver_0 SmartFusion2_MSS_MMUART_Driver 2.1.100 ~||5F2_MS5_sh_MSS:MMUART_0
] |~/_ !; SmartFusion2_MSS_NVM_Driver_0 SmartFusionZ_MSS_NVM_Driver 2.5.100 i SF2_MSS_sb_MSS
7 ¥ B, SmartFusion2_MSS_RTC_Driver_0 SmartFusion2_MSS_RTC_Driver 2.2.100 ~||5F2_MS5_sb_MSS:RTC
8 |~/_ !; SmartFusion2_MSS_System_Services_Driver_0 SmartFusionZ_MSS_System_Services_Driver 2.9.100 i SF2_MSS_sb_MSS
9 |7 !3 SmartFusion2_MSS_Timer_Driver_0 SmartFusion2_MSS_Timer_Driver 2.2.100 ~||SF2_MSS_sb_MSS

Figure 47 - Selecting SmartFusion2_CMSIS version 2.3.105

6. Create the CorePWM sample project by selecting CorePWM_Driver_0 on the DESIGN FIRMWARE tab, then right
clicking and selecting Generate Sample Project > Cortex-M3 > SoftConsole v4.0 > PWM slow blink. Note that
SoftConsole v4.0 projects could be imported in SoftConsole v2021.3; if user is experiencing any problem please refer
to the example projects and SoftConsole Release Note documentation part of the SoftConsole installation.

4

Reports & X | StartPage & X 4 DESIGN_FIRMWARE & X |

e
sen E.‘I'ﬂtEI l

!-H CorePWM_Driver_0

Version Compatible Hardware Instance

2.4.100 H SF2_MSS_sys_sb:corepwm_0_0

Core Type

Instance Name

CorePWM_Driver

2 || & |@F By SmarFusionz_ CMSIS 0 Disable Generation SmartFusion2_CMSIS 23.105 =] /5F2_MS5_sys_sb_MSS

3 I !; SmartFusion2_MSS_GPIC  Show Details... SmartFusion2_MSS5_GPIO_Driver 2.1.102 - ||SF2_MSS_sys_sb_MSS:GPIO

4 |~t_ !3 SmartFusion2_ MSS_HPDI  Open Documentation > SmartFusion2_MSS_HPDMA_Driver 2.2.100 ~||SF2_MSS_sys_sb_MSS

5 w [ AEUCENEEEE NI Generate Sample Project * RGP R VRIS |MSS_MMUART_Driver 2.1.100 ~||SF2_MSS_sys_sb_MSS:MMUART_0

6 |7 !3 SmartFusion2_MSS_MMUART _Driver_1 Cortex-M3 * SoftConsale v4.0 * PWM edge control = 5F2_MSS_sys_sb_MSS:MMUART_1

7 v SmartFusion2_MSS_NVM_Driver_0 = NV - ~||5F2_MSS_sys sb_MSS

LA L s T et RISCV  » PWM slow blink hd =

3 ¥ H; SmartFusion2_MSS_RTC_Driver 0 SmartFusion2_MSS_RTC_Driver +||sF2_mss_sys sh_mss:RTC
PWM tachometer measure =

9 I !3 SmartFusion2_MSS_System_Services_Driver_0 SmartFusion2_MSS_System_Services Dr ~ ~||SF2_MSS_sys_sb_MSS
PWM waveform alignment =

10 I !3 SmartFusion2_MSS_Timer_Driver_0 SmartFusion2_MSS_Timer_Driver i ~|/SF2_MSS_sys sb mss

Figure 48 - Generating the CorePWM sample project

7. Confirm the following settings in the Generate Sample Options dialog box then click OK:
C:\Microsemiprj\SMF2000-M3_BaseDesign\SoftConsole
e Show generation report: checked

e Folder:
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(® Generate Sample Options 7 x

Samples folder: |C: {Microsemipri\sMF 2000-M3_BaseDesignSoftConsole ™

Files will be generated in:
C:\Microsemipri{sMF 2000-M3_BaseDesignSoftConsolesF2_GMU_SC4_pwm_slow_blink

¥ Show generation report

Help QK Cancel

Figure 49 — CorePWM slow blink sample project options

8. The Report dialog box will list all the files generated and the location.

@ Report ? >

Save é Print

Files generated in 'C:\Microsemipri\SMF 2000-M3_BaseDesign'\SoftConsole": -~

SF2_GMU_SC4_pwm_slow_blink\.cproject

SF2_GMU_SC4_pwm_slow_blink\.project

SF2_GMU_SC4_pwm_slow_blink\CMSISYhw_reg_io.h

SF2_GMU_SC4_pwm_slow _blink\CMSISYm 25000 h

SF2_GMU_SC4_pwm_slow_blink\CMSIS'mes_assert.h
SF2_GMU_SC4_pwm_slow_blink\CMSI5\startup_gcc\debug-in-microsemi-smartfusion2-envm.ld
SF2_GMU_SC4_pwm_slow_blink\CMSIS\etartup_gccdebug-in-microsemi-smartfusion2-esram.|d
SF2_GMU_SC4_pwm_slow_blink\CM3I5\startup_gccdebug-in-microsemi-smartfusion2-external-ram.|d
SF2_GMU_SC4_pwm_slow _blink\CMSIS\etartup_gccinewlib_stubs.c
SF2_GMU_SC4_pwm_slow_blink\CMSIS\startup_gcc\production-smartfusion2-execute-in-place. ld
SF2_GMU_SC4_pwm_slow _blink\CMSIS'startup_geciproduction-smartfusion2-relocate-to-external-ram.ld
SF2_GMU_SC4_pwm_slow_blink\CMSIS'\startup_goclstartup_m2sxxx. S
SF2_GMU_SC4_pwm_slow_blink\CMSIS'system_m2sxoc.c
SF2_GMU_SC4_pwm_slow_blink\CMSIS'\eystem_m2sxxx.h
SF2_GMU_SC4_pwm_slow_blink\CM3I5\sys_init_cfa_types.h

SF2_GMU_SC4_pwm_slow _blink\drivers\CorePWM'corepwm_regs.h
SF2_GMU_SC4_pwm_slow_blink\drivers\CorePWM'core_pwm.c
SF2_GMU_SC4_pwm_slow_blink\drivers\CorePWMcore_pwm.h
SF2_GMU_SC4_pwm_slow_blink\drivers_configlsys_config\sys_config.c
SF2_GMU_SC4_pwm_slow_blink\drivers_config\sys_config\sys_config.h
SF2_GMU_SC4_pwm_slow_blink\drivers_configleys_config\sys_config_mss_docks.h
SF2_GMU_SC4_pwm_slow_blink\hal\CortexM3\cortex_nvic.c b
SF2_GMU_SC4_pwm_slow_blink\hal\CortexM3\cortex_nvic.h
SF2_GMU_SC4_pwm_slow_blink\hal\CortexM3\GNU\cpu_types.h
SF2_GMU_SC4_pwm_slow_blink\hal\CortexM3\GNUhal.5
SF2_GMU_SC4_pwm_slow_blink\hal\CortexM3\GNUhw_macros.h
SF2_GMU_SC4_pwm_slow_blink\hal\CortexM3\GNUhw_req_access.5 ﬂ
CET Chl €rd mwm elria hlink-thallhal B

Help Close

Figure 50 - GPIO Simple Blink project files

9. Click Close to close the Report window.
10. Create the MSS RTC sample project by selecting SmartFusion2_MSS_RTC_Driver_0 on the DESIGN_FIRMWARE tab,

then right clicking and selecting Generate Sample Project > Cortex-M3 > SoftConsole v4.0 > RTC Time.
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Reports & X | StartPage & X

@ DESIGN_FIRMWARE & X |

[SmartFusion2_MSS_RTC_Driver_0 _MSS_RTC_Driver

| sF2_mss_sys_sb_mss:rTC

Disable Generation

. SmartFusion2_MSS_System_Services_Driver | MSS_System_Services_Driver ~||SF2_mss_sys_sb_mss

b
o |
Senerate I Instance Name Core Type Version Compatible Hardware Instance
1] I B CorePWM_Driver_0 CorePWM_Driver 2.4.100 = SF2_MSS_sys_sb:corepwm_0_0
i ¥ |i@F By SmariFusion2_CMSIS_0 SmartFusion2_CMSIS 2.3.105 - ||SF2_MsS_sys_sb_MsS
3 I B SmartFusion2_MSS_GPIO_Driver_0 SmartFusion2_MSS_GPIO_Driver 2.1.102 t SF2_MSS_sys_sb_MSS:GPIO
4 I B SmartFusion2_MSS_HPDMA_Driver_0 SmartFusion2_MSS_HPDMA_Driver 2.2.100 t SF2_MSS_sys_sb_MSS
5 I . SmartFusion2_MSS_MMUART Driver_0 SmartFusion2_MSS_MMUART _Driver 2.1.100 t SF2_MSS_sys_sb_MSS:MMUART_0
6 I B SmartFusion2_MSS_MMUART Driver_1 SmartFusion2_MSS_MMUART _Driver 2.1.100 t SF2_MSS_sys_sb_MSS:MMUART_1
7 ¥ B SmartFusion2_MSS_NVM_Driver_0 SmartFusion2_MSS_NVM_Driver t SF2_MSS_sys sb_MsS
= _
o —
R

Show Details...

T

B SmartFusion2_MSS_Timer_Driver_0 | MSS_Timer_Driver |2.2.1UU j|5F2,M55,sys,sb,M55

Open Documentation 4

Generate Sample Project » Cortex-M3 » IAR Embedded Workbench *

Keil-MDK 4

SoftConsole v3.4 4

RTC Interrupt
RTC Calendar Alarm

Figure 51 - Generating the RTC Driver sample project

11. Confirm the following settings in the Generate Sample Options dialog box then click OK:
C:\Microsemiprj\SMF2000-M3_BaseDesign\SoftConsole
e Show generation report: checked

e Folder:

(™ Generate Sample Options 7 X

samples folder: IC:‘l,Mi::rusemiprj‘lSMFZUUU—MS_EaseDesign\SuFﬂ:unsnle| ™

Files will be generated in;
C:\Microsemipri\sMF 2000-M3_BaseDesign\SoftConsolelSF2_GHU_SC4 RTC_time

¥ show generation report

Help |

QK Cancel

Figure 52 — RTC Time sample project location

12. The Report dialog box will list all the files generated and the location.
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G"‘ Report

? X

Save | & Print

Files generated in 'C:\Microsemipri\SMF 2000-M3_BaseDesign'\SoftConsole":

SF2_GMU_SC4_RTC_timel. cproject

SF2_GMU_SC4_RTC_time\, project

SF2_GMWU_SC4_RTC_time\CMSISthw_reg_io.h

SF2_GMU_SC4_RTC_time\CMSIS \m2sxxx.h
SF2_GMU_SC4_RTC_time\CMSISmss_assert.h
SF2_GMU_SC4_RTC_time\CM5I5\startup_agccidebug-in-microsemi-smartfusion2-envm. Id
SF2_GMU_SC4_RTC_time\CMSIS\startup_gecidebug-in-microsemi-smartfusion2-esram. |d

SF2_GMU_SC4_RTC_time\CMSIS\startup_geocinewlib_stubs.c

SF2_GMU_SC4_RTC_time\CMSIS\startup_geclstartup_m2sxxx.5

SF2_GMU_SC4_RTC_time\CMSIS \system_m2sxoc.c

SF2_GMU_SC4_RTC_time\CMSIS\system_m2sxo.h

SF2_GMU_SC4_RTC_time\CMSIS\sys_init_cfg_types.h

SF2_GMU_SC4_RTC_time\drivers\mss_rtcmss_rtc.c

SF2_GMU_SC4_RTC_time\drivers\mss_rtcimss_rtc.h

SF2_GMU_SC4_RTC_time'\drivers\mss_uart\mss_uart.c

SF2_GMU_SC4_RTC_time\drivers\mss_uartimss_uart.h

SF2_GMU_SC4_RTC_time\driversmss_uart'mss_uart_regs.h

SF2_GMU_SC4_RTC_time\drivers_configleys_configieys_config.c

SF2_GMU_SC4_RTC_time\drivers_config\sys_config\sys_config.h

SF2_GMWU_SC4_RTC_time\drivers_configisys_config\sys_config_mss_cocks.h

SF2_GMU_SC4_RTC_time‘hal\CortexM3'cortex_nvic.c

SF2_GMU_SC4_RTC_time\hal\CortexM3lcortex_nvic.h

SF2_GMU_SC4_RTC_time\hal\CortexM3\GMNU\cpu_types.h

SF2_GNU_SC4_RTC_time\hal\CortexM3\GNUhal. 5

SET ML 2rA DT timabhal i artewM WM ks macrae b

Help

SF2_GMU_SC4_RTC_time\CMSIS\startup_gcc\debug-in-microsemi-smartfusion2-externalram. ld

SF2_GMU_SC4_RTC_time\CMSIS \startup_gcc\production-smartfusion 2-execute-in-place.|d
SF2_GMU_SC4_RTC_time\CMSIS \startup_agccproduction-smartfusion 2relocate-to-externalram. ld

-

=
Close

Figure 53 - RTC_time project files

13. Click Close to close the Report window.
14. Close the DESIGN_FIRMWARE tab (File > Close DESIGN_FIRMWARE). Select Yes if prompted about saving changes
to DESIGN_FIRMWARE.

Exporting firmware configuration files and firmware drivers
The firmware used in a SoftConsole project must match the target hardware configuration. For SmartFusion2® projects,

e\

MICROCHIP

Libero® SoC generates specific firmware files that are required to ensure that the SoftConsole project matches and is

compatible with the target hardware. The sample projects created in the previous step contain generic firmware files

that may not match the target hardware. In this step, you will export firmware configuration files that match the design

configuration.
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15. Select Export Firmware under Handoff Design for Firmware Development on the Design Flow tab, then right-click
and select Export Firmware... to create the firmware drivers for the design.

Design Flow & x

Top Module(root): SF2_MSS = o g’

Active Synthesis Implementation: synthesis

Tool lLl

B » Constraints
- |3 Manage Constraints
¢ = b Implement Design
B Open Netlist Viewer
v "G Synthesize
- B Verify Post-Synthesized Design
-+ Configure Flash*Freeze
~-+("] Configure Register Lock Bits
v % Place and Route
» Verify Post Layout Implementation
Program and Debug Design
v --+[] Generate FPGA Array Data
--[# Update eNVM Memory Content
- #  Configure Hardware
- = Configure Programming Options
-~ @ Configure Security
E- » Program Design
% Generate Bitstream
@ Run PROGRAM Action
- Debug Design
Identify Debug Design
- € SmartDebug Design
Handoff Design for Production
Handoff Design for Firmware Development
¥ Configure Firmware Cores

=- b Handoff Design for Debu
-0 Export SmartDebug Dz Help

Design Flowr Design Hierarchy Stimulus Hierarchy

Figure 54 - Exporting the firmware configuration files

® Il
&2} [#

i
-

-
)

L=

T
v wv

16. Enter the following in the Export Firmware dialog box then click OK:

e Location: Accept the default location

e Software IDE: select SoftConsole4.0 from the pull-down menu

e Export hardware configuration: Checked
B Export Firmware ? *
Location: IC:‘|,|'~"Iicrnsemiprj‘lSMFEﬂUU-MS_EaseDesign| Browse... |

Software IDE: ISoFb:onsoIe4.D ;I
¥ Export hardware configuration and firmware drivers

" Create software project induding hardware configuration and firmware drivers

Help | QK Cancel

Figure 55 - Export Firmware options
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17. Click OK in the dialog box that indicates the location of the firmware cores.

Information

.

| Firmware project was successfully exported to 'C:\MicrosemiprjSMF2000-MM3_BaseDesign',

Ok

x

Figure 56 - Firmware driver location

18. The firmware drivers will be visible on the Libero® SoC Files tab. The Project for selected toolchain and the sample

projects will be visible on the Files tab in the SoftConsole folder. If the projects are not visible, select View > Refresh

Design Hierarchy from the Libero® SoC menu.
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(1 component
[ constraint
7 designer

7 firmware
+- [ CMSIS
=[] drivers
#- 3 CorePWM
[3 mss_gpio
[3 mss_hpdma
1 mss_nvm
[3 mss_rtc
[7 mss_sys_services
[ mss_timer
[ mss_uart
=~ (0 drivers_config Firmware Configuration
+ [ sys_config
[7 filelist Flles
- [ hal
B README.txt
B SF2_MSS_cmsis_svdxml
B SF2_MSS_hw_platform.h

Firmware drivers

- [ - - -

L1 hal
1 simulation
[ smartgen

[1 SoftConsole ]
[7 filelist Sample Projects

+- [ SF2_GNU_SC4_pwm_slow_blink
+- ] SF2_GNU_SC4_RTC_time

7 stimulus
[ synthesis
[ tooldata

Design Flowr ] Design Hierarchy I Stimulus Hierarchy ] Catalog Files

Figure 57 - Sample projects on Libero® SoC Files tab
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19. The Data Sheet containing the memory map will be visible in the Libero® SoC Report tab.

Reports @ X } StartPage & X | Tming Report Explorer

&% | constantManager &% |

£

20.

21.

22.

- Project Summary
£+ SF2_MSS reports

Components
Generate Memory Map
SF2_MSS_DataSheet.xml
Synthesize
synplify.log
i SF2_MSS.sr
run_options.txt
SF2_MSS_dsp_rpt.tt
SF2_MSS_ram_rpt.txt
SF2_MSS_compile_netlist_resourcesml
5F2_MSS_compile_netlist_hier_resources.csv
& SF2_MSS_compile_netlist.log
Place and Route
SF2_MSS_glb_net_report.xml
SF2_MSS_mindelay_repair_report.rpt
SF2_MSS_layout_combinational_loopssml
SF2_MSS_place_and_route_constraint_coverage.ml
SF2_MSS_pinrpt_name.rpt
SF2_MSS_pinrpt_number.rpt
SF2_MSS_bankrpt.ipt
SF2_MSS_joff.xml
@ SF2_MSS_layout_loglog
Verify Timing
¥ SF2_MSS_max_timing_multi_corneraml
& SF2_MSS_min_timing_multi_cornerxml
¥ SF2_MSS_max_timing_violations_multi_cornerxml
& SF2_MSS_min_timing_violations_multi_corneraml
W SF2_MSS_ma_timing_slow_1.14V_85C.xml
& SF2_MSS_min_timing fast_1.26V_0Caml
& SF2_MSS_max_timing_fast_1.26v_0C.ml

& SF2_MSS_min_timing_slow_1.14V_85Cml

¥ SF2_MSS_max timing viclations_slow_1.14V_85C.xm|

& SF2_MSS_min_timing_violations_fast_1.26_0C.xml
& SF2_MSS_max_timing_vielations._fast_1.26V_0C.xml
& SF2_MSS_min_timing_violations_slow_1.14V_85C.xml
SF2_MSS_timing_constraints_coveragexmi
SF2_MSS_timing_combinational_loops.xm

Generate FPGA Array Data
SF2_MSS_init_configxml

Generate Bitstream
SF2_MSS_generateBitstream.log

Export Bitstream
SF2_MSS_exportBitstream.log

Scroll in the SF2_MSS

Data Sheet: SF2_MSS

Project Settings
FAM: SmartFusion2
Die: M25010
Package: 400 VF
Speed Grade: STD
Voltage: 12
HDL: VHDL
Project Description: test design ${currdate}
Location: C/Mchppri/M25010_PWM_Lab/componentwork/SF2_MSS
State (Time): GENERATED ( Wed Mar 10 09:33:16 2021 )

Table of Contents
Generated Files
10's
Hardware Instances
Firmware
Memory Map

Generated Files

top of page

Figure 58 — Data Sheet for the design

data sheet and become familiar with the Generated Files, Firmware and Memory Map

sections (click on the hyperlink at the top of the data sheet to move to the section of interest).

Select the Memory Map to become familiar with the locations of the peripherals.

What is the address of MMUART_0?

What is the address of corepwm?

Minimize Libero® SoC.
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Step 7 - Debugging with SoftConsole v2021.3

Running the CorePWM slow blink application
In this step, you will launch SoftConsole, import the sample projects created from Libero® SoC and run the CorePWM
slow blink application from the SmartFusion2® eSRAM.

Note: SoftConsole 2021 do not allow to create a Workspace in a not empty folder. You will then create a workspace for
SoftConsole in a new empty folder.

1. Browse your Windows Explorer and go to the project location folder e.g. “C:\Microsemiprj\SMF2000-
M3_BaseDesign”. Create a new folder named $C2021v3_Workspace.

E x iﬁ Tl New item = Iﬂ T Open - selectan
Edit

£ Easy access + Select none

B Dﬂ.m Rename fglfd":, Pmpfms g History T Invert selection
Organize Mew Open Select
» SMF2000-M3_BaseDesign v 0 £ Search SMF2000-M3_BaseDesign
~ Name B Date modified Type Size ~
component 3/29/2022 5:47 PM File folder
constraint 3/29/2022 ©:02 PM  File folder
designer File folder
firmware y File folder
hdl /2! File folder
SC2021v3_Workspace 30 File folder
simulation 3/29/2022 5:59 PM  File folder
smartgen 3/29/2022 6:03 PM File folder
SoftConsole 3/29/2022 6:01 PM File folder
stimulus 3/2 File folder
synthesis 3/29/2 File folder
tooldata 3/29/202 File folder
|=] libero_setup_info.txt 3/29/2022 5:48 PM Text Document 1KB
) @ SMF2000-M3_BaseDesign.prix 3/29/2022 5:59 PM PRJX File 37 KB v

—

2. Click Start > Programs > Microsemi > SoftConsole v2021.3, or click the shortcut on your desktop. The SoftConsole
Workspace Launcher may open as shown below.

SC SoftConsole - x

SoftConsole

select a directory as workspace

Workspace: |..fextras/workspace.example Browse...

[] Popuiate the new workspace with SoftConsale’s recommended settings

> Recent Workspaces

Launch Cancel

Figure 59 - SoftConsole Workspace Launcher (location shown may differ)

3. Click the browse button in the Workspace Launcher and navigate to the project location into the
$C2021v3_Workspace subfolder e.g. “C:\Microsemiprj\SMF2000-M3_BaseDesign\SC2021v3_Workspace” then click
Select Folder.
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€ Select Workspace Directory

X

<« - P « ArrowComeHome_Apr2022 » SMF2000-M3_BaseDesign 2 Search SMF2000-M3_Ba..,
Organize ~ Mew folder = (2]

Pictures(1) Name Date modified Type

R l

ecordings component 3/29/2022 547 PM  File folder
3 This PC constraint 3/29/2022 &:02 PM  File folder
I 3D Objects designer 3/29/2022 552 PM  File folder
I Deskiop firmware 3/29/2022 &:01 PM  File folder
7 hdl 3/29/2022 4:25 PM File folder

|£ Documents S =
SC2021v3_Workspace 3/30/2022 6:49 AM  File folder
3 Downloads simulation 3/29/2022 559 PM  File folder
& Music smartgen 3/29/2022 6:03 PM  File folder
&= Pictures SoftConsale 3/29/2022 &:01 PM  File folder
8 Videos stimulus 3/28/2022 4:28 PM  File folder
i Local Disk (C3) synthesis 3/29/2022 €02 PM  File folder
= DATA SSD (E) tooldata 3/29/2022 6:03 PM File folder

= Elements (Z3)
= Elements (Z3) v <
Folder: | 5C2021v3_Workspace
Select Folder Cancel

Figure 60 - Selecting the SoftConsole workspace

e\
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3. Click Launch in the Workspace Launcher to open the SoftConsole GUI. Then click OK when asked to create a new

workspace.

sc SoftConsole v2021.3-7.0.0.599 Launcher

Select a directory as workspace

SoftConsole v2021.3-7.0.0.599 uses the workspace directory to store its preferences and development artifacts.

9
Workspace: \SMF2000-M3_BaseDesign\SC202 1v3_Workspacejid Browse...

[J Use this as the default and do not ask again

» Recent Workspaces

Figure 61 — Eclipse Launcher with workspace selected.

4. The SoftConsole GUI will open.

b

Figure 62 - SoftConsole GUI

- 8 x

Hrss

If the workspace launcher did not open, select File > Switch Workspace > Other and navigate to the workspace location

shown on the previous page.
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5. Import the SoftConsole Projects by selecting File > Import... from the SoftConsole menu. The Import dialog box will

open. Expand General and select Existing Projects into Workspace then click Next.

6. Enter the following in the Import Projects dialog box then click Finish:

e Selectro

Browse to C:\Microsemiprj\SMF2000-M3_BaseDesign\SoftConsole

SC Import

Select

Select an import wizard:

type filter text

Create new projects from an archive file or directory.

v (= General
JE Archive File

| =% Existing Projects into Workspacel

3 File System
=] Preferences
2 Projects from Folder or Archive

= C/C++
= Git
= Install
@' < Back Finish Cancel

Figure 63 - SoftConsole Import dialog box

ot directory:

Click Select Folder in the Select Folder dialog box.

e Projects:

“SF2_GNU_SC4_pwm_slow_blink” checked

e Options:

“SF2_GNU_SC4_RTC_time” checked

o Search for nested projects: un-checked (default)

o Copy projects into workspace: checked (default)

o Close newly imported projects upon completion: un-checked (default)
o Hide projects that already exist in the workspace: un-checked (default)

e C(Click Finish to import the two projects into the current Workspace.
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- - - i
SC |mport O *
Import Projects B
Select a directory to search for existing Eclipse projects. d
@ Select root directory: | CA\SWA\FPGA\Libero_projects\ArrowComeHome_Apr2022\SMF2000-M3_BaseDesign\SoftConsole V| Browse...
O Select archive file: Browse...
Projects:
rtc_time (C\SWN\FPGA\Libero_projects\ArrowComeHome_Apr2022\SMF2000-M3_BaseDesign\SoftConsaole\SF2_GMNU_SC4_RTC_time) Select All
SF2_pwm_slow_blink (C\SWN\FPGA\Libero_projects\ArrowComeHome_Apr2022\SMF2000-M3_BaseDesign\SoftConsole\SF2_GNU_SC4_pwm_slow_blink)
Deselect All
Refresh
Options
[ Search for nested projects
Copy projects into workspace
[ Close newly imparted projects upon completion
[J Hide projects that already exist in the workspace
Working sets
[J Add project to working sets New...
Working sets: Select... |

® < Back Next = Cancel

Figure 64 - Importing the sample projects into the workspace
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7. The SoftConsole projects will be visible in the SoftConsole Project Explorer.
SC M25_5CE5_workspace - SoftConsele v6.5.0.442 — O >
File Edit Source Refactor Mavigate Search Project Gt Run  Window Help
| & ~in|mmme sz @0~ 0 -QG-B® g~ 4t M Q B|IEFS
5 Projectbspl... 22| = O = B 5= Outli.. 32 & Expr.. =¥ Disa = 8
B8 Y §
5 rte_time There is no active editor that provides an
= SF2_pwm_slow_blink outline.
()= Viariabl Registers = 0
ZﬁﬁDe... 3 % Br = B B B ac T : = - . x)= Variables &3 g
Problems Warkers onsole ermina Search [} Debugger Console 2 & g
B I+ 3 S 3 Debugg e | i ed 8
4 # B[
Mo consoles to display at this time.
0 itemns selected

Figure 65 - SoftConsole projects in the workspace

8. Close the Rtc_time project by selecting the project name in the Project Explorer then right-clicking and selecting
Close Project.

Page 46 of 76 v1.5



SmartFusion2 ARM Cortex-M3 Lab Guide MICFIQOCHIP

Importing the firmware configuration files

9. Import the firmware configuration files that were exported from Libero® SoC into the SF2_pwm_slow_blink project
by selecting SF2_pwm_slow_blink in the Project Explorer then selecting File > Import from the SoftConsole menu.
The Import dialog box will open.

10. Expand the General category in the Import dialog box and select File System and then click Next.

SC Import m} X
Select N
=9
Import resources from the local file system into an existing project.

Select an import wizard:

type filter text

1= Existing Projects into Workspace -
(3 File System
[l Preferences
22 Projects from Folder or Archive
= CfC++
= Git
= Install
= Run/Debug
= Team v

Figure 66 - Importing the firmware configuration files

11. The File system dialog box will open. Click the Browse button. Navigate to the
C:\Microsemiprj\SMF2000-M3_BaseDesign\firmware folder and click Select Folder.
12. Enter the following in the File system dialog box:
e From directory:

C:\Microsemiprj\SMF2000-M3_BaseDesign\firmware

e Select

o Click next to the firmware folder in the left window pane to expand it (circled in the figure below)
o Make sure the following folders are enabled (checkmark):

= CMSIS

= drivers

= drivers_config
= hal

o With firmware folder selected on the left side, un-check “README.txt”, “SF2_MSS_cmsis.svd.xml” and
“SF2_MSS_hw_platform.h” on the right side

e Into Folder: SF2_pwm_slow_blink
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SC Import O bt

File system B
Import resources from the local file system. 'd

From directory: | C\SW\FPGA\Libero_projects\ArrowComeHome_Apr2022\5MF2000-M3_BaseDesign\firmware v| ‘ Browse... |

v [m] (= firmware (] |2/ README.txt
> = CMSIS O E sF2_mss_cmsis_svd.xml

> &= drivers L] [€ SF2_MSS_hw_platform.h
> = drivers_config

» O &= filelist
> = hal

| FiterTypes.. || SelectAll || Deselect Al

Into folder: | SF2_pwm_slow_blink | ‘ Browse...

Options
(] Overwrite existing resources without warning

[ Create top-level folder

@ < Back Next > Finsh | | Cancel

Figure 67 - Importing the firmware configuration files into the project
13. Click Finish. Click Yes To All in the Question dialog box when prompted about Overwriting files.
| 8C Question X

@ Overwrite "hw_reg_io.h" in folder 'SF2_pwm_slow_blink\CMSI5'?

| Yes | vesomr || No || NoToAl ||  Cancel

Figure 68 - Question dialog box
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14. The project should appear in the Project Explorer as shown in the figure below.

5 Project Explorer i2 BS Y 8 = 8

0 rtc_time
v 15 SF2_pwm_slow_blink
> il Includes
> = CMSIS
» = drivers
» = drivers_config
» = hal
s [€ main.c
> [n platform.h
= READMEtxt

W
Il

Figure 69 - SF2_pwm_slow_blink after importing the firmware configuration files

15. Double click main.c in the Project Explorer window to open the file in the SoftConsole C/C++ editor. Scroll through
the file to become familiar with it.

i) main.c Xl = o
1_/t*************t******k********************************************************* -~
2 * (c) Copyright 2015 Microsemi SoC Products Group. B2ll rights reserved.
2 *
4 * This example project demonstrates control control the duty cycle of
5 * individual PWM outputs
3 *
7 * Please refer to the file RERDME.txt for further details about this example.
*
*

SVN SRevision: 8042 S
* SVN SDate: 2015-10-13 17:53:12 40530 (Thu, 15 oct 2015) 3
*/

#include "platform.h"

#include "core pwm.h"

oW o

_/t******t******t******t**********************k*************k******k******k*****

* Delay count used to time the delay between duty cyvcle updates.
t******k******t******t**********************k*************k******k******k****/

#define DELAY COUNT 10000

SRR LA =S TV SR

:—/k*************#***************************************************************

* PWM prescale and period configuration values.
#******#******#******#*******************************************************/

#define PWM_PRESCARLE 8
#define PWM_PERIOCD 100

_/k*************#******k********************************************************

S SR

* CorePWM instance data.
#******#******#******#*******************************************************/

pwm_instance t the pwm;

LS L T 6 T S T S T 6 T o B S R S B o I S B i i e e B e B e e B e B el
[ BT R w's]

oo oo

Figure 70 - main.c in the SoftConsole editor
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16. Double click platform.h in the Project Explorer window to open the file in the SoftConsole C/C++ editor. Compare
the COREPWM_BASE_ADDR on line 16 to the address recorded on page 40. Modify and save the file if necessary.

Hint: The default address value shown below is incorrect and needs to be updated according to the memory map.

e main.c | [8 platform.h 2

1= "f*******************************************************************************

*

Platform definitions.

SVN $Revision: $
SVN $Date: $
*/

#ifndef _ PLATFORM_H_
10 #define _ PLATFORM_H_

2
3
4 *
5 =
5 *
7 *
8
9

* (c) Copyright 2015 Microsemi SoC Products Group. All rights

reserved.

4

12& /-‘k-‘k-‘k-‘k#-‘k-‘k-‘k-‘k-‘k-‘k-‘k-‘k-‘k-‘k-‘k:k-‘k-‘k-‘k-‘k-‘k-‘kk-‘k-‘k-‘k-‘k-‘k-‘k#-‘k-‘k-‘k-‘k#{-‘k-‘k-‘k-‘k-‘k-‘k*###*#*#***#*#### :5

13 * Peripherals base addresses
14 */
15

#define COREPWM_BASE_ADDR

16

17

18 #endif /*_ PLATFORM_H_*/
o

9x50001000UL

#ifndef SF2 MSS_HW_PLATFORM H_
#define SF2_MSS_HW_PLATFORM H_
] /o kAR KRR KKk KKK KKK R KKK KRR

*Created by Microsemi SmartDesign Wed Mar 10 09:33:14 2021

*Memory map specification for peripherals in SF2_MSS

Les

B
* CM3 subsystem memory map
* Master(s) for this subsystem: CM3

#define COREPWM 0 0 0x5000_0000U

#endif /* SF2_MSS_HW_PLATFORM H */

Compare address to the memory map in
the Libero project and modify as needed

Figure 71 - platform.h in the SoftConsole editor

Confirming the SoftConsole Project Settings
The next steps to confirm the sample project settings prior to performing a build. SoftConsole supports multiple build
configurations. By default, projects contain two build configurations: Debug and Release. Some project settings apply to
all build configurations while others apply to a specific build configuration.

17. Open the Project Properties dialog box by clicking on the project name (SF2_pwm_slow_blink) in the Project
Explorer and selecting Project > Properties.
18. Navigate to C/C++ Build > Settings in the Properties for SF2_pwm_slow_blink dialog box.
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type filter text
Resource
Builders
~ C/C++ Build
Build Variables
Environment
Logging
Settings
Tool Chain Editor
C/C++ General
Linux Tools Path
MCU
Project References
Run/Debug Settings
Task Repository
Task Tags
Validation
WikiText

SC Properties for SF2_GNU_SC4_pwm_slow_blink

Settings

ICUmﬁguratiUn: Debug [Artive]l

& Tool Settings & Toolchains # Build Steps

(% Target Processor
(& Optimization
(& Warnings
(% Debugging
~ 1 Cross ARM GNU Assembler
(& Preprocessor
2 Includes
& Warnings
(& Miscellaneous
~ & Cross ARM C Compiler
(2 Preprocessor
2 Includes
(2 Optimization
(& Warnings
(& Miscellaneous
~ 1 Cross ARM C Linker
(& General
(2 Libraries
(2 Miscellaneous
~ & Cross ARM GNU Create Flash Image
2 General
~ & Cross ARM GNU Print Size
(2 General

ARM family caortex-m3
Architecture Toolchain default
Instruction set Thumb (-mthumb)

[ Thumb interwork (-mthumb-interwork)

Endianness Toolchain default
Toolchain default
Toolchain default

Unaligned access  Toolchain default

Generic (-mcpu=generic)

Toolchain default
Toolchain default
Toolchain default

Enabled (+simd)

Small (-mcmodel=small})

Strict align (-mstrict-align)

Build Artifact Binary Parsers @ Error Parsers

~ | |Manage Configurations...

Other target flags

Apply and Close Cancel

Figure 72 - Project Properties dialog

MICROCHIP

Select different Build configurations by using the pull-down menu in the Configuration field of the Project Properties
dialog box (highlighted in the figure above). Some project settings are applicable to all build configurations while others
are for a specific build configuration.

19. Select Configuration = [All configurations] to configure settings applicable to both the Debug and Release build
targets.

Settings ~ —

| Configuration: _[Mh:nn-ﬁguralmnﬂ

x| ?Mmage Configurations... .

Figure 73 - Selecting all build configurations

20. Select Cross ARM C Compiler > Includes on the Tool Settings tab. Confirm that the Include paths (-I) field contains
the following:
e .. /drivers_config/sys_config
e ../drivers/CorePWM
e .. /CMSIS
e ../hal/CortexM3/GNU
e ../hal/CortexM3

e . /hal
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Settings

= A=

| »

|Configuration: ’5[ All configurations ] | '] [Manage Configurations...
—

i Tool Settings | ] Tooichainsl 45 Build Steps Build Artifactl Binary Parsers | @ Error Parsers

(%2 Target Processor

Include paths (-I)

= €8 87 #
% a::?:ga:lon o drers_conﬁ 1
Lfdrivers/CorePWH
(% Debugging JCMSIS
4 133 Cross ARM GNU Assembler ./hal/CortexM3/GNU
(2 Preprocessor -/hal/CortexM3
@ Includes "
=5 Warnings /hal

@ Miscellaneocus
4 %3 Cross ARM C Compiler
Preprocessor
(2 Includes
Optimization
% Warnings

m

Figure 74 - Project Include paths

If necessary, add or modify the Include paths by clicking the Add directory path button ( € ) or the Edit directory path
button ( = ).
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21. SmartFusion2® projects require a setting in order for the preprocessor to find the toolchain CMSIS header files.
Select Cross ARM C Compiler > Miscellaneous on the Tool Settings tab. Confirm that the Other compiler flags field

contains -—-specs=cmsis.specs.

i Tool Settings | B3 Toolchains | 4 Build Stepsl

Build Artifactl Binary Parsersl @ Error Parsersl

1Y

1Y

(% Target Processor
(# Optimization
@ Warnings
(%2 Debugging
B3 Cross ARM GNU Assembler
(22 Preprocessor
@ Includes
(2 Warnings
@ Miscellanecus
B3 Cross ARM C Compiler
@ Preprocessor
(2 Includes
(28 Optimization

Warnings
@ Miscellaneous
B3 Cross AR C Linker

(2 General
@ Libraries
(2 Miscellaneous
B3 Cross ARM GNU Create Flash Image
(2 General
B3 Cross ARM GNU Print Size
(2 General

Figure 75 - Confirming the Cross ARM C Compiler Other compiler flags setting

[[] Generate assembler listing (-Wa,-adhlns="3@.lst"}

[] Save temporary files (--save-temps Use with caution!)
[ Verbose (-v)

|Other compiler flags  --specs=cmsis.specs I

The appropriate linker script must be configured for the project build configuration. The sample projects include linker
scripts bundled with the CMSIS/HAL firmware core. Follow the steps below to confirm the linker script setting for the

Debug and Release build configurations.

22. Select Configuration = Debug [Active] from the pull-down menu in the Configuration field of the Project Properties
dialog box.

23. Select Cross ARM C Linker > General on the Tool Settings tab of the Project Properties dialog box. Confirm that the

Script files (-T) contains ../CMSIS/startup_gcc/debug-in-microsemi-smartfusion2-esram.ld. This linker script builds
an application that runs from the SmartFusion2® eSRAM.
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Settings

»

|Configuration: [DEbug [ Active ] I ‘] ’Manage Configurations...

i Tool Settings | 3 Toolchains | 4 Build Steps | Build Artifactl Binary Parsers | @ Error Parsers

(% Target Processor Script files (-T) i Iﬁl IG'
@ Optimization
T

(B Wamings ../CM5I5/ startup_gcc/debug-in-microsemi-smartfusion? -esram.ld
(% Debugging
a4 8 Cross ARM GNU Assembler
(2 Preprocessor
@ Includes
(# Warnings
(2 Miscellaneous
4 B Cross ARM C Compiler
(% Preprocessor
2 Includes
(2 Optimization
@ Warnings
(# Miscellaneous

BAL Linker
IL% General |

nraries

m

@ Miscellanecus

Figure 76 - Debug configuration linker script

24. Select Configuration = Release from the pull-down menu in the Configuration field of the Project Properties dialog
box.

25. Select Cross ARM C Linker > General on the Tool Settings tab of the Project Properties dialog box and confirm that

the Script files (-T) field contains ../CMSIS/startup_gcc/debug-in-microsemi-smartfusion2-envm.ld. This linker
script builds an application that runs from the SmartFusion2® eNVM.

Settings

| »

Coenfiguration:

'] lManage Configurations...

& Tool Settings | ] Toolchainsl 4 Build Stepsl Build Artifactl Binary Parsersl @ Error Parsers

(2 Target Processor
@ Optimization e - - - -
= . JSCMSIS/startup_gece/debug-in-microsemi-smartfusion?-envim.ld
(22 Warnings
(%2 Debugging
4 % Cross ARM GNU Assembler
(2 Preprocessor
22 Includes
@ Warnings
(22 Miscellaneous
4 [ Cross ARM C Compiler
(2 Preprocessor
(2 Includes
(% Optimization
(2 Warnings
(22 Miscellaneous

BRALC Linker

ibraries

Script files (-T)

88 8 4l 2

m

Figure 77 - Release configuration linker script

26. After confirming the settings listed in the previous steps, click Apply and Close in the Properties for
SF2_pwm_slow_blink dialog box.
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Building the Project

After configuring the project settings, the next step is to build the project. The build configuration may need to be set
prior to building the project. SoftConsole selected GUI should be in C/C++ entry mode

SC M25_SCB5_workspace - SF2_pwm_slow_blink/main.c - SoftConsole v6.5.0.442

File Edit Source Refactor Mavigate Search Project Run Window UltraDevelop Help

- ul X
=5 | ® -] - @ UE O | w | g | S @ - - HF- Q- - -@E L~ Bl -0 & - o - | A
Q x| 1]Ek s
5 Project Explorer 5 BEY & =0 [§ main.c 32 = B 5 Outline 5 (@ Build Targets = A
S rte_time ! ~ 2w e 8
~ 125 SF2_pwm_slow_blink 2 (c) Copyright 2015 Microsemi SoC Preducts Group. ALl rights reserved. B R ®
il Includes Iz

U platform.h

BN care mae b

27. Select SF2_pwm_slow_blink in the Project Explorer and then selecting Project > Build Configurations > Set Active.

Confirm that a check mark appears next to Debug indicating it is the selected build configuration. If necessary click
Debug.

5C M25_5C65_workspace - SF2_pwm_slow_blink/main.c - SoftConsole v6.5.0.442

Eile Edit Source Refactor Mavigate Search  Project  Run Window  UltraDevelop

Help
i | BB @ e O Open Project B S S HFEr -G
Close Project
¥ Project Explorer 3 = <_E‘> l? mg  Build All Ctrl+B
=5 rtc_time Build Configurations » Set Active ¥
v 1= SF2_pwm_slow_blink Build Project Alt+B Manage... 2 Release
[}t Includes - - e
= CMSIS Build Working et ] Build by Working Set s [he duty cycle of
= drivers LT Set Active by Working Set »
[ drivers_config Build Automatically Manage Worling Sets... ils about this exar
% hal. Build Targets » g
main.c 5 17:55:12 +8538 (Thu, 15 Oct 2015) $
[n| platform.h C/C++ Index »
2/ README.txt
Properties Ctrl+Alt+Shift+P

Figure 78 - Selecting the build configuration

28. With the project name still selected in the Project Explorer, select Project > Build All or by clicking the Build All icon

("™ ) on the SoftConsole toolbar to build the project. The results of the build process can be viewed in the Console
view and the Problems view. Confirm that there are no errors or warnings in the Problems view.

[¥] Problems 22 | 2| Tasks [l Console [T Properties ¢ =~ — O
0 iterns

Description Resource Path Location Type

Figure 79 - Problems view after building the project
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Debugging with SoftConsole

After building the project, the next step is to use the SoftConsole debugger to run the application on the SmartFusion2®
Cortex-M3. Before using the On-chip Debugger (OCD), the debug launch configuration must be created.

Creating a debug launch configuration

29. Select SF2_pwm_slow_blink in the SoftConsole Project Explorer View.
30. Select Run > Debug Configurations... from the SoftConsole menu. The Debug Configurations dialog will open.

31. Select GDB OpenOCD Debugging in the Debug Configurations dialog box then right-click and select New
Configuration to create a new debug launch configuration for the Debug build configuration.

SC Debug Configurations [m] hed

Create, manage, and run configurations

i |§ < | = [? M Configure launch settings from this dialog:

| type filter text | - Press the 'New Configuration' ...figuration of the selected type.

[£] GDB OpenOCD Debu ne' butt... prototype of the selected type.

. New Configuration
. Launch Group I; Mooy L. I to export the selected configurations.
v Sf UltraDevelop Agent i SWETORYH New launch configuration
S6 PolarFire SoC Ultrz § Export... copy the selected configuration.

Duplicate n to remove the selected configuration.

Delet ; S -
See tton to configure filtering options,

IR oy e ing configuration by selecting it.

Unlink Prototype
tion(s)...' menu item to link a prototype.

Reset with Prototype Values
stion(s...enu item to unlink a prototype.

Figure 80 - Creating a new debug launch configuration

32. Ensure that the C/C++ Application field on the Main tab of the Debug Configurations dialog box contains
Debug\SF2_pwm_slow_blink.elf
§¢ Debug Configurations m]

Create, manage, and run configurations

EECNER AN

Name: | SF2_pwrm_slow_blink Debug

| type filter text | [2 Main . 35 Debugger| & Startup| &+ Source| [ Common | ™
v [£] GDB OpenOCD Debugging

[t] SF2_pwm_slow_blink Debug
/A Launch Group ‘ SF2_pwm_slow_blink Browse...

Project:

C/C++ Application:
‘ DebughSF2_pwm_slow_blink.elf

Variables... Search Project... Browse...

Build (if required) before launching

Build Configuration: | Select Automatically ~
O Enable auto build O Disable aute build
@ Use workspace settings Configure Workspace Settings...
< >
Revert Apply

Filter matched 3 of 11 items

Figu-ré 81- Dél_)-ugl-z;uh-cﬁ.configuration
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33. Select the Debugger tab of the Debug Configurations dialog box. The Config Options field must contain the correct
command line options/script to be passed to OpenOCD, that has to be enabled, in case it is not.

34. Enter --command "set DEVICE M25010" --file board/microsemi-cortex-m3.cfg in the Config Options field.
--command "set DEVICE M2S0XX" specifies the target device, modify based on the target silicon.
--file board/microsemi-cortex-m3.cfg is a board script for the integrated Cortex-M3 core of
SmartFusion2®

35. Scroll to the GDB Client Setup field on the Debugger tab. Confirm that the following appear:
e Executable: ${cross prefix}gdb${cross suffix}
e (Commands: set mem inaccessible-by-default off. If necessary, delete the lines “set arch

riscv:rv32” and “set riscv use compressed breakpoints no”

CEeRX BY- Name:| SF2_pwm_slow_blink Debug

‘ type filter text | [l Main |35 Debugger “._B Startup| % Source| [J Common | ., SVD Path f

~ [&] GDB OpenOCD Debugging OpenOCD Setup

[€] SF2_pwm_slow_blink Debug | Start OpenOCD \ocal\yl

& Launch Group

Executable path: |S{openocd_path)/S{opemocd_executable) Browse.. | Variables...

Actual executable: | CAMicrochip\SoftConsale-v2021.3-7.0.0.599\eclipse'/../openocd/bin/openocd.exe

(to change it use the global or workspace preferences pages or the project properties page)

GDB port: 3333
Telnet port: 4444
Tcl port: 6666
Config options: --command "set DEVICE M25010" --file board/microsemi-cortex-m3.cfg l
Allocate console for OpenOCD Allocate console for the telnet connection

GDB Client Setup
Start GDB session

Executable na[ve: | S{cross_prefixjgdbS{cross_suffix)

Browse...| | Variables...

Actual executable: | arm-none-eabi-gdb |

Other options:

Commands: [ set mem inaccessible-by-default off l

Remote Target
Host name or IP address:  localhost
Port number: 3333 |

[ Force thread list update on suspend

Restore defaults

Filter matched 3 of 11 items Revert Apply

Figure 82 - SoftConsole Debugger tab settings for the SmartFusion2® SMF2000 kit
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36. Select the Startup tab and confirm that the default settings are configured as shown in the figure below.

o Disable (un-check) “Pre-run/Restart” under Run/Restart Commands and enable (check) “Enable ARM
semihosting”

FEoEX BT -

MName: ‘ SF2_pwm_slow_blink Debug
‘ type filter text

| = Main 1$'§>'-Del:»uggskr' ¥ Startup 1 Source| 1 Common | 2, SVD Path

~ [c] GDB OpenOCD Debugging Initialization Commands

[c] SF2_pwm_slow_blink Debug Initial Reset. Type:
& Launch Group

[ Enable ARM semihosting l

Load Symbols and Executable
Load symboals
® Use project binary: SF2_pwm_slow_blink.elf

O Use file: Workspace... File System...

Symbols offset (hex): l:l

Load executable
(® Use project binary: SF2_pwm_slow_blink.elf

O Use file: Workspace... File System...

Executable offset (hex): I:I

Runtime Options
[ Debug in RAM

Rur/Restart Commands
[ Pre-run/Restart reset Type:] halt

[ set program counter at (hex):

Set breakpoint at:

Continue

Restore defaults

Revert Appl
Filter matched 3 of 11 items evel pply

Figure 83 - Startup tab settings
37. Click Apply to save the changes.
38. Click Debug to launch the Debugger. Click Switch in the Confirm Perspective Switch dialog box. If you’re not asked

to switch, you can do it manually selecting the icon ks

¥ - L - L == -
|iz 8 = B

!
L1

)= Variables ®e Breakpoints | i Registers &2 =i Modules % Peripherals

The SoftConsole Debug perspective will open. The code will be downloaded to the SmartFusion2® SMF2000 board.

The program will be suspended at the first line of main() as shown in the figure below. Use for example F6 key to
execute code single lines (Step Over).
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= main() at main.c:41 (x2000144e
»| openocd.exe
s arm-none-eabi-gdb

[ main.c 22

2 * Local function prototype.
3

4 woid delay( void );

uint32_t duty cycle = 13
int direction = 1;

B

* Initialize the CorePWM instance setting the prescale and peried values.

/

Pi_init( &the_pwm, COREPWM_BASE_ADDR, PWM_PRESCALE, PWM_PERIOD ) ;

B Console 5% | | Tasks [*] Problems (3 Executables @Debuggar(onsole [ Memory

SF2_pwm_slow_blink Debug [GDE OpenOCD Debugging]
(13) sp (/32): @x20910000 (dirty)

(14) 1r (/ BxBaRRRRRE (dirty)
(15) pe (/ @x20098199 (dirty)
(16) xPSR @x@100006@ (dirty)
(17) msp { 820016000

(18) psp (/3
(19) primask (/ axaa
(2@) basepri (/8): exea

MicRoOCHIP
SC M25_SCH5_workspace - SF2_pwm_slow_blink/main.c - SoftConsole v6.5.0.442 - [m] X
Eile Edit Source Refactor Navigate Search Project Run Window UltraDevelop Help
- @~ O TE oD ®Nze. el | & @-e-[&-@- e v H-O0-QL-SE -
G Blv o v v Q E| RS
3 Debug 2 = (i3 | i# & = B8 - \Varables 2 Breakpoints Registers odules Penphera i Ell et § =8
w [£] SF2_pwm_slow_blink Debug [GDB OpenQCD Debugging] Name Type Value
~ (12 SF2_pwm_slow_blink.elf 4= duty_cycle uint32_t ]
~ of# Thread #1 (Suspended : Breakpoint) )= direction int 0

= B8 5= Outline 2
platform.h

Bl®R e ¥ =0

core_pwm.h
DELAY_COUNT
PWM_PRESCALE
PWM_PERIOD

the_pwm : pwm_instance_t
delay(void) : void
mainfveoid) ; int
delay(void) : void

e e T @HUHHLELE

BX % EMEEE ve-0- 0

A

Figure 84 - SoftConsole Debug perspective

Running the pwm_slow_blink Application

39. Start the Cortex-M3 software application by clicking Run > Resume from the SoftConsole menu. The LEDs will

appear as shown in the table below.

LED State

LED D1 (green) ON

LED D2 Blinking (PWM),
gradually get dimmer
and brighter quickly

Others Off

Table 2 — SMF2000 board LED states

40. Suspend the software application by clicking Run > Suspend from the SoftConsole menu or by clicking the Suspend

icon ( |:":I) on the SoftConsole Toolbar.
41. Open the Registers view (Window > Show View > Registers).

42. Select the Registers view on the lower window pane to view the value of the Cortex-M3 internal registers as shown

in the figure below. Your values may differ. If the Registers view is not visible, open it by selecting Window > Show

View > Registers. If Registers field is not visible, click Others and look in the Debug folder, then click Registers and

Open.
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B Console ! Registers 2 |[%] Problems €3 Executables & Debugger Console 0 Memory

Name Value
~ 5% General Registers
i ro 0x50000008
i Ox1
it r2 Ox270f
Wi OxfOf
it rd 0x0
it rs 0x0
it re O0x11
it r7 0x2000ffe0
it r8 0x0
st r9 0x0
W r10 00
i 0x0
12 0x20e2a368

LB i = 0
Description &
General Purpose and FPU Register Group
v
>

Figure 85 - Cortex-M3 registers

43. Choose Window > Show View > Disassembly to display the assembly level instructions. The Disassembly window
will open on the right side in the middle of the Debug perspective as shown in the figure below.

SC M25_! _workspace - SF2_pwm_slow_blink/main.c - SoftConsole v6.5.0.442 — m] x
File Edit 3Source Refactor Mavigate Search Project Run  Window UltraDevelop Help
il B MEE e R|(|BEE SO B-E20 -2 2H5-0-LW- ™8 ¢~ R CRCR SRS ¥
35 Debug 53 B %@ |3 &8 = 8 e-varables 2 ° s o & L BE it § =0
~ [ SF2_pwm_slow_blink Debug [GDBE OpenOCD Debugging] Name Type Value
v il SF2_pwm_slow_blink.elf ()= counter wvolatile int 4323
w o Thread #1 (Suspended : Signal : SIGINT:Interrupt)
= delay() at main.c:89 (x200014b2
= main( at main.c:63 0:2000147c
wl openocd.exe
p] arm-none-eabi-gdb
n| pl (€] main.c 33 = B | &= Outline |22 Disassembly 33 Enter location here Y& BiBlE| s 82 = 8
o duty_cycle += direction; " 200014b0:  ldr r3, [r7, #4] "
if ( duty_cycle »= PWM_PERIOD ) » 200014b2: adde r3, #1
di . _ . 268614b4; str r3, [r7, #4]
irection = -1; 87 while ( counter < DELAY_COUNT )
}1 v oa e 280014b5:  ldr r3, [r7, #4]
else if ( duty_cycle == @ ) 200014b3:  moww  r2, #9999 ; exaref
" . .. 288014bc: cmp r3, r2
irection = 1; 260014be:  ble.n  Bx200014bd <delay+12>
91 1
H 280814c@: nop
268014c2: nop
268014c4: adds r7, #12
280814c6: mov sp, r7
268014c8: 7.
* Delay function. 29981423' ﬁp i: !
, :
. . ! _ libc_init_array:
53= void delay( void ) 268614cc: push {r4, r5, r6, 1Ir}
latile i o 288814ce: ldr r6, [pc, #52] ; (ex2eealses <_ libc_init_array+56:)
volatile int counter = 8; 200014d0:  ldr r5, [pc, #52] ; (Bx20001588 < libc init array+6@s)
. 268614d2: subs ré, ré, r5
while ( counter < DELAY_COUNT ) 286814d4: asrs r6, ré, #2
- 200014d6: beq.n  @x20@@14e6 <_ libc_init array+26>
countertt; 208014d5:  movs  ra, #@
} 2880814da: ldr.w  r3, [r5], #4
266814de: adds rd, #1 ©
4 RO L -
El Console 5% | Tasks Problems E i |§Eﬁid§'@\:5'[‘j'=‘ ]
5F2_pwm_slow_blink Debug [GDB OpenOCD Debugging]
(18) psp (/32): @x4648D628 ~
(19) primask (/1): exee
(20) basepri (/8): exee
(21) faultmask (/1): @x@e v

Figure 86 — SoftConsole Disassembly view

44, Scroll in main.c and locate PWM_PERIOD on line 24.
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[£] main.c &3

45.

2@

12 #include "platform.h”
13 #include "core_pwm.h"
14

* (c) Copyright 2815 Microsemi SoC Products Group.

211 rights reserved.[] -

m

16
17
18 #define DELAY_COUNT
19

202 /*
21
22
23 #define PWM_PRESCALE 8
24 #define PWM_PERIOD 100

laaae

* CorePWM instance data.

eriod configuration values

29 pwm_instance_t the_pwm;
e

Figure 87 - PWM_PERIOD in main.c

Changing the value of PWM_PERIOD on line 24 will change the toggle rate of the LED. Try changing the value then

save the file (File > Save). A larger value for the period will make the LED toggle more slowly.

46.
47.

Build the project by selecting Project > Build All. Select the Problems View and confirm that there are no errors.
Select SF2_pwm_slow_blink.elf under the Debug tab in the upper left corner of the SoftConsole Debug Perspective.

Right-click and choose Terminate and Relaunch to stop the debugger and download the new application.

% Debug 2 | I3 Project Explorer

~ [E] SF2_GNU_SC4_pwm_slow_blink Debug [GDB OpenOCD Debugging.
~ [ SF2_GNU_SC4 _pwm_slow_blink.&“"_r

~ ® Thread #1 (Suspended : Sign

1 openocd.exe
Wi arm-none-eabi-gdb

i+ = 0O

=l Copy Stack

delay() at mainc89 0x200  Nd-

main() at main.c:63 0x2000 Drop To Frame

Step Into

Step Over

Step Return
i+ Instruction Stepping Mode
Use Step Filters

Resume Without Signa
Resume

Suspend

Terminate

Terminate and Relaunch
Restart

Disconnect

Connect...

Debug New Executable..

& E

Remove All Terminated
Relaunch

Terminate and Remove

w8 ] &

Terminate/Disconnect All

Properties

[g] mainc 2

18 #define DELAY_COUNT

19

n platform.h

Ctrl+C
Ctrl+F

F8

Ctrl+F2

Edit SF2_GMNU_SC4_pwm_slow_blink Debug...

10000 ~

Bic s s s s o s o 38 3 3 3 o 3 K S ok R R R R R RO S R R R R RR R

period configuration values.
Bk kR R R R R kR R R R R R R R R R R R R kR R R R R R R R R R

E 8
800

P e o e e S SR SR S S S R e R S R S R R R R e R R R R

data.
e s o e o o O KR R R R KR R KR R R

pwim;

P e o e e S SR SR S S S R e R S R S R R R R e R R R R

rototype.
Bl st 3K K SR KA KR SR AR K SRR K SRR SRR KRR KRR K

Problems Executables &} Debugger Console

Memon

4_pwm_slow_blink]

[T ey sty e S T s e T T Sy ey e

dec hex filename
65536 10008 SF2_GNU_SC4_pwm_slow_blink.e:
sNU_SC4_pwm_slow_blink.siz

@ errors, @ warnings. (took 3s.182ms)

Figure 88 — Terminating and re-launching the debugger

48. Run the application by clicking Run > Resume from the SoftConsole menu. The LED will toggle at a different rate.
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Driving two LEDs
The application in the sample project only drives one LED, but CorePWM was configured to drive two outputs. Follow
the steps below to modify the application to drive two LEDs.

49,
50.

51.

52.
53.

54.
55.
56.

Terminate the software application by clicking Run > Terminate from the SoftConsole menu.

Scroll in main to the section with the comment “* Set the initial duty cycle for CorePWM output 1.” on
line 50. This line configures one CorePWM output.

Copy the line “PWM_set_duty cycle( &the_pwm, PWM_1, duty cycle );”and paste it below the existing line.
Modify the line to drive PWM_2.

Scroll to the section with the comment “* Update the duty cycle for CorePWM output 1.”” on line 58.

Copy the line “PWM_set_duty cycle( &the pwm, PWM 1, duty cycle );”and paste it below the existing line.
Modify the line to drive PWM_2. Save the file after making the edits above.

[€ main.c 22 | [n] platform.h = &

9= int main( void ) it

uint32_t duty_cycle = 1;
int direction = 1;

! 1n:+ance ;e**lng Fhe RE e:cale and pe lcd ualue;
: 3 3 3 ik

P 1n1t( &the_pwm, COREPWM_BASE_ADDR, PWM_PRESCALE, PWM_PERIOD ) ;

" Set fhe 1n1f1al duf; c;cle f0’ CoreP cufpuf 1

PWM_set duty_cycle( &the_pwm, PWM I, duty_cycle ),
PWM_set_duty_cycle( &the_pwm, PWM 2, duty_cycle ); // add te drive a second LED

m

while ( 1)

PhN set dL.rt}\ur cycle( &the pme PM‘I 1 dl.lty cycle H -

Figure 89 - Modified code to drive two PWM outputs

Repeat the previous steps to build the project. Confirm that there are no errors in the Problems View.

Re-launch the debugger (Run > Debug History > SF2_GNU_SC4_pwn_slow_blink Debug).

Run the application (Run > Resume) and observe the LEDs. Both LED D2 and LED D3 should toggle at the same rate.
When finished, terminate the application by selecting SF2_pwm_slow_blink.elf under the Debug view, then right-
clicking and selecting Terminate and Remove to stop the debugger. Click Yes when prompted about Terminating.
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45 Debug 32

a [T SF2_GMU_SC4_pwm_slow_blink Debug [GDB OpenOCD Debugging]

wE|i» == 8

4 |f32 SF2_GNU_SC4_pwm_slos

3@ Thread #1 (Running

w| openocd
s arm-none-eabi-gdb

[ main.c #2

ek e e o e e e

* Ini*’ial'

ek e e e e e e e e ek

Set the initial

PWM_set_duty_cycle
PWM_set_duty_cycle

while ( 1)
pEEEEEEEE RS
ek e

PluH set duty_

& Console 2 Tacks Pr
SF2_GNU_SC4_pwm_slow_blink Deb|

Pl 1r|1t( &the_pwn §

* Update the|:

_%

IL) UWil_Z_Comp (J3£]
(32) d'.-.'t_2_rrask (/4)
(33) dwt_2_function (/32)

Copy Stack
Find...

Drop To Frame

Step Into
Step Owver
Step Return

Instruction Stepping Mode
Use Step Filters

Resume Without Signal
Resume

[0 Suspend

Terminate

Terminate and Relaunch

Restart

v 8 @

Disconnect
&7 Connect...

Debug Mew Executable...

Remove All Terminated
Relaunch
E Edit SF2_GMNU_5C4_pwm_slow_blink Debug...

% Eerminate and Removej

[@ Terminate/Disconnect All

Properties

Ctrl+C
Ctrl+F

F5
T -
F7 ues.

p—
ek e

p—

F&
e a second LED

Ctrl+F2

EEEEEY

ek §

econd LE

e

(34) dwt 3 comp (/32%

Figure 90 — Terminating the application

57. Close the Debug perspective (Window > Perspective > Close Perspective).

58. Close the SF2_pwm_slow_blink project by selecting the project name in the Project Explorer then right-clicking and

selecting Close Project.
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Step 8 - Running the RTC_time application (time permitting)
In this step, you will open the Rtc_time sample project, import the firmware configuration files and run the application.

This sample project uses the SmartFusion2® RTC’s calendar function.

1.

4,

5.

Open the Rtc_time project by selecting the project name in the Project Explorer then right-clicking and selecting
Open Project.

Repeat the steps on pages 46 to 47 to import the firmware drivers and configuration files into the project.

Double click main.c in the Project Explorer window to open the file in the SoftConsole C/C++ editor. Scroll through
the file to become familiar with it. The comments at the top of the file describe what the program does.

Select Rtc_time in the SoftConsole Project Explorer. Build the project by selecting Project > Build All or by clicking
the Build All icon.
Confirm that no error messages appear in the SoftConsole Problems view.

Determining the COM port setting
This design requires a terminal emulator. The COM port assignment must be determined to configure the terminal

emulator.

6.

Open the Windows Device Manager and expand the Ports (COM & LPT) section.
e One port will appear as “FlashPro 5 Port”. Record the COM port number below.

USB Serial Port: CcCoOM

M Device Manager - O X

File Action View Help
e m B =
i Firmware ~
¥l Human Interface Devices
== |DE ATA/ATAPI controllers
<i% Imaging devices
— Keyboards
L1 Memory technology devices
u Mice and other pointing devices
B Monitors
@ Network adapters
§ Ports (COM &LPT)
W FlashPro5 Port (COMS)
M Print queues

= Printers
™

<

Figure 91 - Windows Device Manager showing COM port

Creating a debug launch configuration

7.
8.
9.

10.

Select Rtc_time in the SoftConsole Project Explorer View.

Select Run > Debug Configurations... from the SoftConsole menu. The Debug Configurations dialog will open.

Select GDB OpenOCD Debugging in the Debug Configurations dialog box then right-click and select New
Configuration to create a new debug launch configuration for the Debug build configuration.

Ensure that the C/C++ Application field on the Main tab of the Debug Configurations dialog box contains
Debug\Rtc_time.elf, otherwise Search Project and select the proper file.
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S¢ Debug Configurations [m] x

Create, manage, and run configurations ﬁ‘
|

) rﬁ b EX ‘ B ? h Name: ‘ rtc_time Debug ‘
| type filter text ‘ Main %% Debuggeﬂ B Stantup] Hp Suurce] B Commun] %, SVD Path]
v [£] GDB OpenOCD Debugging R @
[&] rtc_time Debug dee
@ Launch Group ‘ rtc_time ‘ ‘ Brreie= |
C/C++ Application:
‘ Debug/rtc_time.elf
Variables... | | Search Project... | ‘ Browse... |
Build (if required) before launching
Build Configuration: | Select Automatically V|
O Enable auto build O Disable auto build
® Use workspace settings Configure Workspace Settings... |
v
Revert Appl
Filter matched 3 of 12 items | v | ‘ A |
@ ‘ Debug | | Close |

Figure 92 - Debug launch configuration

11. Select the Debugger tab of the Debug Configurations dialog box. Confirm that the Config options field appears as
shown in the figure below.

SC Debug Configurations o x
Create, manage, and run configurations ﬁ‘
CEREX| OV - Neme: | 5F2_GNU_SC4_RTC_time Debug |
[type fitter tet ] Main | %5 Debugger = Startup| & Source| [[] Common| 2, SVD Path|
v [£] GDB OpenOCD Debugging OpenOCD Setup ~
SF2_GNU_SC4_RTC_time Debug Start OpenOCD locally
5 Launch Group -
@ Robot Executable path: | S{openocd_path}/S{openocd_executable} | |Browse...| | Variables...|
() Robot Remote Actual executable: | CAMicrochip\SoftConsole-v6.4\eclipse\/../openocd/bin/openocd.exe |

56 UltraDevelop Agent
56 UltraDevelop OCD
S UltraDevelop Remote Target

(to change it use the global or workspace preferences pages or the project properties page)

GDE port:

Telnet port:
Tel port: 5656

Config eptions: || -command "set DEVICE M25010" --file board/microsemi-cortex-m3.cfg |

Allocate console for Open0CD Allocate console for the telnet connection

GDE Client Setup
Start GDB session

Exccutable names| | S{cross_prefixlgdbScross suffi) | || Browse..| | Variables...|

Actual executable: | arm-none-eabi-gdb |

Other options: |

Commands: | et mem inaccessible-by-defaul off |

Revert Apply

Filter matched 8 of 15 items.

@

Figure 93 - SoftConsole device and board file settings for the SmartFusion2® SMF2000 kit
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12. Select the Startup tab. Confirm that the settings match the figure below.

SC Debug Configurations

Create, manage, and run configurations

CEeEX B Y- Name: | SF2_GNU_SC4_RTC_time Debug |
| type filter text | Main 3‘(\? Debugger | = Startup E/ Source] =] Qommorﬂ %_ VD Path]
w [£] GDB OpenOCD Debugging Initialization Commands ~

[T] SF2_GMU_SC4_RTC_time Debug Initial Reset. T - -
= = . Type: | init
i Launch Group -

@ Robot

@ Robot Remote

S6 UltraDevelop Agent

S UltraDevelop OCD

Sff UltraDevelop Remote Target

Enable ARM semihosting

Load Symbols and Executable
Load symbols
® Use project binary:  5F2_GNU_SC4 RTC_time.elf
() Use file: Workspace... File Systern...

Symbaols offset (hex): l:l

Load executable
® Use project binary:  SF2_GNU_SC4_RTC_time.elf
() Use file: Workspace... File Systern...

Executable offset (hex): l:l

Runtime Options
[]Debug in RAM

Run/Restart Commands
[] Pre-run/Restart reset Type: | halt | (always executed at Restart)
B

[]5et program counter at (hex):

Continue
v

Dact, A=faulbe

Revert Apply

Filter matched 8 of 15 items

® Debug | | Close

Figure 94 - Startup tab settings

13. Click Apply to save if changes were made.

Page 66 of 76 v1.5



SmartFusion2 ARM Cortex-M3 Lab Guide MICFIQOCHIP

Launching the Debugger
14. Click Debug or, if you already closed the dialog box, select Run > Debug Configurations to open it again. You can

also launch the debug configurations or the debugger by clicking the debug icon ( i ) in the SoftConsole tool bar.
15. Click Switch in the Confirm Perspective Switch dialog box or manually switch to the Debug Perspective as explained
in the previous exercise.

Configuring a Serial Terminal View
SoftConsole includes a built-in serial terminal view, which eliminates the need to run a separate serial terminal emulator
when connecting to a target board using a UART.

16. Select Window > Show View > Terminal to open a serial terminal. The Terminals view will be visible.

Bl Console [£! Problems 2 Executables {2 Terminal 2 | | & =0

Figure 95 - Terminal view in the Debug perspective

17. Click the Open a Terminal button (highlighted in the figure above) to configure the serial terminal.
18. Enter the following in the Launch Terminal dialog box then click OK:

e Choose terminal: select Serial Terminal from the pull-down menu

e Port: Enter the COM port number recorded on page 63.

e Baud rate: 115200

e Data Bits: 8

e Parity: None

e Stop Bits: 1

e Flow Control: None

e Encoding: Default (ISO-8859-1)

The baud rate, data bits, parity, stop bits and flow control settings are based on the MSS_UART_init function in main().
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SC Launch Terminal O X
Choose terminal: ‘ESeriaI Terminal V|
Settings
Serial port: ‘ COM5 v‘
Baud rate: | 115200 v|
Data size: ‘8 ~ ‘
Parity: ‘None ~ ‘
Stop bits: ‘1 A ‘
Encoding: | Default (ISO-8859-1) v|
@ | OK | ‘ Cancel ‘

Figure 96 - Serial terminal settings - COM port setting will vary

19. Run the software application by clicking the Resume icon ( U¥) or by clicking Run > Resume from the SoftConsole

menu. The Terminals view will display a message as shown in the figure below.

B Console | Tasks [*] Problems (J Executables [§) Debugger Console [J Memory | (& Terminal 33

B |5kl E @ S= O

B coms 2

kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk kb kb kb kb kkkkkkkkkkkkkkkkkkkkkkkkkkk

FEREEEEEFEF SmartFusion2 RTC Calendar Time Example by LucaC F*#xsxsxsss
FREEEEERREERRR XXX XXX R XXX R R R AR R RN R R R R R R R R R R R R R R R ®
This example project displays the time read from the SmartFusion2 RTC.
& simple command line interface allows the following operaticns:

- Set the RTC time by pressing "t"

- Set the RTC date by pressing "d”

Saturday January 1 2808 (week 1) @@:01:27]]

Figure 97 - SoftConsole Terminals view with message
20. Type d to set the date.

B Console =] Tasks (2] Problems (3 Executables [3 Debugger Console [J Memory | & Terminal &2

BR| &R EE®E=D

B coms &2

Change date.

Day (1 to 31): 14
Month (1 to 12): 3
Year (8 to 254): 21

ddkdeddkk ok gk ok ke kR kR kR Rk kR Rk kR Rk kR Rk kR Rk kR Rk ke ke kR kR ~
This example project displays the time read from the SmartFusicn2 RTC.
& simple command line interface allows the following operations:
- Set the RTC time by pressing "t"
- Set the RTC date by pressing "d”
Saturday January 1 2888 (week 1) 88:82:15
Wednesday March 18 2821 (week 11) ee:@2:3s] v

Figure 98 - Changing the date

21. Type t to set the time.
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Bl Console 4= Tasks |2 Problems (3 Executables [} Debugger Console [] Memory | & Terminal 23 2 | iENEN b]j| B &= 0
B coms 3

Saturday January 1 2008 (week 1) @8:82:15 A
Change date.
Day (1 to 31): 1@
Month (1 to 12): 3
Year (@ to 254): 21

Wednesday March le 2821 (week 11) @@:83:23
Change time.
Hours: 1@
Minutes: 42
Seconds: @

Wednesday March la 2821 (week 11) 19:42:19. v

Figure 99 - Setting the time

22. After becoming familiar with the Debug perspective and the debug features, terminate the debugger by clicking the

Terminate icon ( IEI) or by selecting Run > Terminate from the SoftConsole menu.

Step 9 - Debugging code running from the SmartFusion2® eNVM
The application can also execute from the SmartFusion2® eNVM. The Cortex-M3 has six hardware breakpoints for
debugging from eNVM. This section describes the steps to execute code from the SmartFusion2® eNVM.

Building the project with the Release build configuration

i

1. Select the SoftConsole C/C++ Perspective by clicking the C/C++ button (
> Open Perspective > C/C++ from the SoftConsole menu.
2. The sample project Release build configuration settings use the debug-in-microsemi-smartfusion2-envm.ld linker

) or by selecting Window > Perspective

script to build an executable that will run in the SmartFusion2® eNVM.

3. Select Rtc_time in the SoftConsole Project Explorer then right-click and select Build Configurations > Set Active >
Release to select the Release configuration as the active build configuration.
Build the project build by selecting Project > Build All. Confirm that there are no errors listed in the Problems view.

5. A folder named Release containing the executable for the Release build configuration will be visible in the Project
Explorer.

6. Select Rtc_time.map in the Release folder, press right mouse button and choose “Open With” “Text Editor” to open
the file in the SoftConsole editor. Scroll down to the Memory Configuration section. The section should appear as
shown in the figure below.
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SC M25_5C63_workspace - ric_time/Release/rtc_time.map - SoftConsole v6.5.0.442 - O X
File Edit Source Refactor Mavigate Search Project Run  Window UltraDevelop Help
C-EQ S8R %G . S lSd-a-@-6- B P e KO R U EB I EE
IR RE CRCR R K Q E|Ets S
& | [€ mainc Bl rte_time.map 52 -8 | s
= P B e e e e miim mmmm Qi mmia s i mmmi gemms e imeim mmmms @ memi memmi s e e Ammm g ey mmm e
L] .data ox2200000000000000 @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/../1ib/gec/arm-none-eabi/9. 2. 1/thumb/v7-m/nofp\libgcc.a(_dvmd_tls.c) Gl EE
.bss Bx0000000600066000 @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/. ./1ib/gcc/arm-none-eabi/9.2.1/thumb/v7-m/nofp\libgcc.a(_dvmd_tls.a) ®
text OxBEEREERAERRORERD @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/. . /lib/gec/arm-nene-eabi/a.2.1/thumb/v7-m/nofp/criend.c .
.data ox2200000000000000 @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/../1ib/gec/arm-nene-eabi/9. 2. 1/thumb/v7-m/nofp/crtend. o =
.bss Bx0000000600066000 @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/. . /1ib/gec/arm-none-eabi/9.2. 1/ thumb/v7-m/nofp/crtend.o o
.eh_frame 2x00E0EE0000660000 @x4 d:/softconscle_vé.5/arm-none-eabi-gcc/bin/. . /lib/gec/arm-none-eabi/3. 2.1/ thumb/v7-m/nofp/criend. o
Jtext 0x2200000000000000 @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/. . /1ib/gec/arm-nene-eabi/9. 2. 1/thumb/v7-m/nofp/crin.o &
.data Bx0000000600066000 @x@ d:/softconsole v6.5/arm-none-eabi-gcc/bin/../1ib/gec/arm-none-eabi/9.2.1/thumb/v7-m/nofp/crtn.o =)
.bss 8x22222E0000000000 @x@ d:/softconsole_v6.5/arm-none-eabi-gcc/bin/. . /1lib/gec/arm-nene-eabi/9.2.1/thumb/v7-m/nofp/crin.o
i=|
emory Configuration =
3
ame Origin Length Attributes fﬁ

om xr

xr
am BRBE xrw
default* exfffffffFfffffffe

793 Linker script and memory map

794

795 LOAD d:/softconsole_v6.5/arm-none-eabi-gec/bin/. ./1ib/gcc/arm-none-eabi/9.2.1/thumb/v7-m/nofp/crti.o

795 LOAD d:/seftconsole_v6.5/arm-none-eabi-gee/bin/. ./Lib/gcc/arm-none-eabi/9. 2. 1/ thumb/v7-m/nofp/cribegin. o

797 LOAD d:/softconsole_v6.5/arm-none-eabi-gec/bin/../lib/gcc/arm-none-eabi/9.2.1/../../../. . /arm-none-eabi/lib/thumb/v7-m/nofp/crte.o

Figure 100 - Rtc_time.map for the Release build configuration

7. Notice that the memory configuration for the Release build includes a rom section at 0x60000000, which is the
address of the SmartFusion2® eNVM.

Creating the Release debug launch configuration
Create a debug launch configuration for the Release build.

8. Select Rtc_time in the SoftConsole Project Explorer View then select Run > Debug Configurations... from the
SoftConsole menu. The Debug Configurations dialog will open.

9. Select GDB OpenOCD Debugging in the Debug Configurations dialog box then right-click and select New
Configuration to create a new debug launch configuration for the Release build configuration.

10. Click the Search Project button under the C/C++ Application field on the Main tab of the Debug Configurations
dialog box.

Name: | rtc_time Release

B Main % Debugger| B Startup| &7 Source| [0 Common| %, SVD Path

Project:

| rte_time Browse...

C/C++ Application:

| Releasefrtc_time.elf

Variables... Search Project.. Browse...

Figure 101 - Search Project button
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11. The Program Selection dialog box will open.

Select armle - / Rtc_time /Release/rtc_time.elf then click OK.

SC Program Selection [m] x

. Choose a program to run:

 Binaries:

O rtc_time.elf

Qualifier:

5 armle - Jric_time/Debug/rtc_time.elf
i"f armle - fric_time/Release/rtc_time.elf

@

Figure 102 - Selecting the Release configuration application program

e\

MICROCHIP

12. Select the Debugger tab of the Debug Configurations dialog box. Confirm that the Config options and GDB Client
Setup fields contain the settings described previously.

? s¢ Debug Configurations
‘

Create, manage, and run configurations.

CEeEX BT~

Name: | rtc_time Release

v [£] GDB OpenOCD Debugging
[E] rtc_time Debug
rtc_time Release
[£] SF2_pwm_slow_blink Debug
& Launch Group

type filter text

Main [ Debugger . B Startup| % Source| ] Common| % SVD Path|

OpenOCD Setup.
Start OpenOCD locally

Executable path: | Stopenocd_path)/Sopenocd_executable]

Browse... | Variables..
Actual executable: | CAMicrochip! nsole-v2021.3-7.0.0. ipsel/../openocd) penocd.exe
(to change it use the global or workspace preferences pages or the project properties page)

GDB port:

Telnet port:

Tapor:

Config options: | -_command "set DEVICE M25010" ~-file board/microsemi-cortex-m3.cfg

Allocate console for OpenOCD Allocate console for the telnet connection

GDB Client Setup

Start GDB session

Executable name: | Sicross_p _suffix} Browse..| | Variables..

Actual executable: | arm-none-eabi-gdb

Other options: |

Commands: set mem inaccessible-by-default off

Remote Target
Host name or IP address: localhost

Port number: 3333

[l Farce thread list undate an susnend

< >
Filter matched 5 of 13 items Revert Apply
@ Close

Figure 103 - Config options for the Release Debug launch configuration for the SmartFusion2® SMF2000 kit

13. Select the Startup tab. Confirm the setting match those shown on page 65.
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14. Click Apply to save the changes.

15. Click Debug to launch the Debugger. Click Switch in the Confirm Perspective Switch dialog box. The SoftConsole
Debug perspective will open and the code will be programmed to the SmartFusion2® eNVM. Messages will appear
in the Console view while the code is being downloaded. When finished the program will be suspended at the first

line of main().
& Console 2 [2! Problems 2 Executables & Terminal & Debugger Console L] Bl RESE # B2 ~8~ = 0O
SF2_GNU_SC4_RTC_time Release [GDB OpenOCD Debugging] openocd.exe
Info : Microsemi SmartFusion2 eNVM - writing 38272 (0x7640) bytes to address 8x60000000 (. = 1024 bytes) A

........ Warn : keep_alive() was not invoked in the 1008ms timelimit. GDB alive packet not sent! (1001). Workaround: inc

Figure 104 - Console view while downloading to the SmartFusion2® eNVM

16. Select the Terminals view in the Debug Perspective. Right click in the Terminal and select Clear Terminal to remove
any existing text. If necessary, open the Terminals view (Window > Show View > Terminal).

17. Click the Resume icon to run the application. Note that the application runs the same as previously when it was
executing from the SmartFusion2® eSRAM memory.

18. Try setting breakpoints while executing the code. When finished, terminate the debugger and close the Debug
perspective (Window > Close Perspective). Do not close SoftConsole.

19. The C/C++ Perspective will be open. Open the Terminal view (Window > Show View > Terminal) and configure as
described earlier in the document.

20. Reset the SmartFusion2® SMF2000 kit by pressing and releasing SW3.

21. Observe the code execution in the Terminals view. The code is running without the debugger because it was
programmed into the SmartFusion2® eNVM.

Note that the serial terminal can be used to display output even when a program is not being debugged - e.g. a
program running from eNVM on power on reset that uses UART output.
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orkspace - rtc_time/main.c - SoftCansole

File Edit Source Refactor Mavigate Search Project Git Run Window Help
DR c-in|onm e S| FEAE-0- @I SO E D
[ Project Explorer 52 = B  [f mainc 2 = 8
&= sy
B v & 75= int main() -
v 25 rte_time 7% {
> T;. Binaries 77 mss_rtc_calendar_t calendar_count;
> i Includes ;S S?Zigtt"“—sgzié N
5 (= CMSIS i uints_t rx_buff[1];
> [z Debug 81 MSS_RTC_init(M55_RTC_CALENDAR_MODE, RTC_PRESCALER):
~ (= drivers 82
> [ mss_rtc 83 MSS_UART_init{gp my_uart,
+ (= mes_uart 24 MS5_UART_11528@_BAUD,
o 85 MSS_UART_DATA_8 BITS | MSS_UART_NO_PARITY | MSS_UART_ONE_STOP_BIT);
> [ drivers_config 85
> = hal a7 MSS_RTC_start();
> (= Release 88
> [ mainc 89 /* Display greeting message. */
L = READMESbt gf display_greeting();
e time Debug.launch 92 /* Display time over UART. */
|Z] rtc_time Release.launch a3 for(s;)
5 (25 SF2_pwm_slow_blink ag {
a5 uint32_t rtc_count_updated;
a6 /* Update displayed time if value read from RTC changed since last read. */
a7 rtc_count_updated = MS5_RTC_get update_flag();
98 if(rtc_count_updated)
9 {
-1} MS5_RTC_get_calendar_count(&calendar_count);
a1 display_time(&calendar_count);
a2 MSS_RTC_clear_update_flag();
03 1
04
as /* Start command line interface if any key is pressed. */ v
4§ Debug 7 © ts = . . §
@ 3 |2 Problems [2] Markers E] Console | 8 Terminal 52 | 4 Search [} Debugger Console ®=n0
B % is

+ [] rte time Release [GDE Open0CD Debug | = “OMS &

w B rte_time.elf
58 Thread #1 (Running : User Reques
o openocd.exe
s arm-none-eabi-gdb

s sksset SmartFusion2 RTC Calendar Time Example by LucaC **ssststssx

This example project displays the time read from the SmartFusion2 RTC.
A simple command line interface allows the following operations:

- Set the RTC time by pressing "t"

- Set the RTC date by pressing

1 2eee

(week 1) BB:BB:M \

Saturday January

< >

Connected - Encoding: Default (150-8359-1)

- O X
Q B|i2k %
0= Outline 22 = bly = B8
Bl R e ¥ §
= drivers/mss_rtc/mss_rtc.h ~
W drivers/mss_uart/mss_uart.h
& stdieh
# RTC_PRESCALER
#  INVALID_USER_INPUT
# ENTER
5 & menu_item
@ menu_item_t : struct menu_item
@® 5 daytab : charf][]
++9 display_greeting(void) : void
145 display_time{mss_rtc_calendar t7) : void
++5 get_time_from_user{void) : void
HS get_number_from_user(void) : int22_t
++5 get_date from_user{void) : void
Hs calculate_week(uint32_t, uint32_t, uint32_t) : uint32_t
45 calculate_weekday(uint32_t, uint32_t, uint32 1) : uint32 ¢
HS calculate_totaldays(uint32_t, uint32_t, uint32_t) : uint32_{
® gp_my uart: mss uart instance t* const
® main():int
of display_greeting(void) : void
® 8 display_time(mss_rtc_calendar_t*) : void
@t get_time_from_user(void) : void
® 5 get_date from_user{void) : void
& 5 nat numher fram usarfunid) - st & e
< >
)= Variables 32 LB e 8 =B
Name Type Value
< >

Figure 105 - Terminals view in C/C++ perspective

This demonstrates how to generate sample SmartFusion2® firmware projects and debug them with SoftConsole.

End of SmartFusion2® lab
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