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Introduction

This tutorial demonstrates how to implement a basic SmartFusion2 / IGLOO2 FPGA fabric design using SmartDesign.

The design drives several LEDs on the SmartFusion2 or IGLOO2 target board. A counter output is used to drive the
LEDs. The SmartDebug Live Probes are used to drive another LED on the target board.

After completing this tutorial, you will be familiar with the following:

e Creating a Libero SoC project

e Implementing a SmartFusion2 / IGLOO2 fabric design with SmartDesign

e Simulating the design

e Importing a PDC file, running layout and programming the SmartFusion2 / IGLOO?2 silicon
e Using the SmartDebug Live Probes

Components Used in the Design
This tutorial uses the SmartFusion2 / IGLOO2 FPGA fabric, the on-chip 25/50 MHz RC oscillator and the Fabric CCC
and Live Probe A.
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Tutorial Requirements

Software Requirements
This tutorial requires the following software installed on your computer:

Microsemi Libero SoCv12.5

Hardware Requirements
This tutorial can be used with the following SmartFusion2 board:

e SMF2000 SmartFusion2 board

Note: The Free Libero Silver license can be used with this kit.

Extracting the source files
Extract SF2_Fab_Probe.zip to extract the required lab files to the <C: or D:>\Microsemiprj folder on

& Microsemi

a AS\MicrocHIP company

the HDD of your

PC. Confirm that a folder named SF2_Fab_Probe containing a sub-folder named Source_files was extracted.

Step 1 - Creating the Design

In this step you will create the fabric design using SmartDesign. Some source files have been provided in the

Source_files folder.

Launching Libero SoC and creating a project
1.
Project Manager will open.

Click Start > Programs > Microsemi > Libero SoC v12.5 or click the shortcut on your desktop. The Libero SoC

@ Libero - O X
Project File Edit View Design Tools Help
AL ey |
NS aON90 vl
StartPage 1 -
Projects N
c Mew... - - -
;] Welcome to Microsemi's Libero® SoC v12.5
Recent Projects Microsemi Libero® System-on-Chip (SoC) design suite offers high productivity with its comprehensive, easy to learn, easy to adopt development tools
for designing with Microsemi’s power effident flash FPGAs, SoC FPGAs, and Rad-Tolerant FPGAs. The suite integrates industry standard Synopsys
C:/Micrasemipr/tes.../tests Synplify Pro® synthesis and Mentor Graphics ModelSim @& simulation with best-in-dass constraints management, debug capabilities, and secure
C:/Microsemipf/PF .../... CSI2TX 4K Mod | production programming support,
C:/Projects/gige/hd.../top level
What's New in Libero SoC v12.5
# Introducing PolarFire SoC family - for further information, refer to PolarFire SoC FPGA
*Preliminary timing and power for MPF5250T_ES EXT device along with programming and SmartDebug
Welcome to Libero 50C = *Preliminary timing and power for MPFS250T/L EXT/IND device
Libero 50C Quickstart * Advance timing and power for MPFS460T/L EXT/IND device
i b * Standalone M55 configurator (... /biné4/pfsoc_mss) and impart of the generated M35 component into Libero SoC
Libero SoC Interface Description
Libero SoC Release Notes on the Web
Libero Tutorials * PolarFire Silicon support
Product Tutorials *MIL operating condition - Production timing for the MPF200TS, MPF300TS and MPFS00TS 1.05V/STD devices
= *New Lidless package FCG784N for MPF300T/S, STD/-1, IND
Training Webcasts packag 5,0/
N - *Transceiver enhancements ﬂ
Message g X
E] Messages & Errors M Wamnings i Info E] Manage suppressed messages
Log Message
Fam: |Part:

Figure 1 - Libero SoC Project Manager
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2. Create a new project by selecting New on the Start Page tab (circled in the figure above), or by clicking Project >
New Project from the Libero SoC menu. The New Project wizard will open.

G‘ MNew project

Project details
Specify project details

Project Details
Device Selection
Device Settings
Design Template
Add HDL Sources
Add Constraints

. gl
Libefo)

System-on-Chip

Help

Project name: |

Browse...

Project location: |C: \Microsemiprj

Description:

Preferred HOL type: |Verilog ~

I”" Enable block creation

Block flow enables you to publish a reusable component that can be instantiated into another design. A block component may not contain 1/O cells and cannot be programmed by itself.
It could include timing constraints, physical constraints, placement or routing.

< Back | Next >

Einish Cancel

Figure 2 - Libero SoC New Project dialog box

3. Enter the information shown below in the Project Details page of the New Project dialog box then click Next:

e Project Name: SmartFusion2_Fabric
e Project Location: <C: or D:>\Microsemiprj\SF2_Fab_Probe (depending on where you extracted the source

files)

o Preferred HDL type: Verilog or VHDL, select VHDL for this lab example
e Enable Block Creation: un-checked

G‘ Mew project

Project details
Specify project details

Project Details
Device Selection
Device Settings
Design Template
Add HDL Sources
Add Constraints

. gl
Libefo

System-on Chip

Help

Project name: |Smarn‘=uswon2_Fabr|c

Browse...

Project location: |C:,'7'~‘Iicrosamiprjf5F 2_Fab_Probe

Description:

Preferred HOL type: |VHDL ™

I™ Enable block creation

Block flow enables you to publish a reusable component that can be instantiated into another design. A block component may not contain IO cells and cannot be programmed by itself.
It could indude timing constraints, physical constraints, placement or routing.

Mext = Einish Cancel
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4. Enter the following in the Device Selection page of the New Project dialog box, select M2S010-VF400 device then
click Next:
o Family: SmartFusion2
o Die: M25010
o Package: 400 VF
o Speed: STD
o Core Voltage(V): 1.2
o Range: COM
( New project _ O w
Dw?&?&ifr::.:?;ur your project from the part number list Selected part: M25010-VF400
Part filter
Bilecie ik Famly: [SmartFusionz | Die: [M25010 v Package: [400vF ~|
speed: [5D =] core voltage: [1.2 =] Range: Joom =
Device Selection
Reset filters

Device Settings
& Search part: |

Part Number 4auT DFF User 1jOs USRAM 1K LSRAM 18K Math (18x18) PLLs and CCCs
Design Template

Add HDL Sources

Add Constraints

o 21
Libefo" | |. .

System-on-Chip

Help < Back | MNext > Einish | Cancel |

Figure 4 - Device selection (settings for SMF2000 board shown)

5. Enter the following in the Device Settings page of the New Project dialog box then click Next:

e Default I/O Technology: LVCMOS 3.3V
e Reserve Pins for Probes: checked (default)
e Power Supplies
o PLL Supply Voltage (V): 3.3V
o VDD Supply Ramp Time: 100ms (default)
o System Controller Suspend Mode: un-checked

The PLL Supply voltage can be either 2.5V or 3.3V. The voltage setting in the New Project dialog box must match
the PLL Analog Supply voltage on the board to ensure the PLL works correctly.

Page 7 of 43 v3.4



& Microsemi

a AS\MicrocHIP company

SmartFusion2/IGLO0OZ2 Fabric Lab Guide

G‘ Mew project — ] »®
Device settings
Choose device settings for your project Selected part: M25010-VF400

Project Details 1/0 settings

Default 1/0 technology: LVCMOS 3.3V * e Please use the 1/0 Editor to change individual IO attributes.

Device Selection M Reserve pins for probes
Device Settings Eonssries
PLL supply voltage (V): =
. WDD Supply Ramp Time: 100ms <
Design Template eely °
I System controller suspended mode
Add HDL Sources
Add Constraints

ozl
Libefo

System-on-Chip

Help

< Back | Mext > | Einish Cancel

Figure 5 - Device Settings (settings for SMF2000 board shown)

6. Enter the following in the Design Template page of the New Project dialog box then click Next:
e Design Templates and Creators: None (this design does not use the SmartFusion MSS or IGLOO2 HPMS)
e Design Methodology:
o Use Standalone Initialization for MDDR/FDDR/SERDES peripherals: un-checked
o Instantiate SystemBuilder/MSS component in a SmartDesign on creation: checked
(® New project - m} X
Design Template
Choose & design template Selected part: M25010-VF400
Design templates and creators
Project Details & None
" Create a system builder based design
Device Selection " Create a microcontroller(MSS) based design
Core Version
DeviceSettings | [T S (0D L
Design Template I show only latest version
Design methodology
Add HDL Sources I"" Use standalone initizlization for MDDR [FDDR,/SERDES peripherals
W' Instantiste SystemBuilder MSS component in a SmartDesign on creation
Add Constraints
Libefo)
System-on-Chip "—
Help < Back | Mext = | Finish Cancel
Figure 6 - Design Template settings (all kits)
Page 8 of 43
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7. The Add HDL Source Files page will be visible. A VHDL source file has been provided. Import the file into the
project by clicking Import File.

8. Enter the following in the Import Files dialog box then click Open:
e Location: <C or D:>\Microsemiprj\SF2_Fab_Probe\Source_files
e File name: count24.vhd
e Files of type:  HDL Source Files (*.vhd *.v *.h)

C" New project — m} X
Add HDL source files
Specify HOL files to importflink to your project. Selected part: M25010-VF400
Link file Delete
Project Details
File type File name File lecation |
Imported count24.vhd C:/Microsemipr)/SF2_Fab_Probe/Source_files

Device Selection

Device Settings

Design Template

Add HDL Sources

Add Constraints

.
Libefo

System-onChip

Help < Back Mext = Einish Cancel

Figure 7 - Imported HDL source files

Page 9 of 43 v3.4



SmartFusion2/IGLO0OZ2 Fabric Lab Guide

& Microsemi

a AS\MicrocHIP company

9. Click Next. The Add Constraints page will be visible. An 1/O constraint file has been provided. Import the file

into the project by clicking Import File.

10. Enter the following in the Import Files dialog box then click Open:

e location:
e File name: Fabric_Top.pdc

e Files of type: 1/0O Constraint Files (*.pdc)

<C or D:>\Microsemiprj\SF2_Fab_Probe\Source_files

G‘ Mew project

Add constraints
Specify constraint files for timing or physical constraints.

- O X

Selected part: M2S010-VF400

Device Selection

Device Settings

Design Template

Add HDL Sources

Add Constraints

. 1I\
Libero
Help

Link file Delete
Project Details
File type File name File location |
Imported Fabric_Top.pdc C:/Microsemiprj/SF2_Fab_Probe/Source files

< Back Next > Einish Cancel

Figure 8 - Imported /0 Constraint file

11. Click Finish in the New Project dialog box.

12. The HDL source file will be visible on the Design Hierarchy tab after clicking Build Hierarchy. Both the HDL source
file and the 1/0 constraint file will also be visible on the Files tab.

Build Hierarchy | @l Show: |Compnnents ﬂ HE ?
= il work

E=j_ count24(RTL) (count24.vhd) [work]
=+ [ User HDL Source Files
Bl hdi\count24.vhd [work]

Files

[3 camponent
[7 constraint

[ fp
=[] io

ES| Fabric_Top.pdc

[ designer
[ hdl

% count2d.vhd
(7 simulation
[ smartgen
[ stimulus
[ synthesis
7 tooldata

Design Flow Design Hierarchy

stimulus Herarchy | Catalog | Files

Design Flow I Design Hierarchy I Stimulus Hierarchy

Catalog Files

Figure 9 - HDL source file and 1/0 constraint file in Libero SoC
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Implementing the design with SmartDesign
1. Open the SmartDesign canvas by selecting File > New > SmartDesign from the menu or by double-clicking Create
SmartDesign under Create Design on the Design Flow tab.

Design Flow F X
o Please select a root = o 7] g’
|Too| -
B » Create Design
& System Builder
£ Configure L

Create SmartDesign
cate

i Create SmartDesign Testbench

Create HDL Testbench

+0

» Verify Pre-Synthesized Design
il Simulate
E- »  Constraints

3 Manage Constraints

= b Implement Design hd

Design Flow I Design Hierarchy I Stimulus Hierarchy I Catalog I Filesl

Figure 10 - Opening the SmartDesign canvas

2. Enter Fabric_Top in the Create New SmartDesign dialog box then click OK. Save the component with
CTRL+SHIFT4S.

B Create New SmartDesign ? *

Mame:

IFabric_Top
Help | 0K I Cancel

Figure 11 - Entering SmartDesign name

3. Click Build Hierarchy on the Design Hierarchy tab.
4. Drag the count24 component from the Design Hierarchy tab to the SmartDesign canvas.

Design Hierarchy B x Reports @ X B3 Fabric Top* & x | StartPage @ X |
- = ~ D% KA
L1 Please select a root v 0 ".T.'lp "ﬂ“—' -—D-ED DD ED ‘ 57
Build Hierarchy | I I, show: IComponents 'I HE ?
E]ii work

lJ —
B8 E5  count24(RTL) (count24.vhd) [work]
B[] User HDL Source Files
B[] Components

count24_0

Figure 12 — Component pasting
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This design uses a fabric CCC to generate the 1 MHz internal clock. The CCC reference clock is the 25/50 MHz RC
oscillator. In the next steps you will configure the CCC to output a 1 MHz clock and configure the on-chip oscillator.

5. Expand Clock & Management in the IP catalog.

Note: If the IP Catalog is not visible, click on View > Windows > Catalog.

Catalog & x

@, » T simulation Mode * Bd

Name Version
#- Arithmetic
+ Bus Interfaces
= Clock & Management
Chip Oscillators 20101

Clock Conditioning Circuitry (CCC) 2.0.201
+ DSP
- 1/0
# LucaC
+- Macro Library
+ Memory & Controllers
- Peripherals
+ Processors
#- §C/Tamper
# Solutions-AXI
#- Solutions-FIL-HSP-1P
+ Solutions-MotorControl
|- Solutions-Video
+ Solutions-WiredComms
+- Tamper
# User Defined

Design Flow J Design Hierarchy J Stimulus Hierarchy Catalog Files

Figure 13 — Clock & Management category of the Libero SoC 10 Catalog

6. Drag an instance of the Clock Conditioning Circuitry (CCC) v2.0.201 component into the SmartDesign canvas.
7. Keep FCCC_CO for the component name and click OK.

The components must be spelled exactly as directed. This nomenclature is necessary because the pre-written codes
include variables that use the names of the components. Naming the components differently can cause errors.

B Create Component ? *

MName:
CCC_CO

Help | oK | Cancel

Figure 14 - Component naming

8. FAB CCC Configurator will open, otherwise double-click the FCCC_CO component in the SmartDesign canvas to
open the FAB CCC Configurator.
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9. Select the Basic tab in the FAB CCC configurator. Enter the following:
e Reference clock: Select Oscillators > 25/50 MHz Oscillator from the pull-down menu
e GLO: checked;
o Exact Value: checked
o Frequency: 1 MHz
B | FAB CCC Configurator - O X
"~
B asic Advanced FLL Options
B asic-Options
Reference Clock r ﬂ
cce
50.000 kHz Exact Value  Frequency Actual
25/50 MHz Dscillator - GLO
[1 [
Gl
— [100 Hz | e
dGL?
[100 pHz | |MHz
[]GL2
S [100 bz | [
LOCK.
\ W,
v
£ >
Help - 0K Cancel
| ok |

Figure 15 - Configuring the fabric CCC

10. Click OK to close the FAB CCC Configurator.
11. Drag an instance of the Chip Oscillators v2.0.101 component from the IP catalog into the SmartDesign canvas.
12. Keep OSC_CO for the component name and click OK.

B Create Component ? *

MName:

0SC_CO|
Help | oK | Cancel

Figure 15 - Component naming

13. Chip Oscillators Configurator will open, otherwise double-click the OSC_CO component in the SmartDesign
canvas to open the Chip Oscillators configurator.
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14. Configure the 50 MHz RC oscillator to drive the fabric CCC as follows:
e Enable the On-chip 25/50 MHz RC Oscillator
e Select Drives Fabric CCC(s)

A Chip Oscillators Configurator ? %

Configuration ————— e —

[] External Main Crystal Oscillator

Source Crystal {32KHz-20MHz) .

Frequency 20.00 MHz

Drives Fabric CCC(s) RCOSC_50MHZ

Drives Fabric Logic

Drives Fabric CCC(s) %)

Drives Fabric Logic O
RCOSC_1MHZ

& XTLOSC

| User Logic
1

1

1

1

! FPGA Fabric

1

[] on-chip 1 MHz RC Oscillator

Drives Fabric CCC(s)

Drives Fabric Logic

1
1
1
1
1
1
1
1
1
1
1
1
On-chip 25/50 MHz RC Oscillator :
1
1
1
1
1
1
1
1
1
1
1
1
1

e

Figure 16 - Configuring the Chip Oscillators (SmartFusion2 target)

15. Click OK to close the Chip Oscillators configurator.
16. Expand Macro Library in the Libero SoC IP catalog.

Catalog g X
I Ql * [ Simulation Mode .Q'I b
Name £ |'u'ersior1 I:I
= Macro Libra

- AND3 1.0
- AND4 1.0
- BIBUF 1.0
- BIBUF_DIFF 1.0
- BUFD 1.0
- BUFF 1.0
- CLKBIBUF 1.0
- CLKBUF 1.0
- CLEBUF_DIFF 1.0
- CLEINT 1.0
- CLEINT_PRESERVE 1.0
~ DDR_IM 1.0
- DDR_OUT 1.0
- DFM1 1.0
- DFM1CO 1.0
~ DFM1TET 1.0
- DFMTE1CO 1.0
- DFNTETPO 1.0 LI
Design Flow | Design Hierarchy | Stimulus Hierarchy Catalog | Files |

Figure 17 — Macro Library category of the Libero SoC IP Catalog
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17. Drag an instance of AND2 and SYSRESET into the SmartDesign Canvas.

Tip: to make it easier to find the macros listed above, type a few letters of the macro name in the IP Catalog

search field.
Catalog (4
SYS Ql ¥ [ simulation Mode '_. “
MName Viersion l;
=I- Bus Interfaces
&= CorefAHBLTOAX] 2.1.101
CoreAXldInterconnect 2.8.103
CoreAXldInterconnect 2.2.102
&= CoreAXITOAHBL 3.3.100
&= CorePCIF 4.2.100
&= CorePCIF_AHB 4.2.100
- Macro Library

SYSCTRL_RESET_STATUS

1.0

-I- Peripherals

& Corel353BRT 4.2.101

&= Corel353BRT_APE 4.3.106 |-
&= Cored29 3.12.105

&= Cored29 APB 3.12.105

CoreAX|ADMAController 2.0.100

& CorelPC 3.2.104

&= CoreRemap 1.1.101

&= CoreSPI 5.2.104 =
S Caratucfandices 27107

Design Flow ] Design Hierarchy ] Stimulus Hierarchy Catalog | Files I

Figure 18 - IP Catalog Search field

18. Drag an instance of LIVE_PROBE_FB into the SmartDesign Canvas. The LIVE_PROBE_FB macro allows the

SmartDebug Live Probes to be re-directed into the FPGA fabric. One of the outputs will be connected to an LED
on the target board.

19. After adding the components, the SmartDesign will resemble the figure below. If needed, drag the components
to improve the appearance of the canvas.

i
Tip: expand the canvas area by selecting View > Maximize Work Area or click the icon on the tool bar ( =.}).

Reports & X & Fabric_Top* & X l StartPage @ X ]

"9 [ 'ﬂCD—BDD o” B°

4

EC }( G)\ G\ (D‘ % A ﬁ Filter Mets: |* I Show Only BIF Nets
=

0OSC_C0 0 FCCC C0 0 count24_0
5 - L) Lk
RCOSC_25_S0MHZ_CCC_OU RCOSC_%_SOMHZ CCCIN | o - .
OSC_CO FCCC_CO0 "
count24
ANDZ O
A
5 Y
ANDZ
SYSRESET 0
DEVRST_N > [DEVRST_N POWER_OMN_RESET_N
SYSRESET

LIVE_PROBE FB_0

PROBE_A
PROBE_E

LIVE_PROBE_FB

" o[

Figure 19 - SmartDesign canvas after adding components
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Making connections in the canvas
Next connect the components in the SmartDesign canvas to complete the design. SmartDesign in Libero SoC has a
connection mode that supports click, drag and release to make connections.

20. Select SmartDesign > Connection Mode from the Libero SoC menu or click the Connection Mode icon ( ).
21. Connect the RCOSC_25 50MHZ_CCC_OUT port of OSC_CO_0 component to the RCOSC_25 50MHZ_CCC_IN port
of the FCCC_CO_0 component as follows:
e Click and hold mouse button on the RCOSC_25 50MHZ_CCC_OUT port of the OSC_0 component.
e Drag mouse to the RCOSC_25_50MHZ_CCC_IN port of FCCC_0 component.
e Release mouse button on the RCOSC_25 50MHZ_CCC_IN port to make the connection.
22. Repeat the previous steps to make the connections shown it the table below.

From To
FCCC_C0_0:GLO count24_0:CLK
FCCC_CO0_0:LOCK AND2_0:A
SYSRESET_O0:POWER_ON_RESET_N AND2_0:B
AND2_0:Y count24_O0:RESETn

Table 2 — SmartDesign canvas connections

0OSC_C0_0 FCCC_C0_0 X

[ RCOSC_25_50MHZ_CCC_OUT] RCOSC_25_50MHZ_CCC_IN LCG}'C‘E count24 0

0SC_Co FCCC_CO ’ > =
—{up_on Qr23:0]

SYSRES ET_[] 5 A2 , RESETn
DEVRST_N [ {DEVRST_N POWER_ON_RES ET_q—BD—li count24
SYSRESET LIVE_PROBE_FB_0
PROBE_A|

LIVE_PROBE_FB

Figure 20 — Connection creating

23. Disable the SmartDesign connection mode by selecting SmartDesign > Connection Mode from the Libero SoC
menu.

24. Promote the UP_DN port from count24_0 to the Top Level by selecting the UP_DN port and choosing Promote
to Top Level from the popup menu (click right mouse button).

25. Rename UP_DN port to USER_BTN by choosing Modify/Rename from the popup menu (click right mouse
button).
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26. Expose bits 16 to 23 of count24_0 by selecting port Q[23:0] of count24_0 then right-clicking and selecting Edit
Slice.
count24 0
CLK L
UP_DN Q[23:07
RESETR == Disconnect

Promote to Top Level

COLInt24 ¥ Magnify Pin

Highlight v

Create Slices L
Edit Slices...

Figure 21 - Adding a slice to the Q[23:0] output

27. Click the + sign (circled in the figure below) in the Edit Slices — Q[23:0] dialog box.

B Edit Slices - Q[23:0] ?

Create I 'I slices of width |1 I Add Slices
X

qizso] B | | et | Right |

Help | oK I Cancel |

Figure 22 - Edit Slices dialog box

28. Enter 23 for the Left and 16 for the Right index to expose count24_0[23:16] and click OK.

B Edit Slices - Q[23:0] ? X

Create I 'I slices of width |1 I Add Slices |

Q[2a:0] [@ Left Right
NRE 16

Help | oK I Cancel

Figure 23 - Adding a slice to the count24_0 output
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29. Mark the PROBE_B port of the LIVE_PROBE_FB_0 component unused by selecting the port then right-clicking
and selecting Mark Unused.

LIVE_PROBE_FB_0

PRC}BE_A]:
PROBE B

== Disconnect

LIV E_P RO B | Promote to Top Level

¥ Magnify Pin

Highlight 3

Clear Attribute

Invert

Mark Unused

Figure 24 - Marking the PROBE_B port unused

30. Click on * icon on the toolbar or right-click anywhere in Design Canvas and select “Add Port”. The Add Port

dialog box will appear.

Generate Component
w  Design Rules Check
€ Highlight Info Instances

A Connection Mode

] Add Port...

Mf] QuickConnect... Ctrl+ K

Figure 25 — Adding a port in Design Canvas

31. Enter the following in the Add Port dialog box then click OK:
e Name: LED[7:0]
e Direction: Output

D Add Port 7 X
@

Name: |LED[7_0]
Direction:
(" Input
* Qutput
(" Bi-directional {inout)

Help | Ok | Cancel

Figure 26 — Adding LED[1:8] output port in Design Canvas

32. If required, click the + sign on the Q[23:0] port of count24_0 to expose the slice that was created above.
33. Connect the Q[23:16] port of count24_0 to the LED[7:0] output port.

34. Add another output port called USER_LED.

35. Connect the PROBE_A port of the LIVE_PROBE_FB_0 component to the USER_LED output port.
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36. After making the connections listed above the SmartDesign canvas will appear as shown in the figure below. You
can drag the components or use the SmartDesign Auto Arrange feature to improve the appearance of the

canvas.
Reports & X E Fabric_Top* & X I StartPage & X ] =
v 0 [ 'ﬂ - ?"D_ oF 5P BP = SR EEIEN G)\ % A ﬁ Filter Nets: [= [~ Show Only BIF Nets
=
0SC_C0_0 FCCC_C0_0 count24_0
— RCOSC_25 SOMHZ CCC_ouT| 0 qmeg ,
- Qf23: 16 LED{7:0]
—‘ 05¢.C0 FCCC_C0 o
count24
SYSRESET 0
:E".‘RE’_'. [ OEVRST N POWER_ON_RESET_N|
SYSRESET
LIVE PROBE FB 0
PROBE_A| USER_LED
LIVE_PROBE_FB
]

Figure 27 - SmartDesign canvas after making connections

37. Save the design (File > Save Fabric_Top).
38. Generate the design by clicking SmartDesign > Generate Component or by clicking the Generate Component

icon on the SmartDesign toolbar ( ).

39. Restore the work area (View > Restore Work Area) if you expanded the work area earlier.

40. Confirm that the message “'Fabric_Top' was successfully generated” appears in the Libero Log window. The
warning message “Floating output bus pin count24_0:Q[23:0]” can be ignored.

41. Set Design Top Level to “Fabric_Top” by right-clicking and selecting Set As Root, the active Top Level component
is shown in bold font in the Design Hierarchy window.

Design Hierarchy [l
“ Please select a root
1, Build Hierarchy | (-__'\g Show: |C0mp0nents ﬂ HE ?
- @ work
T

= 03 User HoL Source [

- [ Components Open Component
% Generate Component
Export Component Description(Tcl)

Hierarchical Export Component Description(Tel)

Figure 28 — Setting Fabric_Top as the Top Level (Root)

42. Click Build Hierarchy to update the Design Hierarchy.
43. Close the design (File > Close Fabric_Top).
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Step 2 - Simulating the design

The next step is to simulate the design. A testbench, ModelSim macro file and a wave format file have been
provided in the source files. The Fabric_Top module/entity contains a 24 bit counter. The simulation would take a
long time because of the 24bit counter where we only need the upper 8 bits and because of the 1:50 clock ratio on
the PLL. In order to accelerate the simulation of the design some of the counter bits are forced high in the ModelSim
macro file during a second phase of the simulation.

1. Confirm that Fabric_Top appears in bold font in the Libero Design Hierarchy window. If it does not, select
Fabric_Top, right-click and select Set As Root.

Design Hierarchy

Top Module(root): Fabric_Top

Build Hierarchy [ Q9 show: [comporents | E E 7
= @ work

F—ﬁ_ XTLOSC_FAB({DEF_ARCH) (osc_comps.vhd) [work]
E=j_ XTLOSC(DEF_ARCH] (osc_comps.vhd) [work]
]

RCOSC_25_50MHZ_FAB(DEF_ARCH) (osc_comps.vhd] [work]
RCOSC_1MHZ_FAB(DEF_ARCH) (osc_comps.vhd) [work]
RCOSC_1MHZ(DEF_ARCH) (osc_comps.vhd) [work]
Fabric_Top
ser HDL Source Files
omponents

Design Flow Design Hierarchy | Stimulus Hierarchy ] Catalog ] Files ]

Figure 29 - Design Hierarchy with Fabric_Top as the Top Level
2. Expand Verify Pre-Synthesized Design in the Design Flow window. Right-click Simulate and select Import Files.

Design Flow

Top Module(root): Fabric_Top E ° ﬁ

Active Synthesis Implementation: synthesis

| Tool

= P Create Design
&4 Systemn Builder
&4 Configure MSS
B3 Create SmartDesign
Create HDL
i Create SmartDesign Testbench
Create HDL Testbench
+| Generate Memory Map

= b Veri%Pre-Sinthesized Desiin

= Constraints [
‘3 Manage Constraints Clean and Run All

=I- # Implement Design .
Q pOpen Metlist ‘?’iewer nealinteractively
S Synthesize Clean
= b Verify Post-Synthesized Design
+[] Generate Simulation File Organize Input Files »
+] Cenfigure Flash*Freeze
+| Configure Register Lock Bits Edit Profile...
9,3 Place and Route
= ¥ Verify Post Layout Implementat Help
E Generate Back Annotated Files

Figure 30 - Importing Simulation files
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3. Import the ModelSim macro file and Wave format file.
Enter the following in the Import Files dialog box then click Open:
e Lookin: <C: or D:>\Microsemiprj\SF2_Fab_Probe\Source_files
e Files of type:  Simulation Files (*.mem *.bfm *.dat *.txt *.do)
e File name: Hold the shift key and select vhdl_run.do and vhdl_wave.do
@ Import Files X
U » This PC » 0SDisk () » Microsemiprj » 5F2 Fab_Probe » Source files v O Search Source files 2
Organize = Mew folder N 4 | o
Name - Date modified Type Size
#F Quick access -
|J vhdl_run.do 8/18/2020 11:54 AM DO File 4KB
@ Onelrive - Micrachip Technolagy, Inc | ] vhdl_wave.do 3/15/20192:12PM DO File 2KB
@ OneDrive - Personal
& This PC
[ Desktop
@ Documents
& Downloads
J} Music
&= Pictures
@ Vvideos
2, 0SDisk (C:)
¥ MNetwork
File name: |"vhd|7wave‘do" "vhdl_run.do" Simulation Files(*.mem *.bfm *
Figure 31 - Importing the ModelSim simulation files
4. Import the testbench by right-clicking Simulate under Verify Pre-Synthesized Design in the Design Flow window

and selecting Import Files.
Enter the following in the Import Files dialog box then click Open:

e lookin: <C: or D:>\Microsemiprj\SF2_Fab_Probe\Source_files
e Files of type:  HDL Stimulus Files (*.vhd *.v)
e File name: user_testbench.vhd
@ Import Files x
I » ThisPC » OSDisk(C) » Microsemiprj » SF2_Fab_Probe » Source files [N J] Search Source_files o
Organize « New folder ==~ [ o
Name - Date modified Type Size
sk Quick access -
| count24.vhd 11/30/2018 1:33 PM VHD File 2KB
@ OneDrive - Microchip Technalagy, Inc " user_testbench.vhd 12/20/201812:07...  VHDFile 2KB
@ OneDrive - Personal
[ This PC
[ Desktop
@ Documents
* Downloads
J! Music
&= Pictures
B Videos
o O5Disk ()
¥ Metwork

File name: | user_testbench.vhd

(HDL Stimulus Files(*.vhdl *vhd ~

Page 21 of 43

Figure 32 - Importing the testbench file

v3.4



& Microsemi
SmartFusiOHZ/IGLOOZ Fabric Lab Guide a@M":nm:mpcompany

6. Select the Stimulus Hierarchy tab & click Build Hierarchy. The testbench (user_testbench.vhd) will be visible.
Select the testbench, right-click and select Set As Active stimulus. A waveform symbol will indicate the active
stimulus (circled below).

Note: If user_testbench.vhd is not visible on the Stimulus Hierarchy tab, the file was not imported as an HDL
stimulus file. Re-import the file as described above.

Stimulus Hierarchy

I Show Root Testhenches

Build Hierarchy | ':-_'; Show: |C0mp0nents ﬂ |

testbench(behavieral) (user_testbench.wvhd) [work]
Fabric_Top

+- [ User HDL Stimulus Files

Figure 33 — Active Testbench in the project
The testbench and simulation files will be visible on the Libero SoC Files tab under Stimulus and Simulation.

Files

3 component

] constraint

[7 designer

[ hdl

(7 simulation
@ modelsim.ini
% vhdl_run.do
% vhdl_wave.do

3 smartgen

=[] stimulus

% user_testbench.vhd

[] synthesis

+ ] tooldata

[N Ny Sy By

Figure 34 - Testbench and simulation files

7. Open the ModelSim macro file (vhdl_run.do) in the Libero SoC editor by double-clicking the filename on the Files
tab.

8. Locate the variable PROJECT_DIR on line 17 of vhdl_run.do and confirm that it matches the location of your
Libero SoC fabric tutorial project. The location is displayed at the top of the Libero SoC GUI (do not include
“SmartFusion2_Fabric.prjx”). Edit the path if necessary (note that backward & forward slash usage differs
between the Libero and Modelsim tool on Windows OS).

G Likero - ChMicrosemipr\5F2_Fab_Probe\SmartFusion2_Fabric\SmartFusion2_Fabric.prix®
Project File Edit View Design Tools Help

Figure 35 - Location of Libero SoC project

9. Locate the variable INSTALL_DIR on line 19 of vhdl_run.do and confirm that it matches the location of your
Libero SoC installation. Edit the path if necessary. Ask the lab instructor if you do not know the Libero SoC
installation path.

10. If you made changes, save the file (File > Save vhdl_run.do).

11. Scroll in the file to become familiar with the commands it contains. The command force —freeze forces some of
the counter bits in Fabric_Top_0 high to speed up the simulation in the second phase of the simulation.

12. Close the editor (File > Close vhdl_run.do).
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13. Open the Libero SoC project settings (Project > Project Settings...).

G\ Project settings -

Device settings Currently selected device is M25010-VF400

Design flow Part fiiter
Analysis operating conditions
3 S'mglgt]'(_ol” options Family: |SmartFusion2 =] Die: [al > Package: [al =
ile
Waveforms Speed: ‘AH j Core voltage: |A\I j Range: |All 5

Vsirmn commands

: Tim_as(a_le ) Reset filters
Simulation libraries

SmartFusion2
General Settings

Global Include Paths Search part: |
Part Number /|| 4Lut | oFF | usery0s | usRAM 1K |Lsramisk  |Math(18x1g)  [PLisandcccs | chip Globals 21
WIZS005-TVRI00T e0e0 [0 T TT o T g
M25005-FG424 606D 5060 200 1 10 1 2 g
M2S005-FG484 6060 6060 200 1 10 1 2 8
M2SANS-TM144 RANRN ANRN R4 11 n 11 2 fa i

Figure 36 - Libero SoC Project Settings dialog box

14. Select Do File under Simulation Options in the Project Settings Dialog box.
15. Un-check “Use automatic DO file”.

16. Click the browse button ( E])next to “User defined DO file” and enter the following then click Open:
e Lookin: <C: or D:>\Microsemiprj\SF2_Fab_Probe\SmartFusion2_Fabric\simulation
e Filesoftype: *.do
e File name: vhdl_run.do

The ModelSim macro file vhdl_run.do calls the Wave format file vhdl_wave.do, so there are no settings required
for the Wave Format file.

(" Project settings O X
Device selection I™ Use automatic DO file
Device settings Save |
Design flow [P S -
N N . Simulation runtime: 1000ns
Analysis operating conditions | J Restore Defaults
= Simulation options Testbench module name: |tEsIbEn-:h
Waveforms Top level instance name: | <top>_0
Ve d
sim commands I~ Generate VD fie
Timescale
= Simulation libraries WCD file name: |pc-‘.' er.ved
SmartFusion2
General Settings - - -
Global Include Paths User defined DO file: |C:M\UDSEm\DF]fSFZ_Fﬂb_PbeEfsmﬂftFUSIDl'lZ_Fﬂbﬂtfsll'ﬂu'ﬂtlUﬂj’\dhd‘_"uﬂ‘dU J
DO command parameters: |

Figure 37 - Simulation options

17. Click Save then Close to close the Project settings dialog box.
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18. Select Project -> Tool Profiles...
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In order to use a ModelSim tool version which is supported by the Silver license, a new Simulation profile has to

be added.

G‘ Tool Profiles

? X

B- Tools
- Synthesis

-~ Stimulus
“- |dentify Debugger

Simulation profiles

(D] x|

Active| |
3 |@

Mame

ModelSim ME Pro

Path
C:\WMicrosemi\Libero_SoC_w12, 5\ModelSimProiwin32acoem

modelsim.exe

Add profile

Export Profiles. ..

QK

Cancel

Figure 38 - Tool Profiles

19. Select Simulation under Tools, click Add profile + button and enter settings below, then click OK:

e Name:
e Tool integration: ModelSim

ModelSim ME

e Browse to Location and select, e.g.: C:\Microsemi\Libero_SoC_v12.5\ModelSim\win32acoem\modelsim.exe

( Add Profile

Mame:
Tool integration:

Version:

Location:

Help |

| Modelsim ME

IMDdE|5iI‘I‘|

[

Model Technology ModelSim Microsemi vsim 2019, 4 Sin

IFD_SDC_'U' 12, 5\ModelSimwin32acoemimodelsim, exe

Ok

Browse. ..

Cancel |

Figure 39 - ModelSim ME Profile

20. Make sure ModelSim ME is set as Active Simulation Profile, then press OK
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21. Expand Verify Pre-Synthesized Design in the Design Flow window. Right-click Simulate and select Open
Interactively to launch ModelSim in GUI mode.

Design Flow

Top Module(root): Fabric_Top E

Active Synthesis Implementation: synthesis

‘TDD|
=} P Create Design
&4 Systern Builder
&4 Configure MSS
Create SmartDesign
Create HDL
i Create SmartDesign Testbench
Create HDL Testbench
+L| Generate Memory Map
=~ P Verify Pre-Synthesized Design
—- ¥ Constraints Run
- Manage Constraints  Clean and Run Al
T
teract
E Open Netlist Viewer r-| nteractively

Figure 40 - Launching pre-synthesis simulation

22. The simulation will run for 2.0 ms. When finished, the Wave window should appear as shown below after
selecting Zoom full from the popup menu (click right mouse button inside Wave — Default window).

om| wWave — [ >
il Edit View Add Format Tools Bookmarks Window Help
Wave - Default s ] e <]
|=8-=8-mm-a|

B-SsReS i 2B O- M || S2H R o d = B con-dEEBEs wmue||taris oo

| & mal ot 0] e 1 Be || 2 Tl % % f || e ag -3 ) seeren s e || e @ mn| L oW i
- s

£ ftestbench/Fabric_Top_0/DEVRST_N

£ ftestbench/Fabric_Top_0/USER_BTN

“a ftestbench/Fabric_Top_0/USER_LED
B ftestbench/Fabric_Top_0/LED

signals
4  ftestbench/Fabric_Top_0/SYSRESET_0/DEVRST_N
“a ftestbench/Fabric_Top_0/SYSRESET_0/POWER_ON_RESET_N
“# ftestbench/Fabric_Top_0/SYSRESET_0jreset_n_int
—— FCCC signals
~  ftestbench/Fabric_Top_0/05C_C0_0_RCOSC_25_S0MHZ_C...
~  [testbench/Fabric_Top_0/FCCC_CO_0_LOCK
“  ftestbench/Fabric_Top_0/FCCC_CO_0_GLO
—— count24 signals
< ftestbench/Fabric_Top_0/count24_0/CLK
[testbench/Fabric_Top_0/count24_0,/RESETn
Jtestbench/Fabric_Top_0/count24_0/Q

UL UL AU UL LT
IR RRATV AR YRR YTLELLLL ORULLLLLAORRTVTLELLL TV RELLLLLOONRNLBLLAIORNNLARRRVMLLRLLUNFVORRRRRTIVY

Bl I ] |
x¢|Find: | &8 | 4| E|t searchFor ~ | T @y @ ®
0 ps to 2025184275 ps Jtestbench fFabric_Top_0/DEVRST_N >

Figure 41 - ModelSim Wave window

23. Scroll in the wave window. The LED[7:0] port represents the LED driver (0 = LED off; 1 = LED on. The USER_LED
port is the re-directed Live Probe output. In the simulation this appears as a Hi-Z signal. When SmartDebug is
used, the output of any flip-flop can be re-directed to this output port.

24. Contact the lab instructor if your results do not match the figure above.

25. Close the ModelSim simulator (File > Quit). Click Yes when asked if you want to quit.
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Step 3 - Editing the I/0 Physical Constraint file
There are multiple ways to make I/O Assignments. In this lab we will use the I/O Physical Design Constraint (PDC) file
that was imported when the project was created. The I/O pdc file must be edited to match the target board.

1. Double-click Manage Constraints in the Libero SoC Design Flow window to open the Libero SoC Constraint
Manager.

4l

aFabnc_Top 5 X I Reports & X Constraint Manager & X | StartPage & X I
1/O Attributes | Timing I Floor Planner I Netlist Attributesl

MNew |V| Import | Link. | Edit |V| View | Check | Help | Save Discard |ﬂ ﬂ

|Placeand Route |
constraint\io\Fabric_Top.pdc O

- ¥ Reserve Pins for Device Migration

Select the devices you are targetting for migration. Pins not bonded on these devices will be reserved in the device selected for this project.
Selected Device: M25010 - 400 VF

[ M2s5025T
[ M2s025
TargetDevices: | [] M25010T
[ mM25003

—General

¥ Reserve Pins for Probes

Figure 42 - Libero SoC Constraint Manager

2. Select the Constraint Manager I/O Attributes tab. Double-click Fabric_Top.pdc to open the file in the Libero SoC
editor. Scroll in the file to become familiar with the syntax. The constraint set_iobank sets the input voltage of
the bank to determine the allowable I/O standards; the constraint set_io sets the pin number and 1/0 specific
attributes. The # symbol is a comment.

Reports & X | StartPage & % | Constraint Manager & X Fabric_Top.pdc & X | 5
¢ ==
1EJ# -
2 | # Company: Microsemi SoC Products Group
3|4
4 | # File: Fabric Top.pdc
5 | # File history:
6 | # Rev 1.0 July 25, 2016 Written for SF2 Fab Probe design
7| # Rev 2.0 March 1, 2017 Added pinouts for Future Creative boards
g | # Rev 2.1 May 8, 2017 Added pinouts for Avnet Kickstart board
9 |# Rev 2.2 Feb 22, 2018 Removed ES silicon
10 | #
11 | # Description:
12 | # PDC constraint file which sets the I/O bank voltage settings and
13 | # I/0 pin assignments for the Microsemi SmartFusion2 Fabric / Probe tutorial
14 | #
15 | # Author: Tim McCarthy
16 | #
17 | # Pin assignments for SF2-4B84-STARTER-KIT with M2S010-FGG484 device OR
18 | # SF2-STARTER-KIT with M25050-FGG484 device
19 | # Banks not listed use default setting of 2.5V
20 | #set_iobank Bank0 -vcci 1.80 -fixed yes
21 | #set_iobank Bankl -vcci 3.30 -fixed yes
22 | #set _iobank Bank2 —wvcci 3.30 -fixed yes
23 | #set igbank Bank3 —vcooi 3.30 —fixed ves 4'LI
4 »

Figure 43 - PDC file in the Libero SoC constraint editor

A description of the PDC constraints syntax is available in the Libero Help (Help > Help Topics > Manage
Constraints > Assigning Design Constraints > Design Constraints Guide > Reference > Constraints by File Format
> PDC Command Reference).
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For more information regarding pin assignments for the SmartFusion2 target board, refer to the schematic for
the board, which is available from the Trenz Electronic website (http://www.trenz-
electronic.de/fileadmin/docs/Trenz Electronic/Modules and Module Carriers/2.5x6.15/TEM0001/REV01/Docu
ments/SCH-TEMO0001-01-010C.PDF).

All assignments in the PDC file are commented out. Uncomment the lines starting with set_iobank and set_io.
Save the PDC file after making modifying (File > Save Fabric_Top.pdc).

Close the PDC file (File > Close Fabric_Top.pdc).

Enable (checkbox) Fabric_Top.pdc for Place and Route on the I/O Attributes tab of the Libero Constraint
Manager.

7. Press Save to store the change in the I/O Attributes constraint file selection.

ok w

Confirm saving of changes in warning notice (design flow invalidation) with OK.

EFabric_Tup g X l Reports & X Constraint Manager & X l StartPage & X l
Ifo Attril:uutesl 1/0 Attributes l Timing l Floar F‘Ianner]

Mew |v Import | Link: | Edit |v View | Check | Help |

Place and Route

: constraint\ic\Fabric_Top.pdc

Figure 44 - Selecting the 1/0 PDC constraint file in the Design Flow window
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Step 4 - Generating Timing Constraints

In this step you derive timing constraints for the design. Timing constraints for known blocks (such as the RC
oscillators and the PLLs) can be generated automatically.

1. Select the Timing tab in the Constraint manager window. Click on Derive Constraints.

Reports & X Constraint Manager & X | EFabric_Tnp g X | StartPage & X |
1/0 Attributes loor Planner | Metist Attributesl

Mew | Impart | Link | Edit |V| Checdk | Derive Cnnstraints onstraint Coverage |V| Help

Synthesis Place and Route | Timing Verification

Figure 45 - Deriving Timing Constraints

2. Click on Yes in the Message window to automatically associate the derived constraints SDC file to the ‘Synthesis’,
‘Place and Route’ and ‘Timing Verification’.

B Message x

To automatically associate the derived constraint SDC file to the 'Synthesis', 'Flace and Route' and Timing Verification' tools dick "fes' else dick Mo’

~ -

Yes No

Figure 46 - Message Window

3. Double click on the Top_derived_constraints.sdc to view the automatically generated clock constraints in the
text editor.

LfO Attributes  Timing | Floor Planner I Metlist .ﬁ.ttributesl

Mew | Import | Lirk. | Edit |"| Check |"| Derive Constraintsl Constraint Coverage |"| Help

Synthesis Place and Route | Timing Verification

constraint\Fabric_Top_derived_constraints.sdc

Figure 47 - Derived Timing Constraints

4. For this design a Clock constraint and Generated Clock constraint are generated automatically. The Clock
constraint is the constraint for the 50 MHz RC oscillator, which is the reference clock for the fabric CCC. The
Generated Clock constraint is the constraint for the 1 MHz Fabric PLL output.

Fobeic_Top_derved_constromts.sde @ X ] Reports @ X | StatPoge 8% |  Constraint Manager & % |

2
~ )
s

Microsemi Corp.

U S W N

#
§
]
L]
L]
]
$

) -] O

9 create clock -name {OSC 0/1 F
U create generated clock
set_false path -ignore errors -th

iod 2 [ get_pins { OSC_0/I
-divide by 100 -

¥ 2 s
SYSRESET _0/POWER_ON RESET N } ]

_25_SOMHZ/CLKOUT } ]

FOCC_0/CCC_INST/ROOSC_25_SOMHZ |

Y

Figure 48 - Derived timing constraints

5. Close the Constraint Manager Editor (File > Close Fabric_Top_derived_constraints.sdc).
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Step 5 - Synthesis and Layout

In this step you will use the push-button flow to synthesize the design with Synplify Pro, run layout and generate the

programming file.

1. Double-click the Generate Bitstream in the Design Flow window to synthesize the design, run layout using the
I/0 constraints that were created and generate the programming file.

Design Flow

Top Medule(root): Fabric_Top E o .!
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Figure 49 - Generate Bitstream

The design implementation tools will run in batch mode. Successful completion of a design step will be indicated
by a green check mark next to the item in the Design Flow window.
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Figure 50 — Successful completion of design implementation

2. The Reports tab will display reports for the tools used to implement the design.
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Figure 51 - Reports tab after implementing the design
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3. Select the Compile report (Fabric_Top_compile_netlist_resources.xml) under Synthesize on the Reports tab to
view the resource usage. Record the number of combinatorial cells (LUTs) and sequential cells (Flip-flops) used

in the design below.

LUTs (4LUT)

Flip-flops (DFF)

4. Configure the timing reports to be generated by right-clicking Verify Timing under Verify Post Layout
Implementation on the Design Flow tab and selecting Configure Options. Enable all available timing report

options and select OK.

&7 Verify Timing Configuration ?

Reports | Reports Settings |

Timing Reports
[V Max delay analysis using Slow process at 1.14¥ and 85C
[¥ Min delay analysis using Fast process at 1.26V and 0C
[¥ Max delay analysis using Fast process at 1.26V and 0C
[ Min delay analysis using Slow process at 1,14V and 85C
[¥ Max delay analysis Multi Corner Repart
¥ Min delay analysis Multi Comner Report
Tining Vioiations Reports
[V Max delay analysis using Slow process at 1.14v and 85C
[¥ Min delay analysis using Fast process at 1,26V and 0C
[¥ Max delay analysis using Fast process at 1.26V and 0C

¥ Min delay analysis using Slow process at 1. 14V and 85C

[V Mav delav analvsis Multi Carner Benart

H|

Help

Figure 52 - Timing reports configuration

5. Generate the timing reports by right-clicking Verify Timing under Verify Post Layout Implementation on the
Design Flow tab and selecting Run.

Design Flow g x
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Figure 53 - Generating the post-layout timing report

Help

6. Select the timing report named Fabric_Top_max_timing_slow_1.14V_85C.xml under Verify Timing on the
Reports tab. Scroll to the timing Summary in the Report window. Record the maximum frequency for the clock

FCCC_0/ GLO below:

FCCC_0/ GLO:

7. Timing violations can quickly be identified by looking at the timing violations reports
(Fabric_Top_max/min_timing_violations_slow_1.14V_85C.xml and
Fabric_Top_max/min_timing_violations_fast_1.26V_0C.xml).

8. The output files from Synplify Pro and Designer (Place&Route, Timing Analyzer) will be visible on the Libero SoC

Files tab.
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Figure 54 - Synthesis and Designer files on Libero SoC Files tab
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Step 6 - Programming

In this step, you will run FlashPro in batch mode to program the SmartFusion2 device on the SmartFusion2 target
board. Connect the SMF2000 board using a Micro-USB cable to the PC USB port (board power is provided from PC
USB port). Since the FlashPro5 driver should be already installed by the Microsemi Libero SoC v12.5 installation, the
Window’s Device Manager should display the following entries (port number may differ depending on your PC):

& Device Manager
File Action View Help
o9 | m Hm e

® Cameras

[ Computer

w Disk drives

[l Display adapters

B Firmware

8 Human Interface Devices

2 Keyboards

@ Mice and other pointing devices

@@ Monitors

3 Network adapters
v i PogslcObiiiulll)
niversa grout rontrollers
§ Generic SuperSpeed USB Hub
§ Generic USB Hub

§ USB FPS Serial Converter A
i USB FP5 Serial Converter B

SOt HuUb (U =)

oes ETOSE
§ USB Root Hub (USB 3.0)

Figure 55 — Device Manager
1. Expand Program Design in the Design Flow window. Right-click Run PROGRAM Action and select Run to begin
programming.
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+
v = Implement Design
] Program and Debug Design
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Create Design
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rvww

b Debug Design
" Identify Debug Design  Clean and Run Al
@‘ SmartDebug Design

Handoff Design for Production

4 Export Bitstream

-@ Export FlashPro Express Job

4 Export Job Manager Data

+L] Export Pin Report
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| Export IBIS Model

Handoff Design for Firmware Development

& Configure Firmware Cores

B: Export Firmware
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T
-

Select Action...

Help

T
-

Design Flow | Design Hierarchy I Stimulus Hierarchy I Catalog J Files

Figure 56 - Launching Programming software from Design Flow window

2. FlashPro will run in batch mode and program the device. Programming messages will be visible in the Libero SoC
log window (programmer number and device number may differ).

Note: Do not interrupt the programming sequence; it may damage the device or the programmer.
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3. The following message should be visible in the Reports view under Program Device when the device is
programmed successfully (programmer number will differ; device will differ depending on the target board):

programmer 'E2002BYKIN' : device 'M25010' : Executing action PROGRAM PASSED.

[E]an €3 o0Errors & 1warning &0 0Info

Software Version: 12.500.10.16
Programmer: 'E2002BYKIN' : JTAG TCK / SPI SCK frequency = 1 MHz

programmer 'E2002BYKIN' : FlashProS

Opened 'C:\Microsemiprj\SF2_Fab_Probe\SmartFusion2_Fabric\designer\Fabric_Top\Fabric_Top_fp\Fabric_Top.pro’
The 'open project' command succeeded.
= = ,

The "enable device' command succeeded.

PPD file 'C:/Microsemipr3/SF2_Fab_Probe/SmarcFusion2 Fabric/designer/Fabric Top/Fabric Top.ppd' has been loaded successfully.
DESIGN : Fabric Top; CHECKSUM : 3481; PDB _VERSION : 1.0

The 'set_programming file' command succesded.

The 'set_programming_action' command succeeded.

programmer 'E2002BYKIN' : Scan Chain...

Programmer: 'E2002BYKIN' : JTAG TCK / SPI SCK frequency = 1 MHz

programmer "EZ002BYKIN®" : Check Chain...

programmer 'E2002BYKIN' Scan and Check Chain PASSED.

amm.

programmer 'E2002BYKIN' : dewice 'M25010' : Executing action PROGRAM
Programmer: 'E2002BYKIN' : JTAG TCK / SPI SCK frequency = 4 MHz

programmer 'E2002BYKIN' : device 'M25010' : Family: Igloo2

programmer 'E2002BYKIN' device 'M2S010°" Product: M2GLOOS

programmer 'E2002BYKIN' device 'M2S010°" Cortex-M3 Disabled (M3_ALLOWED = O

programmer 'E2002BYKIN' device 'M25010' : EXPORT ISC ENASBLE RESULT[32] = 007=6b44

programmer 'E2002BYKIN' device 'M25010' : EXPCRT CRCERR[1] = O

programmer 'E2002BYKIN' device 'M25010' : EXPCRT EDCERR[1] = O

programmer 'E2002BYKIN' device 'M25010° Programming FPGA Array. .

programmer 'E2002BYKIN' device 'M2S010' : EXPORT Fabric component digest[256] = 1£630438dec0ldféc23396c6cabdd467£c29743d8367delb0
programmer 'E2002BYKIN' device 'M2S010°"

programmer 'E2002BYKIN' device 'M2S010' : EXPORT DSN[128] = Telff526%elf523ac77705de6ddssTca

programmer 'E2002BYKIN' device 'M25010°"

programmer "E2002BYKIN device 25010 nished: Thu Oct 1 14:24:07 2020 (Elapsed time 00:00:26)

The 'run selected actions' command succesded.
Project saved.

The 'save_project' command succesded.

Project closed.

Exported log file C:\Microsemiprj\SF2_Fab Probe\SmartFusion2_Fabric\designer\Fabric_Top\Fabric Top_ fp\Fabric_Top.log.
The 'close_project' command succeesded.

The Execute Script command succesded.

Figure 57 - Programming messages in Libero SoC log window

4. A green check mark will appear next to Program Design and Run PROGRAM Action in the Design Flow window to
indicate programming completed successfully.
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= »  Debug Design
Q Identify Debug Design
é SmartDebug Design
Handoff Design for Production
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@ Export FlashPre Express Job
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Figure 58 - Design Flow window after programming
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Running the Application
5. Reset the board by pressing and releasing the Reset button (the button on the opposite side of the LEDs) and
observe the pattern of the LEDs.

6. Pressthe USER_BTN (the button near the 8 LEDs) and observe the counter changing the count direction.

Step 7 - Debugging with SmartDebug

In this step you will use SmartDebug to view internal circuits in the design.

SmartDebug tool is a new approach to debug the Microsemi FPGA array and SERDES without using an internal logic
analyzer (ILA). SmartDebug provides the following methods to debug the SmartFusion2 / IGLOO2 FPGA array:

e Live Probe: Two dedicated probes can be configured to observe a Probe Point which is any input or output of a
logic element. The probe data can then be sent to an oscilloscope or logic analyzer.

e Active Probe: Active Probe allows dynamic asynchronous read and write to a flip-flop or probe point. This
enables a user to quickly observe the output of the logic internally or to quickly experiment on how the logic will
be affected by writing to a probe point.

e Memory Debug: Memory debug is used to debug embedded FPGA fabric memories (USRAM and LSRAM) by
reading and writing to the memory block. Memory Debug also supports reading eNVM memory content.

e Probe Insertion: Probe insertion is used to insert probes into the design and bring signals out to the FPGA
package pins to evaluate and debug the design.

e SERDES Debug: SmartDebug is used to debug high speed serial interfaces by utilizing on-chip PRBS features and
signal integrity controls.

e FPGA Hardware Breakpoint: Enables single stepping and synchronous signal capture capabilities on selected
clock domains. Available for logic running on an internally generated PLL clock (clock gating logic will be added).
See Project settings “Enable FPGA Hardware Breakpoint Auto Instantiation”.
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SmartDebug Live Probes

In this step we will use Live Probe A to drive one of the LEDs on the target board. The LIVE_PROBE_FB macro re-
directs the Live Probe output. For this design we connected the PROBE_A output of the LIVE_PROBE_FB macro to an
output pin which is connected to the USER_LED on the target board.

1. Expand Debug Design in the Libero Design Flow window. Select SmartDebug Design then right-click and select
Open Interactively.

Design Flow & X
Top Module(root): Fabric Top O Q o
Active Synthesis Implementation: synthesis

[Too! |
» Create Design
» Constraints
v » Implement Design
= » Program and Debug Design
v -+ Generate FPGA Array Data

B @ Update eMVM Memory Content
&+ b Configure Hardware
-l Programming Connectivity and Interface
-~ @k Configure Programmer
@ Select Programmer
"l Configure 10 States During ITAG Programming
»é-, Configure Programming Options
@ Configure Security
v E- # Program Design
v % Generate Bitstream
& Configure Actions and Procedures
v -G Run PROGRAM Action
|

£ b Debug Design

2 T SmartDebug Design
= » Handoff Design for Production [0 pn il
48] Export Bitstream s
'@ Export FlashPro Express Job
- 4] Bxport Job Manager Data
+] Export Pin Report
-+ Export BSDL
-+ Export IBIS Model
E »  Handoff Design for Firmware Development
Configure Firmware Cores
- B Export Firmware
= »  Handoff Design for Debugging
"€ Export SmartDebug Data

Help

Design Flow | _Design Hierarchy | Stimulus Hierarchy | Catalog | Files |

Figure 59 - Launching SmartDebug

2. The SmartDebug GUI will open. Click the Debug FPGA Array button (circled in the figure below). The Debug
SERDES option may not be available for some target boards.

€ SmartDebug — O *
File View Help

Device: IMzSD 10 (M25010) j Programmer: |[E2002BYK 1M (E2002BYK 1M) j

ID code read from device: 3F8031CF

Project Checksum (DDC) :3481

View Device Status... | Debug FPGA Array...

View Flash Memory Content... |

Log [
E]Messages QErrors ¥, Warnings OInfo
Programmer: 'E2002BYK1IN' : JIAG TCK / SPI S5CK freguency = 1 MHz
Programmer: 'E2002BYK1IN' : JIAG TCK / SPI S5CK freguency = 1 MHz
Programmer: 'EZ002BYEIN' : JTAG TCK / SPI SCK freguency = 1 MHz

Figure 60 - SmartDebug GUI
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4. Select the Live Probes tab in the Debug FPGA Array GUI. The design hierarchy is displayed in the left window.
Signals selected for probing are displayed in the right window.

r h
] Debug FPGA Array [E=EER
LivefActive Probes Selection 8 X FPGA Array debug data
Hierarchical View Metlist View Live Probes Active Probes Memory Blocks Probe Insertion
Filter: Delete Delete Al
Tnstance(s): tome e
Instance Tree
[»
Assign to Channel A -
Assign to Channel B -
Unassign Channels
b

Figure 61 - SmartDebug Live Probes tab

5. Select count24_0 in the Instance Tree on the Hierarchical View then click Add. The signals will appear in the Live

Probes tab.
€0 Debug FPGA Array - O >
=1
Live/Active Probes Selection & X —FPGA Array debug data

Hierarchical View | Netlist View | Live Probes | Active Probes | Memory Blocks | Probe Insertion I

Filter: I search | Save... I Load... | Delete | Delete Al

MName Type -
Instance(s): Add >
LED_c[0]:count24_0/Q_int[16]:Q

Y me—
< [+ ¥ count24_0 ’

count24_0/Q_int_1[15]:count24_0/Q_int[15]:Q

DFF

count24_0/Q_int_1[14]:count24_0/Q_int[14]:Q

DFF

count24_0/Q_int_1[13]:count24_0/Q_int[13]:Q

Assign to Channel B | -

AssignhoChanneIAl -» LED_c[2]:count24 0/Q_int[18]:Q

DFF Ad|
Unassign |
Unassign |

Help |

Close |

Figure 62 - count24_0 signals in the Live Probes tab

6. Select the signal LED_c[0]:count24_0/Q_int[16]:Q then click Assign to Channel A.

7. The USER_LED starts blinking.

Note: the USER_LED is located directly next to the USB connector.
8. Select a different signal and assign it to Channel A. Observe the change in the LED patterns. Live Probe allows
observation of any flip-flop output without having to re-run layout on the design.
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SmartDebug Active Probes

In this step, we will use the Active Probes to observe the output of count_24_0.

10.

Signals selected for probing are displayed in the right window.

'@ Debug FPGA Array

a AS\MicrocHIP company

Select the Active Probes tab in the Debug FPGA Array GUI. The design hierarchy is displayed in the left window.

=1

Live Active Probes Selection

g X

Hierarchical View | Metlist View

Filter: |

Instance(s):

Search |

Add

—FPGA Array debug data

Live Probes Active Probes | Memory Blocks | Probe Inserﬁonl

_I ﬂ ﬂ LI Save... | Load...

Delete

| Delete Al |

+
Mame

= [Type |Read Value

Read Active Probes | Save Active Probes' Data... | Write Active Probes |

[Wirite Value |

Help |

Close |

11.

Active Probes tab.

'@ Debug FPGA Array

Figure 63 - SmartDebug Active Probes tab

Select count24 0 in the Instance Tree on the Hierarchical View then click Add. The signals will appear in the

- O X
Live/Active Probes Selection —FPGA Array debug data
Hierarchical View | Netlist View I Live Probes Active Probes | Memory Blocks I Probe Insertion I
Filter: | Search | ‘|'| —| 1‘| §| Save... | Load... Delete | Delete Al
Mame ~ |Type Read Value \Write Value
F#HLED_c[7:0] DFF Unread gh
- 3 count24_0 - count24_0/Q_int_1[15:0] DFF Unread 18'h

Read Active Probes | Sawve Active Probes' Data... | Write Active Probes |

Help |

Close |

Figure 64 - Adding the count24_0 signals to the Active Probes tab
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12. Click the Read Active Probes button (circled in the figure below). The state of the signal will be displayed.
Clicking Read Active Probes repeatedly will allow observation of the counter output.

€ Debug FPGA Array = O X
If=|
Live /Active Probes Selection [ —FPGA Array debug data
Hierarchical View | Netlist View Live Probes Active Probes | Memory Blocks | Probe Insertion I
Filter: | Search | ‘|'| —| 1+ | + | Save... | Load... | Delete | Delete Al
Mame = [Type Read Value Write Value
Ere=gE #{LED_c[7:0] DFF 3hes gh
[+ I count24 0 [+ count24_0/Q_int_1[15:0] DFF 16'hD493 16'h

‘ Read Active Probes

- —

¥ave Active Probes' Data. .. I Write Active Probes |
p—

Help |

Figure 65 - Reading the counter with the Active Probes

Close |

)

13. Click Close to close the Debug FPGA dialog box. Click Cancel when prompted about saving the active probes.
14. Close SmartDebug (File > Exit) and Libero SoC (Project > Exit).

End of SmartFusion2 Fabric lab
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Record answers to questions below

Name:

Page 31
Record the number of combinatorial and sequential cells used in the design below.

LUTs (4LUT)

Flip-flops (DFF)

Record the maximum frequency for the clock FCCC_0/ GLO below:

FCCC_0/ GLO:
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Answers to Questions (results can slightly vary on your system)

Page 31
Record the number of sequential and combinatorial cells used in the design below.

4LUT 25
DFF 24

Record the maximum frequency for the clock FCCC_0/GLO below:

FCCC_0/ GLO: 430.108 MHz
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